aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-11 12:58:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-11 12:58:15 +0000
commit6bea222dd544c13b0d0ff0e10a800e8fe4e6e3ef (patch)
tree640eefc8790cf5d029a454e99a11abbf25a22250 /graphics
parent44af1c525ca5f363f2602fbbd358ad63ee752566 (diff)
downloadports-6bea222dd544c13b0d0ff0e10a800e8fe4e6e3ef.tar.gz
ports-6bea222dd544c13b0d0ff0e10a800e8fe4e6e3ef.zip
Fix a place where Mesa looks for mesa.conf - it should be ${PREFIX}/etc/mesa.conf,
not /etc/mesa.conf. PR: 17678 Submitted by: Mario Sergio Fujikawa Ferreira <lioux@uol.com.br>
Notes
Notes: svn path=/head/; revision=32516
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Mesa3/Makefile3
-rw-r--r--graphics/Mesa3/files/patch-ae11
-rw-r--r--graphics/mesagl/Makefile3
-rw-r--r--graphics/mesagl/files/patch-ae11
4 files changed, 28 insertions, 0 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index 6a3ab8afd701..6b17ab4fe2e6 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -53,6 +53,9 @@ MAKE_ENV+= SUB_GL=${SUB_GL} \
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+post-configure:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/config.c
+
post-install:
.for lib in GL GLU
@${LN} -sf ${PREFIX}/lib/lib${lib}.so ${PREFIX}/lib/libMesa${lib}.so
diff --git a/graphics/Mesa3/files/patch-ae b/graphics/Mesa3/files/patch-ae
new file mode 100644
index 000000000000..295ebbb601f6
--- /dev/null
+++ b/graphics/Mesa3/files/patch-ae
@@ -0,0 +1,11 @@
+--- src/config.c 2000/09/11 12:25:04 1.1
++++ src/config.c 2000/09/11 12:25:27
+@@ -406,7 +406,7 @@
+ #if defined(__WIN32__) || defined(__MSDOS__)
+ const char *filename = "mesa.cnf";
+ #else
+- const char *filename = "/etc/mesa.conf";
++ const char *filename = "%%PREFIX%%/etc/mesa.conf";
+ #endif
+ FILE *file;
+ struct cnode *list;
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index 6a3ab8afd701..6b17ab4fe2e6 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -53,6 +53,9 @@ MAKE_ENV+= SUB_GL=${SUB_GL} \
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+post-configure:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/config.c
+
post-install:
.for lib in GL GLU
@${LN} -sf ${PREFIX}/lib/lib${lib}.so ${PREFIX}/lib/libMesa${lib}.so
diff --git a/graphics/mesagl/files/patch-ae b/graphics/mesagl/files/patch-ae
new file mode 100644
index 000000000000..295ebbb601f6
--- /dev/null
+++ b/graphics/mesagl/files/patch-ae
@@ -0,0 +1,11 @@
+--- src/config.c 2000/09/11 12:25:04 1.1
++++ src/config.c 2000/09/11 12:25:27
+@@ -406,7 +406,7 @@
+ #if defined(__WIN32__) || defined(__MSDOS__)
+ const char *filename = "mesa.cnf";
+ #else
+- const char *filename = "/etc/mesa.conf";
++ const char *filename = "%%PREFIX%%/etc/mesa.conf";
+ #endif
+ FILE *file;
+ struct cnode *list;