aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-02 15:10:04 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-02 15:10:04 +0000
commitf56d5946acdfa6a488c90cf18e58a79a192d4297 (patch)
tree58410cb906716be3fb5ee40ad2f9132b1bb9196b /graphics
parentf7c47523107ff8fcdd94d21c8189f15407c4df63 (diff)
downloadports-f56d5946acdfa6a488c90cf18e58a79a192d4297.tar.gz
ports-f56d5946acdfa6a488c90cf18e58a79a192d4297.zip
Add new gle port.
GLE is a library of C functions that draw extruded surfaces, including surfaces of revolution, sweeps, tubes, polycones, polycylinders and helicoids. GLE uses the OpenGL(R) API to perform the actual rendering. PR: 20931 Submitted by: David Gilbert <dgilbert@velocet.ca>
Notes
Notes: svn path=/head/; revision=32210
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gle/Makefile31
-rw-r--r--graphics/gle/distinfo1
-rw-r--r--graphics/gle/pkg-comment1
-rw-r--r--graphics/gle/pkg-descr14
-rw-r--r--graphics/gle/pkg-plist4
6 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 413e32d699bb..d222595e6b9e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -52,6 +52,7 @@
SUBDIR += gimp-manual-ps
SUBDIR += gimp1
SUBDIR += giram
+ SUBDIR += gle
SUBDIR += gltk
SUBDIR += gnofract4d
SUBDIR += gnomeiconedit
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
new file mode 100644
index 000000000000..fc3bbc0726b7
--- /dev/null
+++ b/graphics/gle/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: GLE
+# Date created: 29 August 2000
+# Whom: David Gilbert <dgilbert@velocet.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gle
+PORTVERSION= 3.0.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://linas.org/gle/ \
+ http://metalab.unc.edu/pub/Linux/libs/X/ \
+ ftp://tsx-11.mit.edu/pub/linux/sources/libs/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dgilbert@velocet.ca
+
+USE_X_PREFIX= yes
+USE_MESA= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= "LIBS=-L${X11BASE}/lib -lXext"
+
+MAN3= gle.3gle gleExtrusion.3gle gleHelicoid.3gle gleLathe.3gle \
+ glePolyCone.3gle glePolyCylinder.3gle gleScrew.3gle \
+ gleSetJoinStyle.3gle gleSetNumSides.3gle gleSpiral.3gle \
+ gleSuperExtrusion.3gle gleTextureMode.3gle gleToroid.3gle \
+ gleTwistExtrusion.3gle
+
+.include <bsd.port.mk>
diff --git a/graphics/gle/distinfo b/graphics/gle/distinfo
new file mode 100644
index 000000000000..fae556eae936
--- /dev/null
+++ b/graphics/gle/distinfo
@@ -0,0 +1 @@
+MD5 (gle-3.0.1.tar.gz) = c335223b9c4a076426129f3ff4e9c939
diff --git a/graphics/gle/pkg-comment b/graphics/gle/pkg-comment
new file mode 100644
index 000000000000..99047bbf0cce
--- /dev/null
+++ b/graphics/gle/pkg-comment
@@ -0,0 +1 @@
+A GL Tubing and Extrusion Library
diff --git a/graphics/gle/pkg-descr b/graphics/gle/pkg-descr
new file mode 100644
index 000000000000..0b295b89d54b
--- /dev/null
+++ b/graphics/gle/pkg-descr
@@ -0,0 +1,14 @@
+The GLE Tubing and Extrusion Library is a graphics application
+programming interface (API). The library consists of a number of "C"
+language subroutines for drawing tubing and extrusions. The library is
+distributed in source code form, in a package that includes
+documentation, a VRML proposal, Makefiles, and full source code and
+header files. It uses the OpenGL (TM) programming API to perform the
+actual drawing of the tubing and extrusions.
+
+
+WWW: http://linas.org/gle/
+ http://sourceforge.net/projects/gle/
+
+- David Gilbert
+dgilbert@velocet.ca
diff --git a/graphics/gle/pkg-plist b/graphics/gle/pkg-plist
new file mode 100644
index 000000000000..ad2b00723519
--- /dev/null
+++ b/graphics/gle/pkg-plist
@@ -0,0 +1,4 @@
+include/GL/gle.h
+lib/libgle.so.3
+lib/libgle.so
+lib/libgle.a