aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-02-24 00:54:30 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-02-24 00:54:30 +0000
commit270ffd602c955e81bb838b0c8e60b659bb16e8d9 (patch)
tree83bd61a841bb4d87440fb7691bd0e9d623ea09ae /graphics
parent5e477ed87f8359d53db426ef08b70c8ef2e80e7a (diff)
downloadports-270ffd602c955e81bb838b0c8e60b659bb16e8d9.tar.gz
ports-270ffd602c955e81bb838b0c8e60b659bb16e8d9.zip
gltk is a simple OpenGL and Tk interface used in the OpenGL
tutorial in http://www.eecs.tulane.edu/www/Terry/OpenGL/Introduction.html Reviewed by: Will Andrews <andrews@TECHNOLOGIST.COM>
Notes
Notes: svn path=/head/; revision=26225
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gltk/Makefile28
-rw-r--r--graphics/gltk/distinfo1
-rw-r--r--graphics/gltk/pkg-comment1
-rw-r--r--graphics/gltk/pkg-descr9
-rw-r--r--graphics/gltk/pkg-plist3
6 files changed, 43 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 60138e2e1f1f..0cd66cab22ce 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -49,6 +49,7 @@
SUBDIR += gimp1
SUBDIR += gimp1-i18n
SUBDIR += giram
+ SUBDIR += gltk
SUBDIR += glx
SUBDIR += gnofract4d
SUBDIR += gnomeiconedit
diff --git a/graphics/gltk/Makefile b/graphics/gltk/Makefile
new file mode 100644
index 000000000000..0048d96f0413
--- /dev/null
+++ b/graphics/gltk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gltk
+# Version required: 1.0
+# Date created: 16 Feb 2000
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+DISTNAME= libtk
+PKGNAME= gltk-1.0
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.sgi.com/opengl/contrib/ \
+ ftp://ftp.u-aizu.ac.jp/pub/os/sgi/misc/ftp.sgi.com/pub/opengl/contrib/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
+
+USE_IMAKE= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libtk.a ${PREFIX}/lib/libgltk.a
+ ${INSTALL_DATA} ${WRKSRC}/tk.h ${PREFIX}/include/GL/gltk.h
+ ${MKDIR} ${PREFIX}/share/doc/gltk
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gltk
+
+.include <bsd.port.mk>
diff --git a/graphics/gltk/distinfo b/graphics/gltk/distinfo
new file mode 100644
index 000000000000..43130a8fa3f8
--- /dev/null
+++ b/graphics/gltk/distinfo
@@ -0,0 +1 @@
+MD5 (libtk.tar.Z) = 369e0a9c3b6669ebb3a17a286b21c7ab
diff --git a/graphics/gltk/pkg-comment b/graphics/gltk/pkg-comment
new file mode 100644
index 000000000000..ec3c7021c9ef
--- /dev/null
+++ b/graphics/gltk/pkg-comment
@@ -0,0 +1 @@
+An OpenGL/Tk interface
diff --git a/graphics/gltk/pkg-descr b/graphics/gltk/pkg-descr
new file mode 100644
index 000000000000..8ae356821931
--- /dev/null
+++ b/graphics/gltk/pkg-descr
@@ -0,0 +1,9 @@
+A simple OpenGL and Tk interface used for the OpenGL tutorial in
+
+ http://www.eecs.tulane.edu/www/Terry/OpenGL/Introduction.html
+
+Other than changing "-lMesatk" to "-lgltk" and "#include <gltk.h>" to
+"#include <GL/gltk.h>", everything should work as described on that page.
+
+- Satoshi
+asami@FreeBSD.org
diff --git a/graphics/gltk/pkg-plist b/graphics/gltk/pkg-plist
new file mode 100644
index 000000000000..96e10410e67b
--- /dev/null
+++ b/graphics/gltk/pkg-plist
@@ -0,0 +1,3 @@
+include/GL/gltk.h
+lib/libgltk.a
+share/doc/gltk/README