aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-20 13:51:47 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-20 13:51:47 +0000
commit318a5369821d1ba2650a4e69e5704cc5c8005f80 (patch)
tree9659071bd68c2b4ba413daf4ff08a9d97a6c480e /graphics
parent10a7fbab572e96a3c7b449944567c3375b5bb069 (diff)
downloadports-318a5369821d1ba2650a4e69e5704cc5c8005f80.tar.gz
ports-318a5369821d1ba2650a4e69e5704cc5c8005f80.zip
Define USE_PERL to make Perl available for (mostly deprecated)
"perl -pi -e" construction.
Notes
Notes: svn path=/head/; revision=94465
Diffstat (limited to 'graphics')
-rw-r--r--graphics/backfract/Makefile1
-rw-r--r--graphics/enfle/Makefile1
-rw-r--r--graphics/gtkgraph/Makefile1
-rw-r--r--graphics/pvmpov/Makefile1
-rw-r--r--graphics/py-opengl/Makefile1
-rw-r--r--graphics/utah-glx/Makefile1
-rw-r--r--graphics/xli/Makefile1
-rw-r--r--graphics/xmandel/Makefile1
-rw-r--r--graphics/xv/Makefile1
9 files changed, 9 insertions, 0 deletions
diff --git a/graphics/backfract/Makefile b/graphics/backfract/Makefile
index 33b133027d61..4a011e1caef2 100644
--- a/graphics/backfract/Makefile
+++ b/graphics/backfract/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= patrick@FreeBSD.org
COMMENT= Fractal image animated wallpaper program
GNU_CONFIGURE= yes
+USE_PERL= yes
USE_X_PREFIX= yes
NO_INSTALL_MANPAGE= yes
ALL_TARGET= # none
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 33c155dc163b..6bc91f836f23 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
+USE_PERL= yes
CONFIGURE_ARGS= --enable-all-plugins \
--enable-plugins-dir \
--enable-loader=ungif \
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 2ab4afaa1678..2d21c59b322f 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= imlib
+USE_PERL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/graphics/pvmpov/Makefile b/graphics/pvmpov/Makefile
index 61e58ccfeda2..fc98e6446101 100644
--- a/graphics/pvmpov/Makefile
+++ b/graphics/pvmpov/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/povray31:configure \
RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray31 \
pvmd:${PORTSDIR}/net/pvm
+USE_PERL= yes
USE_XLIB= yes
WRKSRC= ${WRKDIR}/pvmpov3_1e_2
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 446c8e249ba5..27e7209d1b54 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+USE_PERL= yes
USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/graphics/utah-glx/Makefile b/graphics/utah-glx/Makefile
index 64b4fc47034b..b6d855599f51 100644
--- a/graphics/utah-glx/Makefile
+++ b/graphics/utah-glx/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
autoconf:${PORTSDIR}/devel/autoconf
USE_X_PREFIX= yes
+USE_PERL= yes
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/graphics/xli/Makefile b/graphics/xli/Makefile
index ded7544de590..aed913c38f9c 100644
--- a/graphics/xli/Makefile
+++ b/graphics/xli/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_IMAKE= yes
+USE_PERL= yes
MAN1= xli.1 xlito.1
post-patch:
diff --git a/graphics/xmandel/Makefile b/graphics/xmandel/Makefile
index e63db99fae80..053d3320105e 100644
--- a/graphics/xmandel/Makefile
+++ b/graphics/xmandel/Makefile
@@ -21,6 +21,7 @@ EXTRACT_CMD= ${SH}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= # empty
USE_IMAKE= yes
+USE_PERL= yes
NO_WRKSUBDIR= yes
MAN1= xmandel.1
diff --git a/graphics/xv/Makefile b/graphics/xv/Makefile
index be68effaa5eb..7e82b3f4c45e 100644
--- a/graphics/xv/Makefile
+++ b/graphics/xv/Makefile
@@ -41,6 +41,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_IMAKE= yes
+USE_PERL= yes
.if !defined(NOMAN)
MAN1= bggen.1 vdcomp.1 xcmap.1 xv.1 xvp2p.1
.endif