aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
commitae994c8ea8a59644c1a1406b0b6547826bc12791 (patch)
tree396acb34b10ac8f349be827c6eb833e0fd68cdff /graphics
parent2c5b5e25ddd43be1ce0fe90095ab5746c431b5b4 (diff)
downloadports-ae994c8ea8a59644c1a1406b0b6547826bc12791.tar.gz
ports-ae994c8ea8a59644c1a1406b0b6547826bc12791.zip
Use libtool port instead of included version to avoid objformat a.out botch
Notes
Notes: svn path=/head/; revision=183830
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Hermes/Makefile1
-rw-r--r--graphics/aalib/Makefile1
-rw-r--r--graphics/cinepaint/Makefile1
-rw-r--r--graphics/corona/Makefile1
-rw-r--r--graphics/freeglut/Makefile1
-rw-r--r--graphics/gdk-pixbuf/Makefile1
-rw-r--r--graphics/geos/Makefile1
-rw-r--r--graphics/giflib/Makefile1
-rw-r--r--graphics/gimp1/Makefile1
-rw-r--r--graphics/gle/Makefile1
-rw-r--r--graphics/gltt/Makefile1
-rw-r--r--graphics/goom/Makefile1
-rw-r--r--graphics/graphviz/Makefile2
-rw-r--r--graphics/gtkcairo/Makefile1
-rw-r--r--graphics/imlib/Makefile1
-rw-r--r--graphics/jasper/Makefile1
-rw-r--r--graphics/libart/Makefile1
-rw-r--r--graphics/libemf/Makefile1
-rw-r--r--graphics/libexif-gtk/Makefile2
-rw-r--r--graphics/libgltext/Makefile1
-rw-r--r--graphics/libmorph/Makefile1
-rw-r--r--graphics/libsvg-cairo/Makefile1
-rw-r--r--graphics/libsvg/Makefile1
-rw-r--r--graphics/libungif/Makefile1
-rw-r--r--graphics/libvisual-plugins/Makefile1
-rw-r--r--graphics/libwmf/Makefile1
-rw-r--r--graphics/libwmf/pkg-plist2
-rw-r--r--graphics/nurbs++/Makefile1
-rw-r--r--graphics/ogre312/Makefile1
-rw-r--r--graphics/ogre3d/Makefile1
-rw-r--r--graphics/ogre3d12/Makefile1
-rw-r--r--graphics/opencv/Makefile1
-rw-r--r--graphics/opencv/pkg-plist4
-rw-r--r--graphics/paintlib/Makefile1
-rw-r--r--graphics/qglviewer/Makefile1
-rw-r--r--graphics/sdl_gfx/Makefile1
36 files changed, 40 insertions, 2 deletions
diff --git a/graphics/Hermes/Makefile b/graphics/Hermes/Makefile
index 63c8cd993f13..1514ada1d6b7 100644
--- a/graphics/Hermes/Makefile
+++ b/graphics/Hermes/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast pixel formats conversion library
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/aalib/Makefile b/graphics/aalib/Makefile
index 7a8878a38cf4..24c04b674c5f 100644
--- a/graphics/aalib/Makefile
+++ b/graphics/aalib/Makefile
@@ -16,6 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= shaun@FreeBSD.org
COMMENT= An ascii art library
+USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}-1.4.0
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 414abae47f20..0a7221c732d1 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
lcms.1:${PORTSDIR}/graphics/lcms \
tiff.4:${PORTSDIR}/graphics/tiff
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/graphics/corona/Makefile b/graphics/corona/Makefile
index 54ee8ba64308..0cab374090ab 100644
--- a/graphics/corona/Makefile
+++ b/graphics/corona/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget lthack
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index 95e9ef0cabcd..64de29418338 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_XLIB= yes
diff --git a/graphics/gdk-pixbuf/Makefile b/graphics/gdk-pixbuf/Makefile
index c5f7018aa600..9d437738245f 100644
--- a/graphics/gdk-pixbuf/Makefile
+++ b/graphics/gdk-pixbuf/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME+= gnomehack gtk12
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index c7c55c23c1e2..4a71f1dc1a23 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -14,6 +14,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= saurbier@math.uni-bielefeld.de
COMMENT= GEOS implements all the OpenGIS "Simple Features for SQL"
+USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= YES
GNU_CONFIGURE= YES
diff --git a/graphics/giflib/Makefile b/graphics/giflib/Makefile
index e558dfdf5173..8e3eff68336e 100644
--- a/graphics/giflib/Makefile
+++ b/graphics/giflib/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Tools and library routines for working with GIF images
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/gimp1/Makefile b/graphics/gimp1/Makefile
index a3e163ce9f56..f7457c1841bc 100644
--- a/graphics/gimp1/Makefile
+++ b/graphics/gimp1/Makefile
@@ -35,6 +35,7 @@ CONFLICTS= gimp-2.* gimp-gnome-2.* gimpshop-[0-9]*
#SHLIBVER?= ${PORTVERSION:S/1.2.//g}
SHLIBVER?= 2
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_XLIB= yes
USE_XPM= yes
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
index bbb7d1767a14..54144fc61c71 100644
--- a/graphics/gle/Makefile
+++ b/graphics/gle/Makefile
@@ -19,6 +19,7 @@ COMMENT= A GL Tubing and Extrusion Library
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index 74d5020def1c..20220fc6fe43 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -16,6 +16,7 @@ COMMENT= TrueType fonts rendering using OpenGL
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_FREETYPE= yes
USE_GMAKE= yes
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index 38135ccc8007..19fabefb04aa 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -16,6 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Visual effects library
+USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 5b8aac13c396..19e8c656faef 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -28,7 +28,7 @@ USE_BISON= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_XPM= yes
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:15 libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
diff --git a/graphics/gtkcairo/Makefile b/graphics/gtkcairo/Makefile
index aef7093fbd6f..42fd9527e32a 100644
--- a/graphics/gtkcairo/Makefile
+++ b/graphics/gtkcairo/Makefile
@@ -17,6 +17,7 @@ COMMENT= Gtk+ bindings to cairo
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= gtk20 gnometarget gnomehack
USE_LDCONFIG= yes
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 8f1318feb98d..ae1993605d8d 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
ungif.5:${PORTSDIR}/graphics/libungif
+USE_AUTOTOOLS= libtool:15
USE_XLIB= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index 422c546c8771..f132a8247da8 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -18,6 +18,7 @@ COMMENT= An implementation of the codec specified in the JPEG-2000 standard
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_AUTOTOOLS= libtool:15
USE_ZIP= yes
USE_GNOME= gnometarget lthack
GNU_CONFIGURE= yes
diff --git a/graphics/libart/Makefile b/graphics/libart/Makefile
index bbeacf64f1ba..acb0194a1f43 100644
--- a/graphics/libart/Makefile
+++ b/graphics/libart/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://tiger.bioinf.cs.uni-potsdam.de/free/Graphics/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for high-performance 2D graphics
+USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}_lgpl-${PORTVERSION}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index 4283b07f1944..e07cb0cb83b8 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/libemf/g}
MAINTAINER= maho@FreeBSD.org
COMMENT= Enhanced Metafile Library
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/libexif-gtk/Makefile b/graphics/libexif-gtk/Makefile
index 770dc57b52fd..5949ae9380cb 100644
--- a/graphics/libexif-gtk/Makefile
+++ b/graphics/libexif-gtk/Makefile
@@ -18,7 +18,7 @@ COMMENT= GTK+ widgets to display/edit EXIF tags
LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
USE_GNOME= gnomehack gnometarget gtk20
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:259 libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index c290a4a8da3e..e3a0ca4ef511 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -17,6 +17,7 @@ COMMENT= Portable font rendering library for C++
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GL= yes
USE_GMAKE= yes
diff --git a/graphics/libmorph/Makefile b/graphics/libmorph/Makefile
index 16fc53de4be7..94f76f6411c8 100644
--- a/graphics/libmorph/Makefile
+++ b/graphics/libmorph/Makefile
@@ -16,6 +16,7 @@ COMMENT= A library for loading (and saving) 3d modeller object files
CONFLICTS= xmorph*
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/libsvg-cairo/Makefile b/graphics/libsvg-cairo/Makefile
index 2a5ddc68a709..adcb0e1ced15 100644
--- a/graphics/libsvg-cairo/Makefile
+++ b/graphics/libsvg-cairo/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
svg.1:${PORTSDIR}/graphics/libsvg \
cairo.2:${PORTSDIR}/graphics/cairo
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig gnometarget gnomehack
USE_LDCONFIG= yes
diff --git a/graphics/libsvg/Makefile b/graphics/libsvg/Makefile
index 1185d2a2cd3a..0188a81419b5 100644
--- a/graphics/libsvg/Makefile
+++ b/graphics/libsvg/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GNOME= libxml2 gnomehack gnometarget
USE_ICONV= yes
diff --git a/graphics/libungif/Makefile b/graphics/libungif/Makefile
index e558dfdf5173..8e3eff68336e 100644
--- a/graphics/libungif/Makefile
+++ b/graphics/libungif/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Tools and library routines for working with GIF images
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/libvisual-plugins/Makefile b/graphics/libvisual-plugins/Makefile
index a1efeaa9b120..a392207699c4 100644
--- a/graphics/libvisual-plugins/Makefile
+++ b/graphics/libvisual-plugins/Makefile
@@ -17,6 +17,7 @@ COMMENT= Set of plugins for the libvisual framework
LIB_DEPENDS= visual.0:${PORTSDIR}/graphics/libvisual
+USE_AUTOTOOLS= libtool:15
WANT_GNOME= yes
USE_GNOME= gnometarget pkgconfig
USE_XLIB= yes
diff --git a/graphics/libwmf/Makefile b/graphics/libwmf/Makefile
index 7a13355303a9..c8f789abe7e8 100644
--- a/graphics/libwmf/Makefile
+++ b/graphics/libwmf/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sys-gd=no \
diff --git a/graphics/libwmf/pkg-plist b/graphics/libwmf/pkg-plist
index 5dec8b234058..01d6830d39fc 100644
--- a/graphics/libwmf/pkg-plist
+++ b/graphics/libwmf/pkg-plist
@@ -30,9 +30,11 @@ include/libwmf/svg.h
include/libwmf/types.h
include/libwmf/x.h
lib/libwmf.a
+lib/libwmf.la
lib/libwmf.so
lib/libwmf.so.2
lib/libwmflite.a
+lib/libwmflite.la
lib/libwmflite.so
lib/libwmflite.so.7
%%PORTDOCS%%%%DOCSDIR%%/caolan/2.html
diff --git a/graphics/nurbs++/Makefile b/graphics/nurbs++/Makefile
index 19b2c3afecdb..60abbbec5b54 100644
--- a/graphics/nurbs++/Makefile
+++ b/graphics/nurbs++/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= libnurbs
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library for representing curves or surfaces
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name="s/x/x/"
USE_LDCONFIG= yes
diff --git a/graphics/ogre312/Makefile b/graphics/ogre312/Makefile
index cd361587c773..f9e3b0239a7d 100644
--- a/graphics/ogre312/Makefile
+++ b/graphics/ogre312/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-pl
--with-cppunit-prefix=/nonexistent
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
USE_GCC= 3.4+
USE_BZIP2= YES
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index cd361587c773..f9e3b0239a7d 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-pl
--with-cppunit-prefix=/nonexistent
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
USE_GCC= 3.4+
USE_BZIP2= YES
diff --git a/graphics/ogre3d12/Makefile b/graphics/ogre3d12/Makefile
index cd361587c773..f9e3b0239a7d 100644
--- a/graphics/ogre3d12/Makefile
+++ b/graphics/ogre3d12/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-pl
--with-cppunit-prefix=/nonexistent
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
USE_GCC= 3.4+
USE_BZIP2= YES
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 5f9012803231..3b99d2323719 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -17,6 +17,7 @@ DISTNAME= opencv-${PORTVERSION}
MAINTAINER= msabramo@yahoo.com
COMMENT= Open Source Computer Vision Library from Intel
+USE_AUTOTOOLS= libtool:15
HAS_CONFIGURE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/opencv/pkg-plist b/graphics/opencv/pkg-plist
index b87617409b1d..58d08f6b396c 100644
--- a/graphics/opencv/pkg-plist
+++ b/graphics/opencv/pkg-plist
@@ -1,17 +1,21 @@
bin/opencv-haartraining
bin/opencv-createsamples
bin/opencv-performance
+lib/libcv.a
lib/libcv.la
lib/libcv.so
lib/libcv.so.9
+lib/libcvaux.a
lib/libcvaux.la
lib/libcvaux.so
lib/libcvaux.so.9
lib/libcvhaartraining.a
+lib/libhighgui.a
lib/libhighgui.la
lib/libhighgui.so
lib/libhighgui.so.9
lib/libcxts.a
+lib/libcxcore.a
lib/libcxcore.la
lib/libcxcore.so
lib/libcxcore.so.9
diff --git a/graphics/paintlib/Makefile b/graphics/paintlib/Makefile
index eb0a63d00425..f88549363fcd 100644
--- a/graphics/paintlib/Makefile
+++ b/graphics/paintlib/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
tiff:${PORTSDIR}/graphics/tiff \
ungif:${PORTSDIR}/graphics/libungif
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-SDL --disable-dfb
diff --git a/graphics/qglviewer/Makefile b/graphics/qglviewer/Makefile
index a34654b02c11..58bab7cb2137 100644
--- a/graphics/qglviewer/Makefile
+++ b/graphics/qglviewer/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://www.gris.uni-tuebingen.de/projects/qglviewer/
MAINTAINER= ports@FreeBSD.org
COMMENT= Use OpenGL to play around with three dimensional scenes
+USE_AUTOTOOLS= libtool:15
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 5f6f932e5504..e70e79ee6bf1 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -18,6 +18,7 @@ DISTNAME= SDL_gfx-${PORTVERSION}
MAINTAINER= shaun@FreeBSD.org
COMMENT= SDL graphics drawing primitives and other support functions
+USE_AUTOTOOLS= libtool:15
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes