aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-05 01:36:52 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-05 01:36:52 +0000
commitb7c4f325f7f12895819798f61fdaaea112d7df81 (patch)
treecd965dcb3aa3408803fcd6d0eb6e984a48794042 /graphics
parent38f0112fc11e2b963a02106d06165a69d1c9e17a (diff)
downloadports-b7c4f325f7f12895819798f61fdaaea112d7df81.tar.gz
ports-b7c4f325f7f12895819798f61fdaaea112d7df81.zip
- Remove patch-src::f-spot.exe.config.in now that most dependant ports
use ltverhack. For the remianing two libraries just do the patching using REINPLACE_CMD in post-patch Project by: BSD# <http://www.mono-project.com/Mono:FreeBSD>
Notes
Notes: svn path=/head/; revision=155230
Diffstat (limited to 'graphics')
-rw-r--r--graphics/f-spot/Makefile7
-rw-r--r--graphics/f-spot/files/patch-src::f-spot.exe.config.in29
2 files changed, 6 insertions, 30 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index 2bcfa3a2d6b3..64cf6b73062d 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -8,7 +8,7 @@
PORTNAME= f-spot
PORTVERSION= 0.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.1
@@ -34,5 +34,10 @@ USE_GMAKE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} 's|target="liblcms.so.1"|target="liblcms.so"|g ; \
+ s|target="libexif.so.@EXIF_SOVERSION@"|target="libexif.so"|g' \
+ ${WRKSRC}/src/f-spot.exe.config.in
+
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/graphics/f-spot/files/patch-src::f-spot.exe.config.in b/graphics/f-spot/files/patch-src::f-spot.exe.config.in
deleted file mode 100644
index 69cfd83017e8..000000000000
--- a/graphics/f-spot/files/patch-src::f-spot.exe.config.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/f-spot.exe.config.in.orig Sun May 15 22:07:34 2005
-+++ src/f-spot.exe.config.in Sun May 15 22:07:40 2005
-@@ -1,14 +1,14 @@
- <configuration>
-- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
-- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
-- <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0.so.0"/>
-- <dllmap dll="libgdk-2.0-0.dll" target="libgdk-x11-2.0.so.0"/>
-- <dllmap dll="libgdk_pixbuf-2.0-0.dll" target="libgdk_pixbuf-2.0.so.0"/>
-- <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so.0"/>
-- <dllmap dll="libgnomeui-2-0.dll" target="libgnomeui-2.so.0"/>
-- <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so.0"/>
-- <dllmap dll="libfspoteog" target="@expanded_libdir@/f-spot/libfspoteog.so.0"/>
-- <dllmap dll="libfspotjpeg" target="@expanded_libdir@/f-spot/libfspotjpg.so.0"/>
-- <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
-- <dllmap dll="libexif.dll" target="libexif.so.@EXIF_SOVERSION@"/>
-+ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so"/>
-+ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so"/>
-+ <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0.so"/>
-+ <dllmap dll="libgdk-2.0-0.dll" target="libgdk-x11-2.0.so"/>
-+ <dllmap dll="libgdk_pixbuf-2.0-0.dll" target="libgdk_pixbuf-2.0.so"/>
-+ <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so"/>
-+ <dllmap dll="libgnomeui-2-0.dll" target="libgnomeui-2.so"/>
-+ <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so"/>
-+ <dllmap dll="libfspoteog" target="@expanded_libdir@/f-spot/libfspoteog.so"/>
-+ <dllmap dll="libfspotjpeg" target="@expanded_libdir@/f-spot/libfspotjpg.so"/>
-+ <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so"/>
-+ <dllmap dll="libexif.dll" target="libexif.so"/>
- </configuration>