aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
commitd750615763ee2d3250de2115295079f66d813d1f (patch)
tree05b94e79be3ac272b9b617e50fc723ea52c6cf34 /graphics
parent767bcfc72cf9c3574739d745cff6620fa75b0e74 (diff)
downloadports-d750615763ee2d3250de2115295079f66d813d1f.tar.gz
ports-d750615763ee2d3250de2115295079f66d813d1f.zip
- Use features of bsd.wx.mk, especially USE_WX
PR: ports/101613 Submitted by: alepulver
Notes
Notes: svn path=/head/; revision=178433
Diffstat (limited to 'graphics')
-rw-r--r--graphics/comical/Makefile5
-rw-r--r--graphics/hugin/Makefile7
-rw-r--r--graphics/multivideo/Makefile5
-rw-r--r--graphics/wxsvg/Makefile5
-rw-r--r--graphics/xaralx/Makefile12
-rw-r--r--graphics/zphoto/Makefile6
6 files changed, 14 insertions, 26 deletions
diff --git a/graphics/comical/Makefile b/graphics/comical/Makefile
index 44caa75c8c0b..e4f0e58c92c9 100644
--- a/graphics/comical/Makefile
+++ b/graphics/comical/Makefile
@@ -15,12 +15,11 @@ MASTER_SITES= http://www.mcaree.org/Comical/ \
MAINTAINER= john@mcaree.org
COMMENT= A sequential image viewer
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-
USE_GMAKE= yes
+USE_WX= 2.4
+WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
.include <bsd.port.pre.mk>
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 5319cb662263..ccef7953bc75 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -20,21 +20,20 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
fftw:${PORTSDIR}/math/fftw \
- wx_gtk2_xrc-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26 \
boost_date_time:${PORTSDIR}/devel/boost
RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -ftemplate-depth-64" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
USE_ICONV= yes
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
DOCSDIR= ${PREFIX}/share/hugin/xrc/data
-WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.6-config
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
@@ -45,7 +44,7 @@ PLIST_SUB+= NLS=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-wxrc|-${X11BASE}/bin/wxrc-gtk2-2.6|' \
+ @${REINPLACE_CMD} -e 's|-wxrc|-${WX_CONFIG:S/wx/wxrc/}|' \
${WRKSRC}/src/hugin/xrc/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/multivideo/Makefile b/graphics/multivideo/Makefile
index 77e87440dea5..6249466c97bf 100644
--- a/graphics/multivideo/Makefile
+++ b/graphics/multivideo/Makefile
@@ -16,19 +16,16 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= An image sequence viewer
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_GMAKE= yes
+USE_WX= 2.4
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
ALL_TARGET= default
PLIST_FILES= bin/multivideo
-WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
-
post-patch:
@${REINPLACE_CMD} -e 's|g++|\$$\(CXX)|g ; \
s|-O2 -g -Wall -W|\$$\(CXXFLAGS\)|g ; \
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 0eb3c86e55c0..168427737f5f 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -15,13 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ahze@FreeBSD.org
COMMENT= C++ library to create, manipulate, and render SVG files
-BUILD_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
-RUN_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
-
USE_LDCONFIG= yes
-WX_CONFIG= wxgtk2-2.6-config
USE_AUTOTOOLS= libtool:15
USE_GNOME= libartlgpl2
+USE_WX= 2.6
.include <bsd.port.pre.mk>
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
index b910d832d12c..5837b1a9862e 100644
--- a/graphics/xaralx/Makefile
+++ b/graphics/xaralx/Makefile
@@ -20,22 +20,17 @@ COMMENT?= Top-tier vector/general purpose graphics program (recommended version)
USE_BZIP2= yes
USE_X_PREFIX= yes
-#WXDEP= ${X11BASE}/libwx_baseu-2.6.so.0.3.1
-WXDEP= wxgtk2-unicode>=2.6.3
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config \
- ${WXDEP}:${PORTSDIR}/x11-toolkits/wxgtk26-unicode \
xml2-config:${PORTSDIR}/textproc/libxml2 \
zip:${PORTSDIR}/archivers/zip
-RUN_DEPENDS+= ${WXDEP}:${PORTSDIR}/x11-toolkits/wxgtk26-unicode \
- convert:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS+= dlmalloc.2:${PORTSDIR}/devel/libdlmalloc \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_AUTOTOOLS= autoconf:259:env aclocal:19:env automake:19:env libtool:15:env
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --with-wx-config=wxgtk2u-2.6-config \
- --program-suffix=${PKGNAMESUFFIX}
+CONFIGURE_ARGS+= --program-suffix=${PKGNAMESUFFIX}
# we're using dlmalloc because the stock libc does not have malloc_usable_size()
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -ldlmalloc"
@@ -43,6 +38,9 @@ USE_GMAKE= yes
MAKE_ENV?= INCLUDES="-I${LOCALBASE}/include/dlmalloc" LANG=C
USE_GCC= 3.4+
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
+WX_UNICODE= yes
MAN1= xaralx${PKGNAMESUFFIX}.1
MANFILE= xaralx.1
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index a8b62c895a0c..e2bfdd10a39f 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -21,9 +21,6 @@ LIB_DEPENDS= ming.4:${PORTSDIR}/graphics/ming \
.if !defined (WITHOUT_AVIPLAY)
LIB_DEPENDS+= aviplay.0:${PORTSDIR}/multimedia/avifile
.endif
-.if defined (WITH_WXGTK2)
-LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-.endif
.if !defined (WITHOUT_ZIP)
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
.endif
@@ -33,7 +30,8 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
.if defined (WITH_WXGTK2)
-CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.4-config
+USE_WX= 2.4
+WX_CONF_ARGS= absolute
PLIST_FILES+= bin/wxzphoto
.else
CONFIGURE_ARGS+= --disable-wx