aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-13 23:15:46 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-13 23:15:46 +0000
commit108960574aded64a7314d0ffdf9cef9768b62fb5 (patch)
tree2a7b3473c6585e30129af2267dea483465374d34 /graphics
parentb5bf2fbd481c38fe84aee0a0a8d9a1bd3c53d779 (diff)
downloadports-108960574aded64a7314d0ffdf9cef9768b62fb5.tar.gz
ports-108960574aded64a7314d0ffdf9cef9768b62fb5.zip
Add telak.
Telak is a small tool to draw local or remote pictures on your root window. This is very useful if you want to have RRD graphs drawn above your wallpaper. WWW: http://julien.danjou.info/telak.html PR: ports/86069 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=142656
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/telak/Makefile40
-rw-r--r--graphics/telak/distinfo2
-rw-r--r--graphics/telak/files/install-user30
-rw-r--r--graphics/telak/files/patch-Makefile13
-rw-r--r--graphics/telak/files/patch-parse.c10
-rw-r--r--graphics/telak/files/patch-telak.c18
-rw-r--r--graphics/telak/pkg-descr7
-rw-r--r--graphics/telak/pkg-message4
9 files changed, 125 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9c4750bbaa5e..12930125d32b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -541,6 +541,7 @@
SUBDIR += synaesthesia
SUBDIR += tcm
SUBDIR += teddy
+ SUBDIR += telak
SUBDIR += tgif
SUBDIR += tgif-nls
SUBDIR += threeDS
diff --git a/graphics/telak/Makefile b/graphics/telak/Makefile
new file mode 100644
index 000000000000..14bae682d794
--- /dev/null
+++ b/graphics/telak/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: telak
+# Date created: 13 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= telak
+PORTVERSION= 0.4
+CATEGORIES= graphics
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A tool to draw pictures on your root window
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ gcrypt.13:${PORTSDIR}/security/libgcrypt \
+ Imlib2.3:${PORTSDIR}/graphics/imlib2
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GETOPT_LONG=yes
+
+ALL_TARGET= ${PORTNAME}
+MAKE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/telak
+MAN1= telak.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+install-user:
+ @${SH} ${FILESDIR}/install-user
+
+.include <bsd.port.mk>
diff --git a/graphics/telak/distinfo b/graphics/telak/distinfo
new file mode 100644
index 000000000000..9a630d931b5f
--- /dev/null
+++ b/graphics/telak/distinfo
@@ -0,0 +1,2 @@
+MD5 (telak-0.4.tar.gz) = ab8d56f191d3c5215a04af846c32c575
+SIZE (telak-0.4.tar.gz) = 13975
diff --git a/graphics/telak/files/install-user b/graphics/telak/files/install-user
new file mode 100644
index 000000000000..50fc16e3c6e3
--- /dev/null
+++ b/graphics/telak/files/install-user
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+
+writeconf()
+{
+cat << "EOF" > $HOME/.telak/telakrc
+# telakrc - see telak(1) for more config options
+
+[example]
+url = http://www.critical.ch/telak/d-mon.gif
+x = 15
+y = 15
+
+EOF
+}
+
+if [ ! -d $HOME/.telak/cache ]; then
+ mkdir -p $HOME/.telak/cache
+ if [ ! -f $HOME/.telak/telakrc ]; then
+ writeconf
+ echo "Example config successfully installed under $HOME/.telak/"
+ else
+ echo "$HOME/.telak/telakrc does already exist."
+ fi
+else
+ echo "$HOME/.telak does already exist."
+fi
diff --git a/graphics/telak/files/patch-Makefile b/graphics/telak/files/patch-Makefile
new file mode 100644
index 000000000000..165b2982d37b
--- /dev/null
+++ b/graphics/telak/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Apr 28 22:15:06 2005
++++ Makefile Wed Sep 14 01:04:46 2005
+@@ -1,8 +1,8 @@
+ VERSION = $(shell grep '^Version' ChangeLog | head -n 1 | cut -d' ' -f2 | tr -d ' ')
+ BIN = telak
+ O = telak.o fetch.o image.o parse.o
+-LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
+-CFLAGS = -W -Wall $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\"" -g
++LDFLAGS += -L$(LOCALBASE)/lib $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
++CFLAGS += -I$(LOCALBASE)/include $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\""
+
+ BINDIR=$(DESTDIR)/usr/bin
+ MANDIR=$(DESTDIR)/usr/share/man/man1
diff --git a/graphics/telak/files/patch-parse.c b/graphics/telak/files/patch-parse.c
new file mode 100644
index 000000000000..83ae83b7f700
--- /dev/null
+++ b/graphics/telak/files/patch-parse.c
@@ -0,0 +1,10 @@
+--- parse.c.orig Tue Sep 13 22:05:22 2005
++++ parse.c Tue Sep 13 22:05:39 2005
+@@ -17,6 +17,7 @@
+ #include <sys/types.h>
+ #include <pwd.h>
+ #include <time.h>
++#include <sys/time.h>
+
+ #include "telak.h"
+ #include "image.h"
diff --git a/graphics/telak/files/patch-telak.c b/graphics/telak/files/patch-telak.c
new file mode 100644
index 000000000000..e1fa7f367c6d
--- /dev/null
+++ b/graphics/telak/files/patch-telak.c
@@ -0,0 +1,18 @@
+--- telak.c.orig Wed Sep 14 01:08:51 2005
++++ telak.c Wed Sep 14 01:08:52 2005
+@@ -91,7 +91,6 @@
+ Atom SWM_VROOT = XInternAtom(display, "__SWM_VROOT", False);
+ Atom NAUTILUS_DESKTOP_WINDOW_ID =
+ XInternAtom(display, "NAUTILUS_DESKTOP_WINDOW_ID", False);
+- win = DefaultRootWindow(display);
+
+ Window unused, *windows = 0;
+ unsigned int count;
+@@ -101,6 +100,7 @@
+ unsigned long nitems, bytes_after_return;
+ unsigned char *virtual_root_window;
+
++ win = DefaultRootWindow(display);
+ if(XGetWindowProperty(display, win, NAUTILUS_DESKTOP_WINDOW_ID,
+ 0, 1, False, XA_WINDOW, &type, &format,
+ &nitems, &bytes_after_return,
diff --git a/graphics/telak/pkg-descr b/graphics/telak/pkg-descr
new file mode 100644
index 000000000000..255a206d07fb
--- /dev/null
+++ b/graphics/telak/pkg-descr
@@ -0,0 +1,7 @@
+Telak is a small tool to draw local or remote pictures on your root window.
+This is very useful if you want to have RRD graphs drawn above your wallpaper.
+
+WWW: http://julien.danjou.info/telak.html
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/graphics/telak/pkg-message b/graphics/telak/pkg-message
new file mode 100644
index 000000000000..b6cc8d93995c
--- /dev/null
+++ b/graphics/telak/pkg-message
@@ -0,0 +1,4 @@
+===============================================================================
+To install an example config file, log into your user account and type
+'make install-user'.
+===============================================================================