aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-20 22:53:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-20 22:53:09 +0000
commit38eb8c5339e31bce015d6652caf364542965d4d0 (patch)
tree57033736b4eab37d8b46bb4b452f790f37bd0c7a /graphics
parent1a3a92532506ba92f7a9670be49752b00ad8a807 (diff)
downloadports-38eb8c5339e31bce015d6652caf364542965d4d0.tar.gz
ports-38eb8c5339e31bce015d6652caf364542965d4d0.zip
- Mark MAKE_JOBS_UNSAFE
Reported by: pointyhat
Notes
Notes: svn path=/head/; revision=244567
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dore/Makefile1
-rw-r--r--graphics/libart/Makefile1
-rw-r--r--graphics/libaux/Makefile1
-rw-r--r--graphics/mapserver/Makefile1
-rw-r--r--graphics/maverik/Makefile1
-rw-r--r--graphics/mesagl/Makefile1
-rw-r--r--graphics/moth/Makefile1
-rw-r--r--graphics/mxp/Makefile1
-rw-r--r--graphics/plotmtv/Makefile1
9 files changed, 9 insertions, 0 deletions
diff --git a/graphics/dore/Makefile b/graphics/dore/Makefile
index 12ea376eedd9..b83522540112 100644
--- a/graphics/dore/Makefile
+++ b/graphics/dore/Makefile
@@ -23,6 +23,7 @@ EXTRACT_CMD= ${MKDIR} ${WRKSRC}; cd ${WRKSRC}; ${GZIP_CMD}
MAKEFILE= mk.stdx
MAKE_ENV= DORE_LOC=${WRKDIR}
NOPRECIOUSMAKEVARS= yes
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/libart/Makefile b/graphics/libart/Makefile
index e2cbfa70ec0f..f3295fb884f4 100644
--- a/graphics/libart/Makefile
+++ b/graphics/libart/Makefile
@@ -18,6 +18,7 @@ USE_AUTOTOOLS= libtool:22
WRKSRC= ${WRKDIR}/${PORTNAME}_lgpl-${PORTVERSION}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
CONFLICTS= libart_lgpl-*
diff --git a/graphics/libaux/Makefile b/graphics/libaux/Makefile
index 122813a6f5b6..2f39f3a6cc0b 100644
--- a/graphics/libaux/Makefile
+++ b/graphics/libaux/Makefile
@@ -19,6 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GL= glut
USE_IMAKE= yes
+MAKE_JOBS_UNSAFE= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libaux.a ${PREFIX}/lib
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index c7e3cf9dc482..e86518e02b58 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-runpath \
--with-gd=${LOCALBASE} \
--with-proj=${LOCALBASE}
+MAKE_JOBS_UNSAFE= yes
OPTIONS= AGG "Support for AGG image rendering (req: FreeType)" off \
TIFF "Support for TIFF (but not GeoTIFF) files" off \
diff --git a/graphics/maverik/Makefile b/graphics/maverik/Makefile
index 6da92a59dbf0..6d4a96b31088 100644
--- a/graphics/maverik/Makefile
+++ b/graphics/maverik/Makefile
@@ -26,6 +26,7 @@ CONFIGURE_SCRIPT= setup
CONFIGURE_ARGS= --MESAPATH=${LOCALBASE}
USE_LDCONFIG= yes
MANCOMPRESSED= no
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index 5142d6b3adaf..ca73c1f5e88f 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -31,6 +31,7 @@ GLVER= 14
MAKEFILE= Makefile.X11
ALL_TARGET= realclean freebsd
+MAKE_JOBS_UNSAFE= yes
do-install:
@${MKDIR} ${PREFIX}/include/Mesa/GL
diff --git a/graphics/moth/Makefile b/graphics/moth/Makefile
index e4687e530ac9..435a1c1df991 100644
--- a/graphics/moth/Makefile
+++ b/graphics/moth/Makefile
@@ -27,6 +27,7 @@ MAKE_ARGS= CC="${CXX}" XLIBDIR="${LOCALBASE}/lib" MOC="${MOC}" \
MOTH_INCLUDES="${WRKSRC_LIBMOTH}/include" \
MOTH_LIBRARIES="${WRKSRC_LIBMOTH}/lib"
ALL_TARGET= clean moth
+MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= manual.pdf
diff --git a/graphics/mxp/Makefile b/graphics/mxp/Makefile
index 9c42174cea7b..fa623874ed92 100644
--- a/graphics/mxp/Makefile
+++ b/graphics/mxp/Makefile
@@ -18,6 +18,7 @@ COMMENT= Application for computing/exploring Mandelbrot set
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET=
USE_XORG= xaw xbitmaps xpm
+MAKE_JOBS_UNSAFE= yes
post-extract:
@${CP} ${WRKSRC}/Makefile.noimake ${WRKSRC}/Makefile
diff --git a/graphics/plotmtv/Makefile b/graphics/plotmtv/Makefile
index fd4032268ffd..479bf1c8c5fe 100644
--- a/graphics/plotmtv/Makefile
+++ b/graphics/plotmtv/Makefile
@@ -22,6 +22,7 @@ USE_IMAKE= yes
USE_XORG= x11 xext xt
ALL_TARGET= World
MAN1= plotmtv.1
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${FIND} ${WRKSRC} -name \*.c | ${XARGS} ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/'