aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-07-02 19:42:43 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-07-02 19:42:43 +0000
commitdee52f7af3b9ad8009bcb24103ed617e17c9dddc (patch)
tree95d055c2130d31e0101386de2b76a214bffef625 /graphics
parent4d335b95072ae6a645ecb7a91e94d483c5480a2a (diff)
downloadports-dee52f7af3b9ad8009bcb24103ed617e17c9dddc.tar.gz
ports-dee52f7af3b9ad8009bcb24103ed617e17c9dddc.zip
Unbreak by removing -Werror
Feature safe: yes
Notes
Notes: svn path=/head/; revision=257314
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gsculpt/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index e3bcdfbbc4ed..589b956d27f6 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -20,8 +20,6 @@ LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gtkgl/__init__.py:${PORTSDIR}/x11-toolkits/py-gtkglext \
${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
-BROKEN= does not compile
-
WRKSRC= ${WRKDIR}/gSculpt-${PORTVERSION}-alpha
USE_SCONS= yes
SCONS_BUILDENV= ${SCONS_ENV}
@@ -44,7 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|prefix = os.path.join( '/usr', 'local' )|prefix='${PREFIX}'|; \
s|'bin', 'gSculpt'|'${PYTHONPREFIX_SITELIBDIR}'|;" \
${WRKSRC}/SConstruct-install
- @${REINPLACE_CMD} -e "s|-O2|-O1\|-O2|;" \
+ @${REINPLACE_CMD} -e "s|-O2|-O1\|-O2|;s|'-Werror',||" \
${WRKSRC}/SConstruct
.if ${ARCH} != "i386"
@${REINPLACE_CMD} -e "s|, '-DGSCULPT_FPU_X86'||;" \