aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-30 08:14:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-30 08:14:43 +0000
commita48d5f5093731197ee51062a1ae73a642c7a960c (patch)
treec01241e662de687efda8cd50ed758ca2cc670532 /graphics
parent3130afd9f6e2bfb6c38a3ebe05bb51c9c6ebd07f (diff)
downloadports-a48d5f5093731197ee51062a1ae73a642c7a960c.tar.gz
ports-a48d5f5093731197ee51062a1ae73a642c7a960c.zip
- fix build for png-1.4.1
Notes
Notes: svn path=/head/; revision=251796
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnofract4d/Makefile8
-rw-r--r--graphics/mtpaint/Makefile2
2 files changed, 9 insertions, 1 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index a492edbeeabf..4724968800ed 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -46,11 +46,17 @@ post-patch:
@${REINPLACE_CMD} -e '236,238d' ${WRKSRC}/setup.py
# fixup library detection
- @${REINPLACE_CMD} -e "s/libpng/libpng12/" ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e "s/libpng/libpng14/" ${WRKSRC}/setup.py
@${REINPLACE_CMD} \
-e "s,/usr/include/jpeglib.h,${LOCALBASE}/include/jpeglib.h," \
${WRKSRC}/setup.py
+ # png14
+ @${REINPLACE_CMD} -e "s/png_infopp_NULL/NULL/g" \
+ -e "s/png_bytepp_NULL/NULL/g" \
+ -e "s/int_p_NULL/NULL/g" \
+ ${WRKSRC}/fract4d/c/imageIO.cpp
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
index 3319d0867541..c7915ef9c454 100644
--- a/graphics/mtpaint/Makefile
+++ b/graphics/mtpaint/Makefile
@@ -46,6 +46,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|="/usr"|="${LOCALBASE}"|g ; \
s|/usr/X11R6|${LOCALBASE}|g ; \
s|GTK_LIB -s|GTK_LIB|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/src/png.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \