aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2007-02-23 03:48:43 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2007-02-23 03:48:43 +0000
commit0db632260f1c78322e98a6a5a3777ba5c1bd20fb (patch)
tree94100aeb6bf2c8fc4c43be5a52b26f0f9eaaf07b /graphics
parented0347a94af5198a6ea96fa86d9a442c30294e51 (diff)
downloadports-0db632260f1c78322e98a6a5a3777ba5c1bd20fb.tar.gz
ports-0db632260f1c78322e98a6a5a3777ba5c1bd20fb.zip
Turn gslib support into option. IM can work with gs with or without it.
Switch to gs-afpl as default one checked. IM needs newer gs for some operations and gs-gnu is too old. Add without-dps option by default since Xorg does not have required DPS library anymore. DPS is poor choice in any case because renders first page only. When DPS is off, gs automatically used, which is the right thing. Approved by: shaun (maintainer)
Notes
Notes: svn path=/head/; revision=185719
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index ab5c57c83cea..14b1ecac243e 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ImageMagick
DISTVERSION= 6.3.2-0
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= ftp://ftp.imagemagick.org/pub/ImageMagick/ \
ftp://gd.tuwien.ac.at/pub/graphics/ImageMagick/ \
@@ -34,7 +35,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15 libltdl:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-shared --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS= --enable-shared --mandir=${MANPREFIX}/man --without-dps
USE_LDCONFIG= yes
MAN1= ImageMagick.1 Magick++-config.1 Magick-config.1 Wand-config.1 \
@@ -63,9 +64,9 @@ OPTIONS= X11 "X11 support" on \
IMAGEMAGICK_DOT "GraphViz dot graphs support" off \
IMAGEMAGICK_WMF "WMF format support" off \
IMAGEMAGICK_SVG "SVG format support" off \
- IMAGEMAGICK_DPS "DPS (Display PostScript) support" on \
IMAGEMAGICK_PDF "PDF format support" on \
- IMAGEMAGICK_MPEG2 "MPEG2 format support" on
+ IMAGEMAGICK_MPEG2 "MPEG2 format support" on \
+ IMAGEMAGICK_GSLIB "libgs (Postscript SHLIB) support" off
.include <bsd.port.pre.mk>
@@ -138,6 +139,14 @@ CONFIGURE_ARGS+= --without-tiff
PLIST_SUB+= TIFF="@comment "
.endif
+.if defined(WITH_IMAGEMAGICK_GSLIB)
+CONFIGURE_ARGS+= --with-gslib
+USE_GHOSTSCRIPT= yes
+WITH_GHOSTSCRIPT_AFPL= yes
+.else
+CONFIGURE_ARGS+= --without-gslib
+.endif
+
# Produce BZip compressed MIFF images
.if defined(WITHOUT_IMAGEMAGICK_BZLIB)
CONFIGURE_ARGS+= --without-bzlib
@@ -238,19 +247,10 @@ CONFIGURE_ENV+= RSVG_CFLAGS="-I${X11BASE}/include/librsvg-2" \
CONFIGURE_ARGS+= --without-rsvg
.endif
-# DPS (Display PostScript) support
-.if !defined(WITHOUT_IMAGEMAGICK_DPS)
-CONFIGURE_ARGS+= --with-dps
-.else
-CONFIGURE_ARGS+= --without-dps
-.endif
-
# PDF (Adobe Portable Document Format) support
.if !defined(WITHOUT_IMAGEMAGICK_PDF)
-CONFIGURE_ARGS+= --with-gslib
USE_GHOSTSCRIPT= yes
-.else
-CONFIGURE_ARGS+= --without-gslib
+WITH_GHOSTSCRIPT_AFPL= yes
.endif
.if defined(WITHOUT_X11)