aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-29 22:28:53 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-29 22:28:53 +0000
commit3dadae3ba010b1783b1f1fd410cdb67bf9087967 (patch)
tree04461cd7f09abf580b727e9441c02c2cb584ddb1 /graphics
parent86cb0d2ccbc5db77869f2fab400966bb39ce79d9 (diff)
downloadports-3dadae3ba010b1783b1f1fd410cdb67bf9087967.tar.gz
ports-3dadae3ba010b1783b1f1fd410cdb67bf9087967.zip
- Add patch to fix build on alpha
PR: ports/62080 Submitted by: maintainer Noticed by: bento via kris
Notes
Notes: svn path=/head/; revision=99449
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xd3d/Makefile5
-rw-r--r--graphics/xd3d/files/patch-RULES.freeBSD16
2 files changed, 21 insertions, 0 deletions
diff --git a/graphics/xd3d/Makefile b/graphics/xd3d/Makefile
index 9fc5a14900b1..6302baf14f80 100644
--- a/graphics/xd3d/Makefile
+++ b/graphics/xd3d/Makefile
@@ -45,6 +45,11 @@ F77?= f77
FFLAGS?= -O
MEMORY_XD3D?= 64
+.if ${MACHINE_ARCH} == "i386"
+FFLAGS+= -malign-double
+CFLAGS+= -malign-double
+.endif
+
.if defined(LANG) && ${LANG:Mfr*} != ""
XD3D_LANG= FRANCAIS
.else
diff --git a/graphics/xd3d/files/patch-RULES.freeBSD b/graphics/xd3d/files/patch-RULES.freeBSD
new file mode 100644
index 000000000000..34b60251eba2
--- /dev/null
+++ b/graphics/xd3d/files/patch-RULES.freeBSD
@@ -0,0 +1,16 @@
+--- RULES.freeBSD.orig Mon Dec 1 14:55:58 2003
++++ RULES.freeBSD Thu Jan 29 21:43:28 2004
+@@ -54,11 +54,11 @@
+ #
+ # Options for the Fortran compiler
+ #
+-OPTF = %%FFLAGS%% -malign-double
++OPTF = %%FFLAGS%%
+ #
+ # Options for the C compiler
+ #
+-OPTC = %%CFLAGS%% -malign-double
++OPTC = %%CFLAGS%%
+
+ #-----------------------------------------------
+ # You should not need to change anything below !