aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-02-13 09:27:11 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-02-13 09:27:11 +0000
commit639cdade050db82995c3e6d019e0d02f653a66d6 (patch)
treea802e9572b5fcf01ef3609986c1c504294a179dc /graphics
parent2e78cdf1642420272a0ea062d243e93d0e628dc7 (diff)
downloadports-639cdade050db82995c3e6d019e0d02f653a66d6.tar.gz
ports-639cdade050db82995c3e6d019e0d02f653a66d6.zip
Fix graphics/xaralx compilation with gcc 4.1
graphics/xaralx-devel does not need this fix, thus we modify it not to use all its masterport patches. Reported by: kris
Notes
Notes: svn path=/head/; revision=185085
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xaralx-devel/Makefile2
-rw-r--r--graphics/xaralx/files/patch-Kernel_cxftree.h11
2 files changed, 13 insertions, 0 deletions
diff --git a/graphics/xaralx-devel/Makefile b/graphics/xaralx-devel/Makefile
index 3e6cd1705533..0d6778fefe0a 100644
--- a/graphics/xaralx-devel/Makefile
+++ b/graphics/xaralx-devel/Makefile
@@ -15,5 +15,7 @@ COMMENT= Top-tier vector/general purpose graphics program (development version)
MASTERDIR= ${.CURDIR}/../xaralx
MD5_FILE= ${.CURDIR}/distinfo
PLIST= ${.CURDIR}/pkg-plist
+PATCHDIR= ${.CURDIR}/files
+EXTRA_PATCHES= ${MASTERDIR}/files/patch-configure.in
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/xaralx/files/patch-Kernel_cxftree.h b/graphics/xaralx/files/patch-Kernel_cxftree.h
new file mode 100644
index 000000000000..ce8abcd930c2
--- /dev/null
+++ b/graphics/xaralx/files/patch-Kernel_cxftree.h
@@ -0,0 +1,11 @@
+--- Kernel/cxftree.h.orig Tue Feb 13 10:21:18 2007
++++ Kernel/cxftree.h Tue Feb 13 10:21:40 2007
+@@ -287,7 +287,7 @@
+
+ INT32 AddDisplayNode(CXFNode* pNode,INT32 Index,INT32 Depth,BOOL ExpandAll);
+ void ShowNodeDebugInfoForNode(CXFNode *pNode);
+- CXaraFileRecordHandler* CXFTreeDlg::FindHandler(UINT32 Tag);
++ CXaraFileRecordHandler* FindHandler(UINT32 Tag);
+ void GetTagText(CXFNode* pNode,String_256& Str);
+
+ CXFNode* pRoot;