aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-03-02 18:05:21 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-03-02 18:05:21 +0000
commitea606d6c8ae8f60a123db4379a4d8e55f9fb0259 (patch)
treec2de15a86a491305b52b47421bb1bb52d5abdeb0 /graphics
parent7f05793b3bc8456ec338df9f7c698e7a8c180cdb (diff)
downloadports-ea606d6c8ae8f60a123db4379a4d8e55f9fb0259.tar.gz
ports-ea606d6c8ae8f60a123db4379a4d8e55f9fb0259.zip
Add s10sh 0.1.91,
Program to interface Canon PowerShot digital cameras over USB and/or serial connections. PR: 25471 Submitted by: John Reynolds <jjreynold@home.com>
Notes
Notes: svn path=/head/; revision=38991
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/s10sh/Makefile39
-rw-r--r--graphics/s10sh/distinfo2
-rw-r--r--graphics/s10sh/files/Makefile.bsd19
-rw-r--r--graphics/s10sh/pkg-comment1
-rw-r--r--graphics/s10sh/pkg-descr16
-rw-r--r--graphics/s10sh/pkg-plist3
7 files changed, 81 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0b0ff2b83e47..a3b6ba9b9345 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -183,6 +183,7 @@
SUBDIR += ruby-ming
SUBDIR += ruby-opengl
SUBDIR += ruby-qt2gl
+ SUBDIR += s10sh
SUBDIR += sane
SUBDIR += sced
SUBDIR += scrot
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
new file mode 100644
index 000000000000..0f8c6d108ee9
--- /dev/null
+++ b/graphics/s10sh/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: s10sh
+# Date created: Tue Feb 27 00:16:34 MST 2001
+# Whom: John Reynolds <jjreynold@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= s10sh
+PORTVERSION= 0.1.91
+CATEGORIES= graphics
+MASTER_SITES= http://www.kyuzz.org/antirez/s10sh-src/
+
+PATCH_SITES=http://www.reynoldsnet.org/s10sh/ \
+ http://members.home.net/jjreynold/s10sh/
+PATCHFILES=${PORTNAME}-${PORTVERSION}.patches.gz
+PATCH_DIST_STRIP=-p1
+
+MAINTAINER= jjreynold@home.com
+
+# Don't extract the libusb bundled with s10sh:
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libusb*'
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+.if defined(NOUSB) || defined(WITHOUT_USB)
+MAKE_ENV+= WITHOUT_USB=YES
+.else
+LIB_DEPENDS= usb-0.1.3:${PORTSDIR}/devel/libusb
+.endif
+
+.if !defined(NOPORTDOCS)
+DOCDIR= share/doc/s10sh
+PLIST_SUB+= DOCDIR="${DOCDIR}"
+post-install:
+ ${MKDIR} ${LOCALBASE}/${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${LOCALBASE}/${DOCDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/s10sh/distinfo b/graphics/s10sh/distinfo
new file mode 100644
index 000000000000..4689bcd21e1f
--- /dev/null
+++ b/graphics/s10sh/distinfo
@@ -0,0 +1,2 @@
+MD5 (s10sh-0.1.91.tar.gz) = fa4bd1793464309910f45ea59fc53cce
+MD5 (s10sh-0.1.91.patches.gz) = b427803d301cb8dc9da6dac40923b3ee
diff --git a/graphics/s10sh/files/Makefile.bsd b/graphics/s10sh/files/Makefile.bsd
new file mode 100644
index 000000000000..d9b2f58516e2
--- /dev/null
+++ b/graphics/s10sh/files/Makefile.bsd
@@ -0,0 +1,19 @@
+PROG = s10sh
+NOMAN = oh...
+
+SRCS = main.c crc.c serial.c common.c bar.c
+
+LDADD += -lreadline -ltermcap
+CFLAGS += -DHAVE_READLINE
+
+.if !defined(WITHOUT_USB)
+USBLIB != ${LOCALBASE}/bin/libusb-config --libs
+LDADD += ${USBLIB}
+USBCF != ${LOCALBASE}/bin/libusb-config --cflags
+CFLAGS += ${USBCF} -DHAVE_USB_SUPPORT
+SRCS += usb.c
+.endif
+
+BINDIR = ${LOCALBASE}/bin
+
+.include <bsd.prog.mk>
diff --git a/graphics/s10sh/pkg-comment b/graphics/s10sh/pkg-comment
new file mode 100644
index 000000000000..ddc50dbba81c
--- /dev/null
+++ b/graphics/s10sh/pkg-comment
@@ -0,0 +1 @@
+USB/serial userspace driver for the Canon PowerShot digital cameras
diff --git a/graphics/s10sh/pkg-descr b/graphics/s10sh/pkg-descr
new file mode 100644
index 000000000000..785e7ae3d65e
--- /dev/null
+++ b/graphics/s10sh/pkg-descr
@@ -0,0 +1,16 @@
+S10sh is a USB/serial userspace driver for the Canon PowerShot digital cameras.
+Using S10sh you can download, upload and explore the images captured with your
+PowerShot camera. The interface is quite similar to DOS's command.com.
+
+S10sh supports the following PowerShot models:
+
+ S10 (serial and USB)
+ S20 (serial and USB)
+ S100 aka Digital Ixus (USB only, since it lacks the serial interface)
+ A50 (serial only, supported with problems)
+ Pro70 (serial only, supported with problems)
+
+With the release of libusb 0.1.3b (http://sourceforge.net/projects/libusb/),
+S10sh gained USB support under FreeBSD.
+
+WWW: http://www.kyuzz.org/antirez/s10sh.html
diff --git a/graphics/s10sh/pkg-plist b/graphics/s10sh/pkg-plist
new file mode 100644
index 000000000000..9b2f6dc49738
--- /dev/null
+++ b/graphics/s10sh/pkg-plist
@@ -0,0 +1,3 @@
+bin/s10sh
+%%PORTDOCS%%%%DOCDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCDIR%%