aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2006-04-16 09:26:59 +0000
committerMartin Blapp <mbr@FreeBSD.org>2006-04-16 09:26:59 +0000
commitbc525a73f74330c40267c3b9eb0158b790b24450 (patch)
tree9906458ed52061ab6b8243629ebd897ffb69e806 /graphics
parent0eac993ce5dc2443f8e2111c8aee442e5bd33296 (diff)
downloadports-bc525a73f74330c40267c3b9eb0158b790b24450.tar.gz
ports-bc525a73f74330c40267c3b9eb0158b790b24450.zip
Do not link with an installed library, use the fresh compiled one instead.
Notes
Notes: svn path=/head/; revision=159683
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gocr/files/patch-link44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/gocr/files/patch-link b/graphics/gocr/files/patch-link
new file mode 100644
index 000000000000..233fda0a64c4
--- /dev/null
+++ b/graphics/gocr/files/patch-link
@@ -0,0 +1,44 @@
+--- src/Makefile.in Mon Feb 28 15:40:39 2005
++++ src/Makefile.in Wed Apr 12 09:20:51 2006
+@@ -4,8 +4,8 @@
+
+ EXEEXT =
+ PROGRAM = gocr$(EXEEXT)
+-PGMASCLIB = Pgm2asc
+-LIBPGMASCLIB = lib$(PGMASCLIB).a
++PGMASCLIB = ./libPgm2asc.a
++LIBPGMASCLIB = $(PGMASCLIB)
+ INCLUDEFILES = gocr.h
+
+ LIBOBJS=pgm2asc.o \
+@@ -53,7 +53,7 @@
+ all: $(PROGRAM) $(LIBPGMASCLIB)
+
+ $(PROGRAM): $(LIBPGMASCLIB) gocr.o
+- $(CC) -o $@ gocr.o $(LDFLAGS) -l$(PGMASCLIB)
++ $(CC) -o $@ gocr.o $(LDFLAGS) $(PGMASCLIB)
+ if test -r $(PROGRAM); then cp $@ ../bin; fi
+
+
+--- src/Makefile Mon Feb 28 15:40:39 2005
++++ src/Makefile Wed Apr 12 09:20:51 2006
+@@ -4,8 +4,8 @@
+
+ EXEEXT =
+ PROGRAM = gocr$(EXEEXT)
+-PGMASCLIB = Pgm2asc
+-LIBPGMASCLIB = lib$(PGMASCLIB).a
++PGMASCLIB = ./libPgm2asc.a
++LIBPGMASCLIB = $(PGMASCLIB)
+ INCLUDEFILES = gocr.h
+
+ LIBOBJS=pgm2asc.o \
+@@ -53,7 +53,7 @@
+ all: $(PROGRAM) $(LIBPGMASCLIB)
+
+ $(PROGRAM): $(LIBPGMASCLIB) gocr.o
+- $(CC) -o $@ gocr.o $(LDFLAGS) -l$(PGMASCLIB)
++ $(CC) -o $@ gocr.o $(LDFLAGS) $(PGMASCLIB)
+ if test -r $(PROGRAM); then cp $@ ../bin; fi
+
+