aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-04 17:19:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-04 17:19:38 +0000
commitc10874ab9ce1b54c4bb57d5c1c7075ae4bddef7f (patch)
tree713c89fee852d928fb08987872a52f8f8b208b1e /graphics
parentc4220cf262252d7c9256cd6622cfe80e50813872 (diff)
downloadports-c10874ab9ce1b54c4bb57d5c1c7075ae4bddef7f.tar.gz
ports-c10874ab9ce1b54c4bb57d5c1c7075ae4bddef7f.zip
Convert to USE_GNOMENG.
Notes
Notes: svn path=/head/; revision=62434
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gdk-pixbuf/Makefile8
-rw-r--r--graphics/imlib/Makefile5
2 files changed, 5 insertions, 8 deletions
diff --git a/graphics/gdk-pixbuf/Makefile b/graphics/gdk-pixbuf/Makefile
index 46be30200b49..b4c85e4d306b 100644
--- a/graphics/gdk-pixbuf/Makefile
+++ b/graphics/gdk-pixbuf/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gtk12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
@@ -35,8 +35,4 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
BUILD_CANVAS?= no
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/aclocal|(prefix)/share/aclocal|g'
-
.include <bsd.port.mk>
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 5b3dd5392a3e..1b196c5019bf 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib --disable-modules \
@@ -34,6 +35,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= imlib-config.1 imlib_config.1
pre-configure:
- ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+ ${REINPLACE_CMD} -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
.include <bsd.port.mk>