aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-23 20:20:19 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-23 20:20:19 +0000
commit1b3325c53518e7ade14d451798493d2f6d963c79 (patch)
treed04d283cde6692e30c5cd775866e4e024b5f5a46 /graphics
parent066ca66c430496759d47f36d468af88b718f5b97 (diff)
downloadports-1b3325c53518e7ade14d451798493d2f6d963c79.tar.gz
ports-1b3325c53518e7ade14d451798493d2f6d963c79.zip
o Take over maintainership
o Update port to 0.4.p1 o Change PORTNAME to match distribution name o Add gnome as secondary category o Update COMMENT file o Both fmt(1) and update DESCR file
Notes
Notes: svn path=/head/; revision=70897
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gsubedit/Makefile53
-rw-r--r--graphics/gsubedit/distinfo2
-rw-r--r--graphics/gsubedit/pkg-comment2
-rw-r--r--graphics/gsubedit/pkg-descr13
-rw-r--r--graphics/gsubedit/pkg-plist28
5 files changed, 64 insertions, 34 deletions
diff --git a/graphics/gsubedit/Makefile b/graphics/gsubedit/Makefile
index f5a422bf6f47..8af07e452641 100644
--- a/graphics/gsubedit/Makefile
+++ b/graphics/gsubedit/Makefile
@@ -6,14 +6,14 @@
# $FreeBSD$
#
-PORTNAME= gsubedit
-PORTVERSION= 0.3
-PORTREVISION= 1
-CATEGORIES= graphics
+PORTNAME= GSubEdit
+PORTVERSION= 0.4.p1
+CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+DISTNAME= ${PORTNAME:L}-${PORTVERSION:S/.p/pre/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lioux@FreeBSD.org
USE_REINPLACE= yes
USE_X_PREFIX= yes
@@ -21,24 +21,33 @@ USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-gettext
post-patch:
- @${REINPLACE_CMD} -e 's|Bison |Bison|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|share/pixmaps|share/gnome/pixmaps|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^gsubeditdoc|#gsubeditdoc|g ; \
- s|-g -O2|| '
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog INSTALL README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+# CFLAGS safeness
+# pthread safeness
+ @${REINPLACE_CMD} -E -e 's|-g -O2||; \
+ s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/src/Makefile.in
+# prefix safeness for docs
+ @${REINPLACE_CMD} -E -e \
+ 's|^(gsubeditdocdir[[:space:]]*=).*$$|\1${DOCSDIR}|' \
+ ${WRKSRC}/Makefile.in
+# prefix safeness for pixmaps
+ @${REINPLACE_CMD} -E -e \
+ 's|^(packagepixmapsdir[[:space:]]*=).*$$|\1share/gnome/pixmaps/\$${PACKAGE}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+# install neither charset.alias nor locale.alias. Therefore, do not
+# build distfiles' gettext
+ @${REINPLACE_CMD} -E -e \
+ 's|^(SUBDIRS[[:space:]]*=.+)intl|\1|' \
+ ${WRKSRC}/Makefile.in
+# do not install docs
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e \
+ 's|^(install-data-am.+)install-gsubeditdocDATA|\1|'
+ \ ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/graphics/gsubedit/distinfo b/graphics/gsubedit/distinfo
index de7c5a91ba33..dbf5896a9d4c 100644
--- a/graphics/gsubedit/distinfo
+++ b/graphics/gsubedit/distinfo
@@ -1 +1 @@
-MD5 (gsubedit-0.3.tar.gz) = 7a6ca020c7a3eff1782666f546179659
+MD5 (gsubedit-0.4pre1.tar.gz) = 0cc52f530339f879e7edf3f60ecb59f9
diff --git a/graphics/gsubedit/pkg-comment b/graphics/gsubedit/pkg-comment
index 675a933a8f53..513c1e0df293 100644
--- a/graphics/gsubedit/pkg-comment
+++ b/graphics/gsubedit/pkg-comment
@@ -1 +1 @@
-GNOME Subtitle Editor
+GNOME Subtitle Editor is a tool for editing/converting video subtitles
diff --git a/graphics/gsubedit/pkg-descr b/graphics/gsubedit/pkg-descr
index df2d986858fd..bb56964d6268 100644
--- a/graphics/gsubedit/pkg-descr
+++ b/graphics/gsubedit/pkg-descr
@@ -1,6 +1,11 @@
-GSubEdit, or GNOME Subtitle Editor, is a tool for editing and converting
-DivX ;-) subtitles. It currently features read/write of SubRip (.srt) and
-MicroDVD (.sub) subtitles. Framerate conversion and frame displacement
-(Increase/decrease all frames by a given offset) is also supported.
+[ excerpt with some modifications from author's website ]
+
+GSubEdit, or GNOME Subtitle Editor, is a tool for editing and
+converting video subtitles. It currently features read/write of
+SubRip (.srt) and MicroDVD (.sub) subtitles. Framerate conversion
+and frame displacement (Increase/decrease all frames by a given
+offset) is also supported.
+
+Check the WWW site below for more information.
WWW: http://gsubedit.sourceforge.net/
diff --git a/graphics/gsubedit/pkg-plist b/graphics/gsubedit/pkg-plist
index 2ae2b753d5cb..93b8da86d4a3 100644
--- a/graphics/gsubedit/pkg-plist
+++ b/graphics/gsubedit/pkg-plist
@@ -1,12 +1,28 @@
bin/gsubedit
-%%PORTDOCS%%share/doc/gsubedit/AUTHORS
-%%PORTDOCS%%share/doc/gsubedit/ChangeLog
-%%PORTDOCS%%share/doc/gsubedit/INSTALL
-%%PORTDOCS%%share/doc/gsubedit/README
-%%PORTDOCS%%share/doc/gsubedit/TODO
+%%PORTDOCS%%share/doc/GSubEdit/ABOUT-NLS
+%%PORTDOCS%%share/doc/GSubEdit/AUTHORS
+%%PORTDOCS%%share/doc/GSubEdit/COPYING
+%%PORTDOCS%%share/doc/GSubEdit/ChangeLog
+%%PORTDOCS%%share/doc/GSubEdit/INSTALL
+%%PORTDOCS%%share/doc/GSubEdit/README
+%%PORTDOCS%%share/doc/GSubEdit/TODO
share/gnome/apps/Applications/gsubedit.desktop
share/gnome/help/gsubedit/C/index.html
share/gnome/help/gsubedit/C/topic.dat
share/gnome/pixmaps/gsubedit/gsubedit_icon.png
+share/locale/cs/LC_MESSAGES/gsubedit.mo
+share/locale/ro/LC_MESSAGES/gsubedit.mo
+share/locale/ru/LC_MESSAGES/gsubedit.mo
share/locale/sv/LC_MESSAGES/gsubedit.mo
-%%PORTDOCS%%@dirrm share/doc/gsubedit
+@unexec %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
+@unexec %D/share/locale/sv 2>/dev/null || true
+@unexec %D/share/locale/ru/LC_MESSAGES 2>/dev/null || true
+@unexec %D/share/locale/ru 2>/dev/null || true
+@unexec %D/share/locale/ro/LC_MESSAGES 2>/dev/null || true
+@unexec %D/share/locale/ro 2>/dev/null || true
+@unexec %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
+@unexec %D/share/locale/cs 2>/dev/null || true
+@dirrm share/gnome/pixmaps/gsubedit
+@dirrm share/gnome/help/gsubedit/C
+@dirrm share/gnome/help/gsubedit
+%%PORTDOCS%%@dirrm share/doc/GSubEdit