aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-03 03:11:48 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-03 03:11:48 +0000
commite8a1c10327028b8f0122ba3ab969a3456aa3d21b (patch)
tree9942daf25d9fc9f541cb86177080b9616c280c33 /graphics
parent5a1376bf46b8f68a45f72c3ce4e9ff7a6a361859 (diff)
downloadports-e8a1c10327028b8f0122ba3ab969a3456aa3d21b.tar.gz
ports-e8a1c10327028b8f0122ba3ab969a3456aa3d21b.zip
Add kudu.
Kudu is a GTK+ and OpenGL powered animation package, which relies mostly on skeletal animation and has an interface loosely based on the style of Wings3D. WWW: http://kudu.sourceforge.net/ PR: ports/95237 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=158688
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kudu/Makefile41
-rw-r--r--graphics/kudu/distinfo3
-rw-r--r--graphics/kudu/pkg-descr5
-rw-r--r--graphics/kudu/pkg-plist17
5 files changed, 67 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d4efd1415e5e..d4f1ca29d094 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -282,6 +282,7 @@
SUBDIR += kix-kmod
SUBDIR += kludge3d
SUBDIR += kooka
+ SUBDIR += kudu
SUBDIR += kuickshow
SUBDIR += landscape
SUBDIR += lcms
diff --git a/graphics/kudu/Makefile b/graphics/kudu/Makefile
new file mode 100644
index 000000000000..7f85c70a3a25
--- /dev/null
+++ b/graphics/kudu/Makefile
@@ -0,0 +1,41 @@
+# ports collection makefile for: kudu
+# Date created: 28 Mar 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kudu
+PORTVERSION= 0.0.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A 3D skeletal animation tool, powered by GTK+ and OpenGL
+
+LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
+
+USE_GL= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GCC= 3.4+
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib" \
+ LIBS="${PTHREAD_LIBS} -lcompat"
+
+DESKTOP_ENTRIES="Kudu" \
+ "Edit 3D models" \
+ "${DATADIR}/images/logo.png" \
+ "kudu" \
+ "Application;Graphics;" \
+ true
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|COPYING||' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/kudu/distinfo b/graphics/kudu/distinfo
new file mode 100644
index 000000000000..b4c01f85fd70
--- /dev/null
+++ b/graphics/kudu/distinfo
@@ -0,0 +1,3 @@
+MD5 (kudu-0.0.1.tar.bz2) = 8f2db02636a0e205393668c316825880
+SHA256 (kudu-0.0.1.tar.bz2) = 33e9ff9907fa7ddb080c9941c499bec5499d10c6fb62bc254f9d5f3eb9d60c8b
+SIZE (kudu-0.0.1.tar.bz2) = 210126
diff --git a/graphics/kudu/pkg-descr b/graphics/kudu/pkg-descr
new file mode 100644
index 000000000000..4339ed5ebd76
--- /dev/null
+++ b/graphics/kudu/pkg-descr
@@ -0,0 +1,5 @@
+Kudu is a GTK+ and OpenGL powered animation package, which relies
+mostly on skeletal animation and has an interface loosely based on
+the style of Wings3D.
+
+WWW: http://kudu.sourceforge.net/
diff --git a/graphics/kudu/pkg-plist b/graphics/kudu/pkg-plist
new file mode 100644
index 000000000000..e9df2e9b0752
--- /dev/null
+++ b/graphics/kudu/pkg-plist
@@ -0,0 +1,17 @@
+bin/kudu
+%%DATADIR%%/examples/claw.kudu
+%%DATADIR%%/examples/claw.rwx
+%%DATADIR%%/examples/figure.kudu
+%%DATADIR%%/examples/figure.rwx
+%%DATADIR%%/images/bone.png
+%%DATADIR%%/images/edge.png
+%%DATADIR%%/images/face.png
+%%DATADIR%%/images/logo.png
+%%DATADIR%%/images/object.png
+%%DATADIR%%/images/shape.png
+%%DATADIR%%/images/vertex.png
+%%DATADIR%%/scripts/Axle-Spinner.py
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%