aboutsummaryrefslogtreecommitdiff
path: root/hebrew
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-10 20:50:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-10 20:50:48 +0000
commit19721549fa2447145e6da7eb620da6c5305c548e (patch)
treef4466cf6a8682dbfa816628b56785f27b9c1a03b /hebrew
parentabc12d2526d7c049030197962d54c6cef6489530 (diff)
downloadports-19721549fa2447145e6da7eb620da6c5305c548e.tar.gz
ports-19721549fa2447145e6da7eb620da6c5305c548e.zip
Unbreak.
Notes
Notes: svn path=/head/; revision=111226
Diffstat (limited to 'hebrew')
-rw-r--r--hebrew/he2/Makefile10
-rw-r--r--hebrew/he2/files/patch-he2::hebSegment.cxx13
-rw-r--r--hebrew/he2/files/patch-he2::hebString.cxx11
3 files changed, 26 insertions, 8 deletions
diff --git a/hebrew/he2/Makefile b/hebrew/he2/Makefile
index fcfea89ffd1c..3c6e39eead88 100644
--- a/hebrew/he2/Makefile
+++ b/hebrew/he2/Makefile
@@ -18,15 +18,9 @@ COMMENT= An editor for editing (primarily LaTeX) Hebrew files
RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/hebrew:${PORTSDIR}/hebrew/elmar-fonts
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
+USE_LIBTOOL_VER= 13
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/hebrew/he2/files/patch-he2::hebSegment.cxx b/hebrew/he2/files/patch-he2::hebSegment.cxx
new file mode 100644
index 000000000000..0efc6bd8ebe6
--- /dev/null
+++ b/hebrew/he2/files/patch-he2::hebSegment.cxx
@@ -0,0 +1,13 @@
+--- ./he2/hebSegment.cxx.orig Wed Mar 14 10:04:03 2001
++++ ./he2/hebSegment.cxx Thu Jun 10 21:53:00 2004
+@@ -869,8 +869,8 @@
+
+ #define alpha "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ"
+ #define anum "0123456789*+=-?@!%^&~:'\".,;()`<>/|_"
+-#define alphanum alpha ## "0123456789*+=-?@!%^&~:'\".,;()`<>/|"
+-#define all alphanum ## "${}^[]"
++#define alphanum alpha "0123456789*+=-?@!%^&~:'\".,;()`<>/|"
++#define all alphanum "${}^[]"
+ int
+ hebSegment::_processLatexCommand(char *buffer, char **str, modeStack& stack)
+ {
diff --git a/hebrew/he2/files/patch-he2::hebString.cxx b/hebrew/he2/files/patch-he2::hebString.cxx
new file mode 100644
index 000000000000..2353599dc048
--- /dev/null
+++ b/hebrew/he2/files/patch-he2::hebString.cxx
@@ -0,0 +1,11 @@
+--- ./he2/hebString.cxx.orig Wed Mar 14 10:04:03 2001
++++ ./he2/hebString.cxx Thu Jun 10 21:31:44 2004
+@@ -21,7 +21,7 @@
+
+ #include "hebString.h"
+ #include <string.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <assert.h>
+
+