aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-04-18 02:04:44 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-04-18 02:04:44 +0000
commitb354619caeb6158786431a93e19985450a0279e8 (patch)
tree230421dc5499b47e3901c51d4b26838b885b9b8f /irc/bitchx/Makefile
parentd5181fd58f9292220513ef43ff230062d77bed2b (diff)
downloadports-b354619caeb6158786431a93e19985450a0279e8.tar.gz
ports-b354619caeb6158786431a93e19985450a0279e8.zip
Imported BitchX, yet another ircII-derived client.
PR: 5605 Submitted by: griffin@blackhole.iceworld.org
Notes
Notes: svn path=/head/; revision=10551
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
new file mode 100644
index 000000000000..6791d16308ff
--- /dev/null
+++ b/irc/bitchx/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: BitchX ircII client
+# Version required: 74p2
+# Date created: 26 Jan 1998
+# Whom: griffin
+#
+# $Id$
+#
+
+DISTNAME= ircii-pana-74p2
+PKGNAME= bitchx-74p2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/
+
+MAINTAINER= griffin@blackhole.iceworld.org
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/BitchX
+
+post-patch:
+ ${SED} -e s,__PREFIX__,$(PREFIX), $(WRKSRC)/include/config.h > $(WRKSRC)/include/config.h.new
+ ${MV} $(WRKSRC)/include/config.h.new $(WRKSRC)/include/config.h
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/BitchX
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/BitchX ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/wserv ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/BitchX.help ${PREFIX}/lib/BitchX
+
+.include <bsd.port.mk>