aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-04-15 15:36:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-04-15 15:36:26 +0000
commit81d2bace35ad4a04ce44ad2dc7b465482ad79647 (patch)
tree673d683b5706e224c43870b2f7acb55ce4023dc9 /irc/bitchx
parente18786ae0dc8b3f6e5b0baf90776fbb45e40ad5c (diff)
downloadports-81d2bace35ad4a04ce44ad2dc7b465482ad79647.tar.gz
ports-81d2bace35ad4a04ce44ad2dc7b465482ad79647.zip
Patch to make TCL work in BitchX.
PR: 26571 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=41431
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/bitchx/files/patch-az82
2 files changed, 83 insertions, 1 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 2ae299c91924..90ddcb100c96 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --exec-prefix="${PREFIX}/share" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L{LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib"
MAN1= BitchX.1
diff --git a/irc/bitchx/files/patch-az b/irc/bitchx/files/patch-az
new file mode 100644
index 000000000000..87bf725790b7
--- /dev/null
+++ b/irc/bitchx/files/patch-az
@@ -0,0 +1,82 @@
+--- configure.orig Sun Jan 7 23:24:22 2001
++++ configure Wed Apr 11 15:18:39 2001
+@@ -701,6 +701,7 @@
+ --with-ssl Enable SSL support
+ --with-tgetent Use tgetent (termcap) instead of setupterm (ncurses)
+ --with-tcl Enable Tcl support
++ --with-tcl-includes=PFX Prefix where tcl.h is installed (optional)
+ --with-maildir=PATH Enable QMAIL support
+ --with-default-server=SERVERNAME:PORT:PASSWORD:NICK:SERVERNETWORK
+ Connect to SERVERNAME by default
+@@ -9244,6 +9245,18 @@
+ #define WANT_TCL 1
+ EOF
+
++# Check whether --with-tcl-includes was given.
++if test "${with_tcl_includes+set}" = set; then
++ withval="$with_tcl_includes"
++ TCL_INCLUDE=-I$withval
++else
++ TCL_INCLUDE=-I/usr/local/include
++fi;
++
++cat >>confdefs.h <<\EOF
++#define WANT_TCL 1
++EOF
++
+ echo "$as_me:9247: checking for dlopen in -ldl" >&5
+ echo $ECHO_N "checking for dlopen in -ldl... $ECHO_C" >&6
+ if test "${ac_cv_lib_dl_dlopen+set}" = set; then
+@@ -9524,13 +9537,13 @@
+ TCL_LIBS="-ltcl"
+ else
+
+-echo "$as_me:9527: checking for Tcl_SetVar in -ltcl80" >&5
+-echo $ECHO_N "checking for Tcl_SetVar in -ltcl80... $ECHO_C" >&6
+-if test "${ac_cv_lib_tcl80_Tcl_SetVar+set}" = set; then
++echo "$as_me:9527: checking for Tcl_SetVar in -ltcl83" >&5
++echo $ECHO_N "checking for Tcl_SetVar in -ltcl83... $ECHO_C" >&6
++if test "${ac_cv_lib_tcl83_Tcl_SetVar+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-ltcl80 $LIBS"
++LIBS="-ltcl83 $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 9535 "configure"
+ #include "confdefs.h"
+@@ -9552,19 +9565,19 @@
+ _ACEOF
+ rm -f conftest.$ac_objext conftest$ac_exeext
+ if { (eval echo $as_me:9554: \"$ac_link\") >&5; (eval $ac_link) 2>&5; } && test -s conftest$ac_exeext; then
+- ac_cv_lib_tcl80_Tcl_SetVar=yes
++ ac_cv_lib_tcl83_Tcl_SetVar=yes
+ else
+ echo "$as_me: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+- ac_cv_lib_tcl80_Tcl_SetVar=no
++ ac_cv_lib_tcl83_Tcl_SetVar=no
+ fi
+ rm -f conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-echo "$as_me:9564: result: $ac_cv_lib_tcl80_Tcl_SetVar" >&5
+-echo "${ECHO_T}$ac_cv_lib_tcl80_Tcl_SetVar" >&6
+-if test $ac_cv_lib_tcl80_Tcl_SetVar = yes; then
+- TCL_LIBS="-ltcl80"
++echo "$as_me:9564: result: $ac_cv_lib_tcl83_Tcl_SetVar" >&5
++echo "${ECHO_T}$ac_cv_lib_tcl83_Tcl_SetVar" >&6
++if test $ac_cv_lib_tcl83_Tcl_SetVar = yes; then
++ TCL_LIBS="-ltcl83"
+ else
+
+ echo "$as_me:9570: checking for Tcl_SetVar in -ltcl76" >&5
+@@ -12023,7 +12036,7 @@
+ HINT_FILE="BitchX.hints"
+ fi
+
+-INCLUDES="-I. -I\$(topdir)/include -I\$(top_srcdir)/include -I\$(srcdir) -I\$(srcdir)/include"
++INCLUDES="-I. -I\$(topdir)/include -I\$(top_srcdir)/include -I\$(srcdir) -I\$(srcdir)/include $TCL_INCLUDE"
+
+ cat >>confdefs.h <<EOF
+ #define DEFAULT_CTOOLZ_DIR "$DEFAULT_CTOOLZ_DIR"