aboutsummaryrefslogtreecommitdiff
path: root/irc/ctrlproxy/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-04 16:07:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-04 16:07:55 +0000
commitf055edb2e0ec2bff3330b040b5d53bf973f6a422 (patch)
tree1cadd601af565d8e96d20225a45b28a0fc5cdf34 /irc/ctrlproxy/Makefile
parent3edbb5c2ee0a778a88e2d43501633f94f76422d4 (diff)
downloadports-f055edb2e0ec2bff3330b040b5d53bf973f6a422.tar.gz
ports-f055edb2e0ec2bff3330b040b5d53bf973f6a422.zip
- Update to version 2.6.1
PR: ports/63751 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=102922
Diffstat (limited to 'irc/ctrlproxy/Makefile')
-rw-r--r--irc/ctrlproxy/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 958e24735a09..627447915bfd 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= ctrlproxy
-PORTVERSION= 2.6
-PORTREVISION= 2
+PORTVERSION= 2.6.1
CATEGORIES= irc
MASTER_SITES= http://jelmer.vernstok.nl/ctrlproxy/
@@ -19,14 +18,11 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
pcre.0:${PORTSDIR}/devel/pcre \
tdb.1:${PORTSDIR}/databases/tdb
-USE_REINPLACE= yes
USE_OPENSSL= yes
-USE_GNOME= libxml2 glib20
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+USE_GNOME= glib20 libxml2
USE_GMAKE= yes
-MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= ctrlproxy.1
MAN5= ctrlproxyrc.5
@@ -37,8 +33,15 @@ MAN7= admin.7ctrlproxy antiflood.7ctrlproxy auto-away.7ctrlproxy \
repl_highlight.7ctrlproxy repl_none.7ctrlproxy repl_simple.7ctrlproxy \
socket.7ctrlproxy stats.7ctrlproxy strip.7ctrlproxy
-post-patch:
- @${FIND} ${WRKSRC} -name "*.c" | ${XARGS} ${GREP} -lR "malloc\.h" | \
- ${XARGS} ${REINPLACE_CMD} -e "s@malloc.h@stdlib.h@g"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+post-install:
+.if !defined(NOPORTDOC)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS TODO doc/ctrlproxy.html doc/ctrlproxy.pdf
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>