aboutsummaryrefslogtreecommitdiff
path: root/irc/darkbot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-25 16:54:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-25 16:54:32 +0000
commit615f8cad4749bf5fe6704c9f0872c32cce968307 (patch)
tree05fa0deb7ec63ec7688279c88c454bf1549e8e03 /irc/darkbot
parentf1b5086b0854b5e4d650dcbc032e895e20bc6746 (diff)
downloadports-615f8cad4749bf5fe6704c9f0872c32cce968307.tar.gz
ports-615f8cad4749bf5fe6704c9f0872c32cce968307.zip
- Support CC/CFLAGS properly
PR: 185312 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=341057
Diffstat (limited to 'irc/darkbot')
-rw-r--r--irc/darkbot/Makefile4
-rw-r--r--irc/darkbot/files/patch-Makefile12
2 files changed, 14 insertions, 2 deletions
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index 24ba85f3e78d..b12ac7e5e7ee 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= darkbot
PORTVERSION= 6f6.r6
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= irc
MASTER_SITES= http://darkbot.sourceforge.net/archive/unix/ \
@@ -21,7 +21,7 @@ PLIST_DIRSTRY= %%ETCDIR%%/logs/ %%ETCDIR%%/dat/ %%ETCDIR%%
.include <bsd.port.options.mk>
-post-patch:
+pre-configure:
${CP} ${WRKSRC}/configure ${WRKSRC}/config
do-install:
diff --git a/irc/darkbot/files/patch-Makefile b/irc/darkbot/files/patch-Makefile
index aecc689a1d72..778a4f6685dd 100644
--- a/irc/darkbot/files/patch-Makefile
+++ b/irc/darkbot/files/patch-Makefile
@@ -1,5 +1,17 @@
--- Makefile.orig Tue Apr 1 00:14:41 2003
+++ Makefile Tue Apr 1 00:23:28 2003
+@@ -11,9 +11,9 @@
+ # ..darkbot_debug.log, 'make debug2' #
+ # ------------------------------------------------ #
+
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -DFORK -O3
++CFLAGS += -DFORK
+
+ DFLAGS = -dm -pg -g -DDEBUG
+
@@ -23,14 +23,15 @@
ALL_SRC = darkbot.c