aboutsummaryrefslogtreecommitdiff
path: root/irc/insub
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2009-03-24 03:54:45 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2009-03-24 03:54:45 +0000
commit4d94dc6b92f48453f4d0ecc94280fb06bd93e8f2 (patch)
tree83497036581761ef8664d18193ab89887e8330e2 /irc/insub
parenta4478c2dc72c2df50f097611d92c7e5d5c17ae16 (diff)
downloadports-4d94dc6b92f48453f4d0ecc94280fb06bd93e8f2.tar.gz
ports-4d94dc6b92f48453f4d0ecc94280fb06bd93e8f2.zip
Update to 13.0 and clean up the Makefile.
PR: ports/132985 Submitted by: Edmondas Girkantas <eg@fbsd.lt>
Notes
Notes: svn path=/head/; revision=230830
Diffstat (limited to 'irc/insub')
-rw-r--r--irc/insub/Makefile39
-rw-r--r--irc/insub/distinfo6
2 files changed, 19 insertions, 26 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index 51b7030b6489..9759ef6ebfff 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -6,43 +6,36 @@
#
PORTNAME= insub
-PORTVERSION= 10.1
-#PORTREVISION= 1
+PORTVERSION= 13.0
CATEGORIES= irc
MASTER_SITES= http://gruntle.org/projects/irssi/insub/
MAINTAINER= adamw@FreeBSD.org
-COMMENT= Some scripts for expressing how you feel on irc and the web
+COMMENT= Some scripts for expressing how you feel on IRC and the web
NO_BUILD= YES
USE_BZIP2= YES
-USE_PERL5= YES
+USE_PERL5= 5.6+
-SCRIPT= ${PORTNAME}.pl
+SCRIPT= ${PORTNAME}.pl
-BUILD_DEPENDS+= cowsay:${PORTSDIR}/games/cowsay
-RUN_DEPENDS+= figlet:${PORTSDIR}/misc/figlet
-RUN_DEPENDS+= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
-
-.include <bsd.port.pre.mk>
+RUN_DEPENDS= cowsay:${PORTSDIR}/games/cowsay \
+ figlet:${PORTSDIR}/misc/figlet
post-install:
@${ECHO}
- @${ECHO} " insub has been installed in irssi's global script store."
- @${ECHO} " To run, you should type '/script load insub' from within"
- @${ECHO} " the irssi client."
+ @${ECHO} " To use insub in irssi, type '/script load insub'"
+ @${ECHO} " from within the irssi client."
@${ECHO}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${LOCALBASE}/bin/${SCRIPT:R}
- ${MKDIR} ${LOCALBASE}/share/irssi/scripts/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${PREFIX}/bin/${SCRIPT:R}
+ ${MKDIR} ${PREFIX}/share/irssi/scripts/
${INSTALL_DATA} ${WRKSRC}/${SCRIPT} \
- ${LOCALBASE}/share/irssi/scripts/${SCRIPT}
- for i in ${WRKSRC}/cows/* ; do \
- case `basename $$i` in \
- *) ${INSTALL_DATA} $$i ${LOCALBASE}/share/cows; \
- esac \
- done
-
-.include <bsd.port.post.mk>
+ ${PREFIX}/share/irssi/scripts/${SCRIPT}
+ ${MKDIR} ${PREFIX}/share/cows/
+ cd ${WRKSRC} && \
+ ${FIND} cows | ${CPIO} -pdmvu ${PREFIX}/share/
+
+.include <bsd.port.mk>
diff --git a/irc/insub/distinfo b/irc/insub/distinfo
index ad49194f773e..51a7105e30c7 100644
--- a/irc/insub/distinfo
+++ b/irc/insub/distinfo
@@ -1,3 +1,3 @@
-MD5 (insub-10.1.tar.bz2) = 08ff17ed320c55f845bd4ee787d1a447
-SHA256 (insub-10.1.tar.bz2) = 5bad917c62797c030446ae1c7b6aaab4558a90909e4504caacb70a76861da731
-SIZE (insub-10.1.tar.bz2) = 45320
+MD5 (insub-13.0.tar.bz2) = aaa30bd86f53e33f57cbfb862d05709d
+SHA256 (insub-13.0.tar.bz2) = 1cfe5c678fa164d7139cca8b8fe04ee35ecfa12354b0e385f21ea142f4ff35a2
+SIZE (insub-13.0.tar.bz2) = 50913