aboutsummaryrefslogtreecommitdiff
path: root/irc/irc/Makefile
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>1994-08-27 12:17:10 +0000
committerTorsten Blum <torstenb@FreeBSD.org>1994-08-27 12:17:10 +0000
commit09bbbfdc3a652eaa8f48f561a6ba318559f5a6b7 (patch)
tree131758c23fea637025af3a253d0d82f94f3c80f2 /irc/irc/Makefile
parent2d6732d1852e47bca6622b0107b0b2d89a502cf7 (diff)
downloadports-09bbbfdc3a652eaa8f48f561a6ba318559f5a6b7.tar.gz
ports-09bbbfdc3a652eaa8f48f561a6ba318559f5a6b7.zip
Initial import for irc (version 2.8.20) port.
Submitted by: torstenb
Notes
Notes: svn path=/head/; revision=42
Diffstat (limited to 'irc/irc/Makefile')
-rw-r--r--irc/irc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
new file mode 100644
index 000000000000..0263094c0f5a
--- /dev/null
+++ b/irc/irc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Irc Server
+# Version required: 2.8.20
+# Date created: 23 August 1994
+# Whom: torstenb
+#
+# $Id:$
+#
+
+.if !defined(prefix)
+prefix= /usr/local
+.endif
+
+DISTNAME= irc2.8.20
+HOME_LOCATION= ftp://cs-ftp.bu.edu/irc/servers/
+
+pre-install:
+ @if [ ! -d $(prefix)/bin ]; then \
+ mkdir -p $(prefix)/bin; \
+ fi
+ @if [ ! -d $(prefix)/lib/ircd ]; then \
+ mkdir -p $(prefix)/lib/ircd; \
+ fi
+ @if [ ! -d $(prefix)/man/man1 ]; then \
+ mkdir -p $(prefix)/man/man1; \
+ fi
+ @if [ ! -d $(prefix)/man/man8 ]; then \
+ mkdir -p $(prefix)/man/man8; \
+ fi
+
+.include <bsd.port.mk>