aboutsummaryrefslogtreecommitdiff
path: root/irc/party
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-25 15:59:36 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-25 15:59:36 +0000
commit31a52f1525510caa06a6d281b10e1f9343fe89d8 (patch)
tree59783db83be05d860f660ab17ba2e71b3e3f3bee /irc/party
parent4b351344cf34af685e9ebffa37276d3eb61b01ff (diff)
downloadports-31a52f1525510caa06a6d281b10e1f9343fe89d8.tar.gz
ports-31a52f1525510caa06a6d281b10e1f9343fe89d8.zip
party version 2.12
A simple multiuser chat system. PR: 15258 Submitted by: James Howard <howardj@wam.umd.edu>
Notes
Notes: svn path=/head/; revision=24063
Diffstat (limited to 'irc/party')
-rw-r--r--irc/party/Makefile32
-rw-r--r--irc/party/distinfo1
-rw-r--r--irc/party/pkg-comment1
-rw-r--r--irc/party/pkg-descr11
-rw-r--r--irc/party/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/irc/party/Makefile b/irc/party/Makefile
new file mode 100644
index 000000000000..8d9b398c7ce6
--- /dev/null
+++ b/irc/party/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: party
+# Version required: 2.12
+# Date created: 4 December 1999
+# Whom: James Howard <howardj@wam.umd.edu>
+#
+# $FreeBSD$
+#
+
+DISTNAME= party-2.12
+CATEGORIES= irc
+MASTER_SITES= ftp://ftp.wam.umd.edu/pub/howardjp/software/party/ \
+ http://www.wam.umd.edu/~howardjp/software/party/ \
+ ftp://dragon.ham.muohio.edu/pub/howardjp/software/party/
+
+MAINTAINER= howardjp@wam.umd.edu
+
+MAN1= party.1
+
+do-install:
+ ${INSTALL_SCRIPT} -g nobody -o nobody -m 4711 ${WRKSRC}/party ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/lib/party
+ ${MKDIR} ${PREFIX}/lib/party/log
+ ${INSTALL_SCRIPT} ${WRKSRC}/chantab ${WRKSRC}/partytab ${PREFIX}/lib/party
+ ${TOUCH} ${PREFIX}/lib/party/partytmp
+ ${TOUCH} ${PREFIX}/lib/party/log/party.log
+ ${CHOWN} -R nobody:nobody ${PREFIX}/lib/party
+ ${CP} ${WRKSRC}/party.1 ${PREFIX}/man/man1/
+
+post-extract:
+ @(cd ${WRKSRC}; ${RM} -f .depend)
+
+.include <bsd.port.mk>
diff --git a/irc/party/distinfo b/irc/party/distinfo
new file mode 100644
index 000000000000..37808a789674
--- /dev/null
+++ b/irc/party/distinfo
@@ -0,0 +1 @@
+MD5 (party-2.12.tar.gz) = 356577d15463016fefee465976fde554
diff --git a/irc/party/pkg-comment b/irc/party/pkg-comment
new file mode 100644
index 000000000000..136b82bf4496
--- /dev/null
+++ b/irc/party/pkg-comment
@@ -0,0 +1 @@
+Simple multi-user chat system
diff --git a/irc/party/pkg-descr b/irc/party/pkg-descr
new file mode 100644
index 000000000000..646fcbf64e24
--- /dev/null
+++ b/irc/party/pkg-descr
@@ -0,0 +1,11 @@
+Party is a real-time chat program for Unix systems. It simulates a party
+line, where any number of users can talk at the same time - if you type a
+line of text, everyone else sees it immediately.
+
+Chat programs are pretty common these days. Party wasn't the first, but it
+was an early one. It's antiquity is reflected in the fact that it doesn't
+support networked systems especially well, nor have a web
+interface. However, its maturity is reflected in the fact that it has a
+clean and simple interface, and a good set of well-integrated features
+that make it easy for first-timers to get into. It remains very popular to
+this day on several systems.
diff --git a/irc/party/pkg-plist b/irc/party/pkg-plist
new file mode 100644
index 000000000000..7cf4747c5a6b
--- /dev/null
+++ b/irc/party/pkg-plist
@@ -0,0 +1,9 @@
+@owner nobody
+@group nobody
+bin/party
+lib/party/chantab
+lib/party/partytab
+lib/party/partytmp
+lib/party/log/party.log
+@dirrm lib/party/log
+@dirrm lib/party