aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-07-03 11:01:36 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-07-03 11:01:36 +0000
commit1ba78c8b216957df89835928665cc8b2fe7f4539 (patch)
treebe2285342494313ef1ae31a739076da09f37ed8b /irc/weechat
parent5105780a5635f01d48cfd054fd4b4fa58767c711 (diff)
downloadports-1ba78c8b216957df89835928665cc8b2fe7f4539.tar.gz
ports-1ba78c8b216957df89835928665cc8b2fe7f4539.zip
- Update to version 0.1.9
- Fix bug with NLS (thanks to kolter@freenode[weechat]) - Add new plugin language (ruby) - Add support of doing secure connection to irc server (gnutls) - Switch from PLIST to pkg-plist for better Makefile reading - Disabled plugin language LUA (if someone want it, just ask me)
Notes
Notes: svn path=/head/; revision=166826
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile82
-rw-r--r--irc/weechat/distinfo6
-rw-r--r--irc/weechat/files/patch-configure47
-rw-r--r--irc/weechat/pkg-plist29
4 files changed, 127 insertions, 37 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 5cec5f39ee0e..8bdabd1b6854 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= weechat
-PORTVERSION= 0.1.7
+PORTVERSION= 0.1.9
CATEGORIES= irc
MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
http://weechat.flashtux.org/download/
@@ -15,52 +15,66 @@ MAINTAINER= az@FreeBSD.org
COMMENT= A lightweight and user friendly ncurse based IRC client
USE_BZIP2= yes
+USE_ICONV= yes
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL
+CONFIGURE_ARGS= --disable-lua
-MAN1= weechat-curses.1
+MAN1= weechat-curses.1
-PLIST_FILES= bin/weechat-curses
-PLIST_DIRS= lib/weechat/plugins lib/weechat
-
-.for lang in cs fr es
-PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/weechat.mo
-.endfor
-
-PLIST_FILES+= %%DOCSDIR%%/html/en/weechat-doc.css %%DOCSDIR%%/html/fr/weechat-doc.css
-PLIST_DIRS+= %%DOCSDIR%%/html/en %%DOCSDIR%%/html/fr %%DOCSDIR%%/html %%DOCSDIR%%
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debug=2
+.else
+CONFIGURE_ARGS+= --with-debug=0
+.endif
-.if !defined(WITHOUT_NLS)
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+= --enable-python
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
.else
-BROKEN= "Does not compile without gettext"
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.if defined(WITH_RUBY)
+CONFIGURE_ARGS+= --enable-ruby
+USE_RUBY= yes
+PLIST_SUB+= RUBY=""
+.else
+CONFIGURE_ARGS+= --disable-ruby
+PLIST_SUB+= RUBY="@comment "
+.endif
+
+.if defined(WITH_GNUTLS)
+CONFIGURE_ARGS+= --enable-gnutls
+LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= --disable-gnu-tls
.endif
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PERL)
.if ${PERL_LEVEL} < 500600
IGNORE= this port requires perl 5.6.0 or later, Install lang/perl5 then try again
.else
-CONFIGURE_ARGS+=--enable-perl
-USE_PERL5= yes
-PLIST_FILES+= lib/weechat/plugins/libperl.a lib/weechat/plugins/libperl.la \
- lib/weechat/plugins/libperl.so lib/weechat/plugins/libperl.so.0
+CONFIGURE_ARGS+= --enable-perl
+USE_PERL= yes
+PLIST_SUB+= PERL=""
.endif
+.else
+CONFIGURE_ARGS+= --disable-perl
+PLIST_SUB+= PERL="@comment "
.endif
-.if defined(WITH_PYTHON)
-CONFIGURE_ARGS+=--enable-python
-USE_PYTHON= yes
-PLIST_FILES+= lib/weechat/plugins/libpython.a lib/weechat/plugins/libpython.la \
- lib/weechat/plugins/libpython.so lib/weechat/plugins/libpython.so.0
-.endif
-
-pre-configure:
- @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
index d2607630a2d4..c1fcf7141ec0 100644
--- a/irc/weechat/distinfo
+++ b/irc/weechat/distinfo
@@ -1,3 +1,3 @@
-MD5 (weechat-0.1.7.tar.bz2) = 917383433fdc4f64979e0fa301a8d086
-SHA256 (weechat-0.1.7.tar.bz2) = a09f950adc9eacdfc45321e6fd1340299600016f7e0ac92da69784d26b77cbff
-SIZE (weechat-0.1.7.tar.bz2) = 748390
+MD5 (weechat-0.1.9.tar.bz2) = 0caed065da9a4ba34834eadad67dac97
+SHA256 (weechat-0.1.9.tar.bz2) = d66f6b29f12436818b3a35181e985a2f0b1d0ba9cf0d89d376c02d9bfa865f0c
+SIZE (weechat-0.1.9.tar.bz2) = 999710
diff --git a/irc/weechat/files/patch-configure b/irc/weechat/files/patch-configure
new file mode 100644
index 000000000000..e8c9d2758c92
--- /dev/null
+++ b/irc/weechat/files/patch-configure
@@ -0,0 +1,47 @@
+--- configure.in.orig Thu May 25 02:46:22 2006
++++ configure.in Sat Jun 17 00:39:13 2006
+@@ -537,6 +537,44 @@
+ fi
+
+ # ------------------------------------------------------------------------------
++# iconv
++# ------------------------------------------------------------------------------
++
++iconv_found="no"
++
++AC_CHECK_HEADER(iconv.h,ac_found_iconv_header="yes",ac_found_iconv_header="no")
++if test "x$ac_found_iconv_header" = "xyes" ; then
++ AC_CHECK_LIB(iconv,iconv_open,ac_found_iconv_lib="yes",ac_found_iconv_lib="no")
++ if test "x$ac_found_iconv_lib" = "xyes" ; then
++ LIBS="$LIBS -liconv"
++ fi
++ AC_MSG_CHECKING(for iconv usability in programs)
++ AC_TRY_RUN([
++ #include <iconv.h>
++ int main(int argc, char **argv) {
++ iconv_t conv = iconv_open("ISO8859-1", "UTF-8");
++ if (conv != (iconv_t) -1) {
++ return 0;
++ }
++ return 1;
++ }],iconv_found="yes")
++ if test "x$iconv_found" = "xno" ; then
++ AC_MSG_RESULT(no)
++ else
++ AC_MSG_RESULT(yes)
++ fi
++fi
++
++if test "x$iconv_found" = "xno" ; then
++ AC_MSG_ERROR([
++*** Iconv headers and/or libraries couldn't be found in your system.
++*** Try to install them with your software package manager.
++*** WeeChat can't be built without Iconv support.])
++fi
++
++
++
++# ------------------------------------------------------------------------------
+ # general vars
+ # ------------------------------------------------------------------------------
+
diff --git a/irc/weechat/pkg-plist b/irc/weechat/pkg-plist
new file mode 100644
index 000000000000..ffe1933e4fec
--- /dev/null
+++ b/irc/weechat/pkg-plist
@@ -0,0 +1,29 @@
+bin/weechat-curses
+%%DOCSDIR%%/html/en/weechat-doc.css
+%%DOCSDIR%%/html/fr/weechat-doc.css
+%%DOCSDIR%%/html/de/weechat-doc.css
+%%NLS%%share/locale/de/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/es/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/weechat.mo
+%%PYTHON%%lib/weechat/plugins/libpython.so.0
+%%PYTHON%%lib/weechat/plugins/libpython.so
+%%PYTHON%%lib/weechat/plugins/libpython.la
+%%PYTHON%%lib/weechat/plugins/libpython.a
+%%PERL%%lib/weechat/plugins/libperl.so.0
+%%PERL%%lib/weechat/plugins/libperl.so
+%%PERL%%lib/weechat/plugins/libperl.la
+%%PERL%%lib/weechat/plugins/libperl.a
+%%RUBY%%lib/weechat/plugins/libruby.so.0
+%%RUBY%%lib/weechat/plugins/libruby.so
+%%RUBY%%lib/weechat/plugins/libruby.la
+%%RUBY%%lib/weechat/plugins/libruby.a
+@dirrmtry %%DOCSDIR%%/html/fr
+@dirrmtry %%DOCSDIR%%/html/en
+@dirrmtry %%DOCSDIR%%/html/de
+@dirrmtry %%DOCSDIR%%/html
+@dirrmtry %%DOCSDIR%%
+@dirrmtry lib/weechat/plugins
+@dirrmtry lib/weechat