aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-gnome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-25 20:11:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-25 20:11:48 +0000
commit28d4c2a7be41a939a6c6ef008e53708d03228cbf (patch)
treeefbacaedefc09e5bdb285a196e770efdc6d91f4f /irc/xchat-gnome
parente82e60987a5e00137f41d03dcdb5ce0cccca9825 (diff)
downloadports-28d4c2a7be41a939a6c6ef008e53708d03228cbf.tar.gz
ports-28d4c2a7be41a939a6c6ef008e53708d03228cbf.zip
- Update to 0.11
PR: ports/97454 Submitted by: Tim Welch <twelch@thepentagon.org>
Notes
Notes: svn path=/head/; revision=163398
Diffstat (limited to 'irc/xchat-gnome')
-rw-r--r--irc/xchat-gnome/Makefile40
-rw-r--r--irc/xchat-gnome/distinfo6
-rw-r--r--irc/xchat-gnome/files/patch-configure11
-rw-r--r--irc/xchat-gnome/pkg-plist134
4 files changed, 125 insertions, 66 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 6f07f826dfc4..9bbb6c84e08d 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -6,37 +6,51 @@
#
PORTNAME= xchat
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.11
CATEGORIES= irc gnome ipv6
-MASTER_SITES= http://flapjack.navi.cx/releases/xchat-gnome/
+MASTER_SITES= http://releases.navi.cx/xchat-gnome/
PKGNAMESUFFIX= -gnome
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An IRC client for GNOME 2 (development version)
+LIB_DEPENDS= sexy:${PORTSDIR}/x11-toolkits/libsexy \
+ notify:${PORTSDIR}/devel/libnotify
+
USE_X_PREFIX= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack libgnomeui
+USE_GNOME= gnomehack libgnomeui gnomedocutils desktopfileutils
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --enable-nls \
- --enable-ipv6 \
- --enable-gnomefe
-
+CONFIGURE_ARGS= --disable-tcl
GCONF_SCHEMAS= apps_xchat.schemas notification.schemas urlscraper.schemas
-
-CONFLICTS= xchat-1* xchat2-2*
+INSTALLS_ICONS= yes
+INSTALLS_OMF= yes
+
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS+= dbus-1.2:${PORTSDIR}/devel/dbus
+CONFIGURE_ARGS+= --enable-dbus
+USE_GNOME+= gconf2
+GCONF_SCHEMAS+= xchat_gnome_url_handler.schemas
+PLIST_SUB+= DBUS=""
+.else
+CONFIGURE_ARGS+=--disable-dbus
+PLIST_SUB+= DBUS="@comment "
+.endif
.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
# openssl in now default in configure
.if defined(WITH_PYTHON)
@@ -51,7 +65,7 @@ PLIST_SUB+= PYTHON="@comment "
.if defined(WITH_TCL)
LIB_DEPENDS+= tcl83.1:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--enable-tcl=${LOCALBASE}/lib/tcl8.3
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include/tcl8.3" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-L${LOCALBASE}/lib/tcl8.3"
@@ -98,8 +112,4 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
${WRKSRC}/configure
-# Create plugins directory even when no plugins are installed
-post-install:
- @${MKDIR} ${PREFIX}/lib/xchat/plugins
-
.include <bsd.port.post.mk>
diff --git a/irc/xchat-gnome/distinfo b/irc/xchat-gnome/distinfo
index c50491445d1e..f82757e775c8 100644
--- a/irc/xchat-gnome/distinfo
+++ b/irc/xchat-gnome/distinfo
@@ -1,3 +1,3 @@
-MD5 (xchat-gnome-0.5.tar.bz2) = 5b2a8a3abae883f68695d9bcf65a568b
-SHA256 (xchat-gnome-0.5.tar.bz2) = 173f4f08ec8dbd6807b8af399e88d79d64346e84b3c38eda4825c2635570d845
-SIZE (xchat-gnome-0.5.tar.bz2) = 2203619
+MD5 (xchat-gnome-0.11.tar.bz2) = dd0d52c7abd419b7559e32a35fea70f4
+SHA256 (xchat-gnome-0.11.tar.bz2) = f3efb3895aea5dab0905ad4965be43694a5b20e25448cee944e3a19f0036c2db
+SIZE (xchat-gnome-0.11.tar.bz2) = 1281509
diff --git a/irc/xchat-gnome/files/patch-configure b/irc/xchat-gnome/files/patch-configure
new file mode 100644
index 000000000000..06e581835c0d
--- /dev/null
+++ b/irc/xchat-gnome/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu May 18 06:42:21 2006
++++ configure Thu May 18 06:41:27 2006
+@@ -21768,7 +21768,7 @@
+
+ if test "x$have_tcl" != "xno"; then
+ have_tcl=no
+- for dir in $tcl /lib /usr/lib /usr/tcl/lib /usr/local/lib /usr/local/tcl-8.4/lib /usr/local/tcl/lib /opt/lib; do
++ for dir in $enable_tcl /lib /usr/lib /usr/tcl/lib /usr/local/lib /usr/local/tcl-8.4/lib /usr/local/tcl/lib /opt/lib; do
+ if test -f $dir/tclConfig.sh; then
+ . $dir/tclConfig.sh
+ TCL_LIBS="$TCL_LIB_SPEC $TCL_LIBS"
diff --git a/irc/xchat-gnome/pkg-plist b/irc/xchat-gnome/pkg-plist
index c68800d193f5..ee25c5b74630 100644
--- a/irc/xchat-gnome/pkg-plist
+++ b/irc/xchat-gnome/pkg-plist
@@ -1,42 +1,40 @@
-bin/xchat
bin/xchat-gnome
-%%PERL%%lib/xchat/plugins/perl.la
-%%PERL%%lib/xchat/plugins/perl.so
-%%PYTHON%%lib/xchat/plugins/python.la
-%%PYTHON%%lib/xchat/plugins/python.so
-%%TCL%%lib/xchat/plugins/tcl.la
-%%TCL%%lib/xchat/plugins/tcl.so
-lib/xchat/plugins/notification.la
-lib/xchat/plugins/notification.so
-lib/xchat/plugins/urlscraper.la
-lib/xchat/plugins/urlscraper.so
+bin/xchat-gnome-remote
+%%DBUS%%lib/xchat-gnome/plugins/dbus.a
+%%DBUS%%lib/xchat-gnome/plugins/dbus.la
+%%DBUS%%lib/xchat-gnome/plugins/dbus.so
+%%DBUS%%lib/xchat-gnome/plugins/netmonitor.a
+%%DBUS%%lib/xchat-gnome/plugins/netmonitor.la
+%%DBUS%%lib/xchat-gnome/plugins/netmonitor.so
+%%PERL%%lib/xchat-gnome/plugins/perl.a
+%%PERL%%lib/xchat-gnome/plugins/perl.la
+%%PERL%%lib/xchat-gnome/plugins/perl.so
+%%PYTHON%%lib/xchat-gnome/plugins/python.a
+%%PYTHON%%lib/xchat-gnome/plugins/python.la
+%%PYTHON%%lib/xchat-gnome/plugins/python.so
+%%TCL%%lib/xchat-gnome/plugins/tcl.a
+%%TCL%%lib/xchat-gnome/plugins/tcl.la
+%%TCL%%lib/xchat-gnome/plugins/tcl.so
+lib/xchat-gnome/plugins/autoaway.a
+lib/xchat-gnome/plugins/autoaway.la
+lib/xchat-gnome/plugins/autoaway.so
+lib/xchat-gnome/plugins/notification.a
+lib/xchat-gnome/plugins/notification.la
+lib/xchat-gnome/plugins/notification.so
+lib/xchat-gnome/plugins/notifyosd.a
+lib/xchat-gnome/plugins/notifyosd.la
+lib/xchat-gnome/plugins/notifyosd.so
+lib/xchat-gnome/plugins/soundnotification.a
+lib/xchat-gnome/plugins/soundnotification.la
+lib/xchat-gnome/plugins/soundnotification.so
+lib/xchat-gnome/plugins/urlscraper.a
+lib/xchat-gnome/plugins/urlscraper.la
+lib/xchat-gnome/plugins/urlscraper.so
share/applications/xchat-gnome.desktop
-share/applications/xchat.desktop
-share/pixmaps/xchat-gnome.png
-share/pixmaps/xchat.png
-share/xchat/channel-list.glade
-share/xchat/color.png
-share/xchat/connect-dialog.glade
-share/xchat/dcc.png
-share/xchat/dcc-window.glade
-share/xchat/global-message.png
-share/xchat/irc.png
-share/xchat/irc-network-editor.glade
-share/xchat/newdata.png
-share/xchat/nicksaid.png
-share/xchat/plugin-manager.png
-share/xchat/preferences-dialog.glade
-share/xchat/servers.png
-share/xchat/setup-dialog.glade
-share/xchat/soap.png
-share/xchat/stock_down.png
-share/xchat/stock_link.png
-share/xchat/stock_up.png
-share/xchat/toilet-paper.png
-share/xchat/topic-change.glade
-share/xchat/xchat-gnome-small.png
-share/xchat/xchat-gnome.glade
-share/xchat/xchat-gnome-ui.xml
+share/gnome/help/xchat-gnome/C/figures/xchat-gnome_main_window.png
+share/gnome/help/xchat-gnome/C/legal.xml
+share/gnome/help/xchat-gnome/C/xchat-gnome.xml
+share/icons/hicolor/48x48/apps/xchat-gnome.png
share/locale/am/LC_MESSAGES/xchat-gnome.mo
share/locale/az/LC_MESSAGES/xchat-gnome.mo
share/locale/bg/LC_MESSAGES/xchat-gnome.mo
@@ -50,9 +48,12 @@ share/locale/et/LC_MESSAGES/xchat-gnome.mo
share/locale/eu/LC_MESSAGES/xchat-gnome.mo
share/locale/fi/LC_MESSAGES/xchat-gnome.mo
share/locale/fr/LC_MESSAGES/xchat-gnome.mo
+share/locale/gl/LC_MESSAGES/xchat-gnome.mo
share/locale/hi/LC_MESSAGES/xchat-gnome.mo
+share/locale/hu/LC_MESSAGES/xchat-gnome.mo
share/locale/it/LC_MESSAGES/xchat-gnome.mo
share/locale/ja/LC_MESSAGES/xchat-gnome.mo
+share/locale/ka/LC_MESSAGES/xchat-gnome.mo
share/locale/ko/LC_MESSAGES/xchat-gnome.mo
share/locale/lt/LC_MESSAGES/xchat-gnome.mo
share/locale/lv/LC_MESSAGES/xchat-gnome.mo
@@ -62,6 +63,7 @@ share/locale/nb/LC_MESSAGES/xchat-gnome.mo
share/locale/nl/LC_MESSAGES/xchat-gnome.mo
share/locale/no/LC_MESSAGES/xchat-gnome.mo
share/locale/pa/LC_MESSAGES/xchat-gnome.mo
+share/locale/pl/LC_MESSAGES/xchat-gnome.mo
share/locale/pt/LC_MESSAGES/xchat-gnome.mo
share/locale/pt_BR/LC_MESSAGES/xchat-gnome.mo
share/locale/ru/LC_MESSAGES/xchat-gnome.mo
@@ -75,15 +77,51 @@ share/locale/vi/LC_MESSAGES/xchat-gnome.mo
share/locale/wa/LC_MESSAGES/xchat-gnome.mo
share/locale/zh_CN/LC_MESSAGES/xchat-gnome.mo
share/locale/zh_TW/LC_MESSAGES/xchat-gnome.mo
-share/xchat/about.png
-share/xchat/book.png
-share/xchat/hop.png
-share/xchat/op.png
-share/xchat/purple.png
-share/xchat/red.png
-share/xchat/voice.png
-@exec mkdir -p %D/lib/xchat/plugins
-@dirrm share/xchat
+share/omf/xchat-gnome/xchat-gnome-C.omf
+share/xchat-gnome/channel-list.glade
+share/xchat-gnome/color.png
+share/xchat-gnome/connect-dialog.glade
+share/xchat-gnome/dcc-window.glade
+share/xchat-gnome/dcc.png
+share/xchat-gnome/effects.png
+share/xchat-gnome/global-message.png
+share/xchat-gnome/hop.png
+share/xchat-gnome/irc-network-editor.glade
+share/xchat-gnome/irc.png
+share/xchat-gnome/logout.png
+share/xchat-gnome/message.wav
+share/xchat-gnome/newdata.png
+share/xchat-gnome/nicksaid.png
+share/xchat-gnome/notauthorized.png
+share/xchat-gnome/op.png
+share/xchat-gnome/plugin-manager.png
+share/xchat-gnome/preferences-dialog.glade
+share/xchat-gnome/preferences-keybindings.png
+share/xchat-gnome/purple.png
+share/xchat-gnome/red.png
+share/xchat-gnome/servers.png
+share/xchat-gnome/setup-dialog.glade
+share/xchat-gnome/soap.png
+share/xchat-gnome/spellcheck.png
+share/xchat-gnome/stock_down.png
+share/xchat-gnome/stock_link.png
+share/xchat-gnome/stock_up.png
+share/xchat-gnome/toilet-paper.png
+share/xchat-gnome/topic-change.glade
+share/xchat-gnome/users.png
+share/xchat-gnome/voice.png
+share/xchat-gnome/wrap.png
+share/xchat-gnome/xchat-gnome-ui.xml
+share/xchat-gnome/xchat-gnome.glade
+share/xchat-gnome/xchat-gnome.png
+@dirrm share/xchat-gnome
+@dirrm share/omf/xchat-gnome
+@dirrm share/gnome/help/xchat-gnome/C/figures
+@dirrm share/gnome/help/xchat-gnome/C
+@dirrm share/gnome/help/xchat-gnome
+@dirrm lib/xchat-gnome/plugins
+@dirrm lib/xchat-gnome
@dirrmtry share/applications
-@dirrm lib/xchat/plugins
-@dirrm lib/xchat
+@dirrmtry share/omf
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true