aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-04-15 01:08:23 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-04-15 01:08:23 +0000
commit56d835d7e8aeda4ca2285cb02cba916d536edf75 (patch)
tree17b84c6a30ca6ab2afb6e90481c12b68692e9d01 /irc
parent851b613b5b3b927708729dcbbb59f7d89b4f5c65 (diff)
downloadports-56d835d7e8aeda4ca2285cb02cba916d536edf75.tar.gz
ports-56d835d7e8aeda4ca2285cb02cba916d536edf75.zip
- Update to 0.3.8
- Add optional ruby support - Add optional libiconv support - Use bzip2 distfiles - Remove hard wired versioning in pkg-plist PR: ports/122641 Submitted by: Josh Paetzel <josh@tcbug.org> (maintainer)
Notes
Notes: svn path=/head/; revision=211273
Diffstat (limited to 'irc')
-rw-r--r--irc/epic5/Makefile37
-rw-r--r--irc/epic5/distinfo6
-rw-r--r--irc/epic5/pkg-plist2
3 files changed, 38 insertions, 7 deletions
diff --git a/irc/epic5/Makefile b/irc/epic5/Makefile
index 636262c4eef2..3edefcccd532 100644
--- a/irc/epic5/Makefile
+++ b/irc/epic5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= epic5
-PORTVERSION= 0.3.5
+PORTVERSION= 0.3.8
CATEGORIES= irc ipv6
MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC5-BETA/ \
http://tehran.lain.pl/epic-mirror/EPIC5-BETA/ \
@@ -22,11 +22,16 @@ SUB_FILES= pkg-message
GNU_CONFIGURE= yes
MAN1= epic5.1
USE_OPENSSL= yes
-CONFIGURE_ARGS+= --without-ruby
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+USE_BZIP2= yes
+CFLAGS:= ${CFLAGS:C/-O2/-g -O/g}
OPTIONS= IPV6 "IPv6 support" on \
TCL "TCL support" on \
- PERL "Perl scripting support" off
+ PERL "Perl scripting support" on \
+ RUBY "Ruby scripting support" on \
+ TERMCAP "Refure to use terminfo/ncurses" off \
+ ICONV "Enable experimental iconv support" off
.include <bsd.port.pre.mk>
@@ -55,8 +60,34 @@ CONFIGURE_ARGS+= --without-tcl
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
+.else
+CONFIGURE_ARGS+= --without-perl
+.endif
+
+## WITH_RUBY: enable ruby scripting support
+#
+.if defined(WITH_RUBY)
+USE_RUBY= yes
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+CONFIGURE_ARGS+= --with-ruby
+.else
+CONFIGURE_ARGS+= --without-ruby
.endif
+## WITH_TERMCAP forecably refuse to use terminfo/ncurses
+#
+.if defined(WITH_TERMCAP)
+CONFIGURE_ARGS+= --with-termcap
+.endif
+
+## WITH_ICON experimental iconv support
+#
+.if defined(WITH_ICONV)
+LIB_DEPENDS+= iconv:${PORTSDIR}/converters/libiconv
+CONFIGURE_ARGS+= --with-iconv
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
post-extract:
@${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -rf
diff --git a/irc/epic5/distinfo b/irc/epic5/distinfo
index 640069ae112e..192bb28a07b6 100644
--- a/irc/epic5/distinfo
+++ b/irc/epic5/distinfo
@@ -1,3 +1,3 @@
-MD5 (epic5-0.3.5.tar.gz) = 5d787fcc966d2389c49288a474d56c74
-SHA256 (epic5-0.3.5.tar.gz) = e4a8e3d0d49e4dbf34b30703eba87a867539b8211121d985ae53f7bdb02cab6a
-SIZE (epic5-0.3.5.tar.gz) = 881160
+MD5 (epic5-0.3.8.tar.bz2) = e3d8df6013c609a9b2e605b6d4524518
+SHA256 (epic5-0.3.8.tar.bz2) = 4e8185214eca094c2f394bbca57a2b8c8310283aa591f757cbde7e5d5a6a0c1e
+SIZE (epic5-0.3.8.tar.bz2) = 734431
diff --git a/irc/epic5/pkg-plist b/irc/epic5/pkg-plist
index 7e2be021b4f2..63862c538e89 100644
--- a/irc/epic5/pkg-plist
+++ b/irc/epic5/pkg-plist
@@ -1,5 +1,5 @@
bin/epic5
-bin/epic5-0.3.5
+bin/epic5-%%PORTVERSION%%
libexec/epic5-wserv4
%%PORTDOCS%%%%DOCSDIR%%/BUG_FORM
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT