aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-04-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-04-30 15:50:30 +0000
commit6328c1047252c9e67e53f08771b696ff5c7998ac (patch)
tree441a601ae7cfd5de7180a9499571be2772cbb3d1 /irc
parent6fb5cb552bfeed4d904262aa7b0abcabdfdee318 (diff)
downloadports-6328c1047252c9e67e53f08771b696ff5c7998ac.tar.gz
ports-6328c1047252c9e67e53f08771b696ff5c7998ac.zip
Add anope 1.6.2, a set of IRC services for IRC networks.
Notes
Notes: svn path=/head/; revision=108040
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/anope/Makefile107
-rw-r--r--irc/anope/distinfo2
-rw-r--r--irc/anope/files/patch-Makefile16
-rw-r--r--irc/anope/files/patch-configure391
-rw-r--r--irc/anope/pkg-descr17
-rw-r--r--irc/anope/pkg-plist25
7 files changed, 559 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 0df72a6ce021..d37f912f3aab 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -3,6 +3,7 @@
COMMENT = Internet Relay Chat utilities
+ SUBDIR += anope
SUBDIR += bitchx
SUBDIR += bitlbee
SUBDIR += blackened
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
new file mode 100644
index 000000000000..aee79c321c28
--- /dev/null
+++ b/irc/anope/Makefile
@@ -0,0 +1,107 @@
+# New ports collection makefile for: anope
+# Date created: 13/04/2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= anope
+PORTVERSION= 1.6.2
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A set of IRC services for IRC networks
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+USE_REINPLACE= yes
+
+# OPTIONS --{{{
+OPTIONS= MYSQL "Use mysql" ON \
+ MODULES "Use modules" ON \
+ MD5 "Encrypt passwords" ON \
+ THREAD "Build with threads (needed for proxy detector)" ON \
+ DREAM "DreamForge 4.6.7 " OFF \
+ BAHAMUT "Bahamut 1.4.27 [or later]" OFF \
+ UNREAL "UnrealIRCd 3.1.1 [or later]" OFF \
+ ULT2 "UltimateIRCd 2.8.2 [or later]" OFF \
+ ULT3 "UltimateIRCd 3.0.0 [alpha26 or later]" OFF \
+ HYB "Hybrid IRCd 7.0 [experimental]" OFF \
+ VIA "ViagraIRCd 1.3.x [or later]" OFF \
+ PTL "PTlink 6.15.0 [experimental]" OFF
+#}}}
+
+ANOPEBIN?= ${PREFIX}/libexec/anope
+ANOPEDAT?= ${DATADIR}
+ANOPEMOD?= ${PREFIX}/lib/anope/
+ANOPEUMASK?= 077
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/-D_REENTRANT/${PTHREAD_CFLAGS}/" \
+ -e "s/-pthread/${PTHREAD_LIBS}/" \
+ ${WRKSRC}/configure
+
+pre-configure: #--{{{
+ @${ECHO_CMD} PROGRAM="anope" > ${WRKSRC}/config.cache
+ @${ECHO_CMD} BINDEST="${ANOPEBIN}" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} DATDEST="${ANOPEDAT}" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} UMASK="${ANOPEUMASK}" >> ${WRKSRC}/config.cache
+.if defined(WITH_MYSQL)
+ @${ECHO_CMD} MYSQL="USE_MYSQL" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} RDB="USE_RDB" >> ${WRKSRC}/config.cache
+.endif
+.if defined(WITH_MODULES)
+ @${ECHO_CMD} USE_MODULES="USE_MODULES" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} MODULE_PATH="${ANOPEMOD}" >> ${WRKSRC}/config.cache
+.endif
+.if defined(WITH_MD5)
+ @${ECHO_CMD} ENCRYPTION="ENCRYPT_MD5" >> ${WRKSRC}/config.cache
+.endif
+.if defined(WITH_THREAD)
+ @${ECHO_CMD} THREAD="USE_THREADS" >> ${WRKSRC}/config.cache
+.endif
+.if defined(WITH_DREAM)
+ @${ECHO_CMD} IRCTYPE=1 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_DREAMFORGE" >> ${WRKSRC}/config.cache
+.elif defined(WITH_BAHAMUT)
+ @${ECHO_CMD} IRCTYPE=2 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_BAHAMUT" >> ${WRKSRC}/config.cache
+.elif defined(WITH_UNREAL)
+ @${ECHO_CMD} IRCTYPE=3 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_DREAMFORGE" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF2="IRC_UNREAL" >> ${WRKSRC}/config.cache
+.elif defined(WITH_ULT2)
+ @${ECHO_CMD} IRCTYPE=4 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_DREAMFORGE" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF2="IRC_ULTIMATE" >> ${WRKSRC}/config.cache
+.elif defined(WITH_ULT3)
+ @${ECHO_CMD} IRCTYPE=5 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_BAHAMUT" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF2="IRC_ULTIMATE3" >> ${WRKSRC}/config.cache
+.elif defined(WITH_HYB)
+ @${ECHO_CMD} IRCTYPE=6 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_HYBRID" >> ${WRKSRC}/config.cache
+.elif defined(WITH_VIA)
+ @${ECHO_CMD} IRCTYPE=7 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_BAHAMUT" >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF2="IRC_VIAGRA" >> ${WRKSRC}/config.cache
+.elif defined(WITH_PTL)
+ @${ECHO_CMD} IRCTYPE=8 >> ${WRKSRC}/config.cache
+ @${ECHO_CMD} IRCTYPE_DEF="IRC_PTLINK" >> ${WRKSRC}/config.cache
+.endif
+#}}}
+
+pre-install:
+ @${MKDIR} ${ANOPEBIN}
+ @${MKDIR} ${ANOPEDAT}
+ @${MKDIR} ${ANOPEMOD}
+
+.include <bsd.port.post.mk>
diff --git a/irc/anope/distinfo b/irc/anope/distinfo
new file mode 100644
index 000000000000..b80df7011d63
--- /dev/null
+++ b/irc/anope/distinfo
@@ -0,0 +1,2 @@
+MD5 (anope-1.6.2.tar.gz) = 55af12ef5f85d26f4f1cb3e5a2f9eec7
+SIZE (anope-1.6.2.tar.gz) = 876615
diff --git a/irc/anope/files/patch-Makefile b/irc/anope/files/patch-Makefile
new file mode 100644
index 000000000000..50d63afd6441
--- /dev/null
+++ b/irc/anope/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile~ Mon Apr 19 04:36:01 2004
++++ Makefile Fri Apr 23 18:59:54 2004
+@@ -74,10 +74,10 @@
+ distclean: spotless
+
+ install: $(PROGRAM) languages
+- $(INSTALL) services $(BINDEST)/services
++ $(INSTALL) $(PROGRAM) $(BINDEST)/$(PROGRAM)
+ rm -f $(BINDEST)/listnicks $(BINDEST)/listchans
+- ln $(BINDEST)/services $(BINDEST)/listnicks
+- ln $(BINDEST)/services $(BINDEST)/listchans
++ ln $(BINDEST)/$(PROGRAM) $(BINDEST)/listnicks
++ ln $(BINDEST)/$(PROGRAM) $(BINDEST)/listchans
+ (cd lang ; $(MAKE) install)
+ $(CP_ALL) data/* $(DATDEST)
+ test -d $(DATDEST)/backups || mkdir $(DATDEST)/backups
diff --git a/irc/anope/files/patch-configure b/irc/anope/files/patch-configure
new file mode 100644
index 000000000000..3ee1d1f4e3d7
--- /dev/null
+++ b/irc/anope/files/patch-configure
@@ -0,0 +1,391 @@
+--- configure~ Mon Apr 19 04:36:02 2004
++++ configure Fri Apr 23 18:36:12 2004
+@@ -327,388 +327,6 @@
+
+ ###########################################################################
+
+-# Ask the user anything we need to know ahead of time.
+-
+-export ok INPUT
+-
+-####
+-
+-ok=0
+-echo "Note: press Return for the default, or enter a new value."
+-echo "In what directory do you want the binaries to be installed?"
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$BINDEST] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$BINDEST
+- fi
+- if [ ! -d "$INPUT" ] ; then
+- if exists "$INPUT" ; then
+- echo "$INPUT exists, but is not a directory!"
+- else
+- echo "$INPUT does not exist. Create it?"
+- echo2 "[y] "
+- read YN
+- if [ "$YN" != "n" ] ; then
+- if mkdir -p $INPUT ; then
+- ok=1
+- fi
+- fi
+- fi
+- elif exists "$INPUT/services.h" ; then
+- echo "You cannot use the Services source directory as a target directory."
+- else
+- ok=1
+- fi
+-done
+-BINDEST=$INPUT
+-DATDEST=$INPUT
+-echo ""
+-
+-####
+-
+-ok=0
+-echo "Where do you want the data files to be installed?"
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$DATDEST] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DATDEST
+- fi
+- if [ ! -d "$INPUT" ] ; then
+- if exists "$INPUT" ; then
+- echo "$INPUT exists, but is not a directory!"
+- else
+- echo "$INPUT does not exist. Create it?"
+- echo2 "[y] "
+- read YN
+- if [ "$YN" != "n" ] ; then
+- if mkdir -p $INPUT ; then
+- ok=1
+- fi
+- fi
+- fi
+- elif exists "$INPUT/services.h" ; then
+- echo "You cannot use the Services source directory as a target directory."
+- else
+- ok=1
+- fi
+-done
+-DATDEST=$INPUT
+-echo ""
+-
+-####
+-
+-OLD_RUNGROUP="$RUNGROUP"
+-if [ "$RUNGROUP" ] ; then
+- echo "Which group should all Services data files be owned by? (If Services"
+- echo "should not force files to be owned by a particular group, type "\"none\"
+- echo "(without the quotes) and press Return.)"
+-else
+- echo "Which group should all Services data files be owned by? (If Services"
+- echo "should not force files to be owned by a particular group, just press"
+- echo "Return.)"
+-fi
+-echo2 "[$RUNGROUP] "
+-if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+-if [ "$INPUT" ] ; then
+- if [ "$INPUT" = "none" ] ; then
+- RUNGROUP=""
+- else
+- RUNGROUP="$INPUT"
+- fi
+-fi
+-echo ""
+-
+-####
+-
+-if [ ! "$UMASK" -o "$RUNGROUP" != "$OLD_RUNGROUP" ] ; then
+- if [ "$RUNGROUP" ] ; then
+- UMASK=007
+- else
+- UMASK=077
+- fi
+-fi
+-
+-ok=0
+-echo "What should the default umask for data files be (in octal)?"
+-echo "(077 = only accessible by owner; 007 = accessible by owner and group)"
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$UMASK] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$UMASK
+- fi
+- if [ `echo "$INPUT" | grep -c '[^0-7]'` -gt 0 ] ; then
+- echo "$UMASK is not a valid octal number!"
+- else
+- if [ "`echo $INPUT | cut -c1`" != "0" ] ; then
+- INPUT=0$INPUT
+- fi
+- ok=1
+- fi
+-done
+-UMASK=$INPUT
+-echo ""
+-
+-####
+-
+-ok=0
+-echo "Select the closest to the type of server on your IRC network:"
+-echo " 1) DreamForge 4.6.7 [dated IRCd, upgrade to a current one]"
+-echo " 2) Bahamut 1.4.27 [or later]"
+-echo " 3) UnrealIRCd 3.1.1 [or later]"
+-echo " 4) UltimateIRCd 2.8.2 [or later]"
+-echo " 5) UltimateIRCd 3.0.0 [alpha26 or later]"
+-echo " 6) Hybrid IRCd 7.0 [experimental]"
+-echo " 7) ViagraIRCd 1.3.x [or later]"
+-echo " 8) PTlink 6.15.0 [experimental]"
+-
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$IRCTYPE] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$IRCTYPE
+- fi
+- case $INPUT in
+- no\ default)
+- echo "You must specify your IRC server type in order for Services to function"
+- echo "correctly."
+- ;;
+- 1)
+- IRCTYPE_DEF="IRC_DREAMFORGE"
+- IRCTYPE_DEF2=
+- ok=1
+- ;;
+- 2)
+- IRCTYPE_DEF="IRC_BAHAMUT"
+- IRCTYPE_DEF2=
+- ok=1
+- ;;
+- 3) IRCTYPE_DEF="IRC_DREAMFORGE"
+- IRCTYPE_DEF2="IRC_UNREAL"
+- ok=1
+- ;;
+- 4) IRCTYPE_DEF="IRC_DREAMFORGE"
+- IRCTYPE_DEF2="IRC_ULTIMATE"
+- ok=1
+- ;;
+- 5) IRCTYPE_DEF="IRC_BAHAMUT"
+- IRCTYPE_DEF2="IRC_ULTIMATE3"
+- ok=1
+- ;;
+- 6) IRCTYPE_DEF="IRC_HYBRID"
+- IRCTYPE_DEF2=
+- ok=1
+- ;;
+- 7) IRCTYPE_DEF="IRC_BAHAMUT"
+- IRCTYPE_DEF2="IRC_VIAGRA"
+- ok=1
+- ;;
+- 8) IRCTYPE_DEF="IRC_PTLINK"
+- IRCTYPE_DEF2=
+- ok=1
+- ;;
+- *)
+- echo "Please enter a valid option number."
+- ;;
+- esac
+-done
+-IRCTYPE=$INPUT
+-echo ""
+-
+-####
+-
+-if [ "$ENCRYPTION" = "ENCRYPT_MD5" ] ; then
+- DEF=yes
+-else
+- DEF=no
+-fi
+-
+-ok=0
+-echo "Do you want to use the MD5 message-digest algorithm to encrypt passwords?"
+-echo "(Selecting "\"yes\"" protects your passwords from being stolen if someone"
+-echo "gains access to the Services databases, but makes it impossible to recover"
+-echo "forgotten passwords. There is no way to reverse this operation, so make"
+-echo "sure you really want to enable it.)"
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$DEF] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DEF
+- fi
+- case $INPUT in
+- n*|N*)
+- ENCRYPTION=
+- ok=1
+- ;;
+- y*|Y*)
+- ENCRYPTION=ENCRYPT_MD5
+- ok=1
+- ;;
+- *)
+- echo "Please enter `yes' or `no'."
+- ;;
+- esac
+-done
+-echo ""
+-
+-
+-
+-####
+-
+-if [ "$THREAD" = "USE_THREADS" ] ; then
+- DEF=yes
+-else
+- DEF=no
+-fi
+-
+-ok=0
+-echo "Do you want to compile Anope with threading support?"
+-echo "If you want to use the proxy detector, you MUST have this. If you get"
+-echo "compilation errors, you should disable this feature and try again."
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$DEF] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DEF
+- fi
+- case $INPUT in
+- n*|N*)
+- THREAD=
+- ok=1
+- ;;
+- y*|Y*)
+- THREAD="USE_THREADS"
+- ok=1
+- ;;
+- *)
+- echo "Please enter yes or no."
+- ;;
+- esac
+-done
+-echo ""
+-
+-if [ "$MYSQL" = "USE_MYSQL" ] ; then
+- DEF=yes
+-else
+- DEF=no
+-fi
+-
+-ok=0
+-echo "Do you want to compile Anope with MySQL support?"
+-echo "At this time Anope is able to dump all databases into MySQL. That means"
+-echo "you get a read-only copy of the data. If you plan to run any module that"
+-echo "uses MySQL, you should enable this option as well."
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$DEF] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DEF
+- fi
+- case $INPUT in
+- n*|N*)
+- RDB=
+- MYSQL=
+- ok=1
+- ;;
+- y*|Y*)
+- RDB="USE_RDB"
+- MYSQL="USE_MYSQL"
+- ok=1
+- ;;
+- *)
+- echo "Please enter yes or no."
+- ;;
+- esac
+-done
+-echo ""
+-
+-####
+-
+-if [ "$USE_MODULES" = "USE_MODULES" ] ; then
+- DEF=yes
+-else
+- DEF=no
+-fi
+-
+-ok=0
+-echo "Do you want to compile Anope with Module support?"
+-echo "This will allow you to load and unload external modules of code without"
+-echo "restarting services. You can find several Anope modules on our website."
+-echo "This requires libdl, if you have problems compiling disable this option."
+-echo "(this option is ignored on OpenBSD for the time being)"
+-while [ $ok -eq 0 ] ; do
+- echo2 "[$DEF] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DEF
+- fi
+- case $INPUT in
+- n*|N*)
+- USE_MODULES=
+- MODULE_PATH=
+- ok=1
+- ;;
+- y*|Y*)
+- USE_MODULES="USE_MODULES"
+- ok=1
+- ;;
+- *)
+- echo "Please enter yes or no."
+- ;;
+- esac
+-done
+-echo ""
+-
+-###
+-if [ "$USE_MODULES" = "USE_MODULES" ] ; then
+- if [ "$MODULE_PATH" ] ; then
+- DEF=$MODULE_PATH
+- else
+- DEF=$BINDEST/modules/
+- fi
+- ok=0
+- echo "Where do you want the modules installed? (The trailing / is important)"
+- while [ $ok -eq 0 ] ; do
+- echo2 "[$DEF] "
+- if read INPUT ; then : ; else echo "" ; exit 1 ; fi
+- if [ ! "$INPUT" ] ; then
+- INPUT=$DEF
+- fi
+- if [ ! -d "$INPUT" ] ; then
+- if exists "$INPUT" ; then
+- echo "$INPUT exists, but is not a directory!"
+- else
+- echo "$INPUT does not exist. Create it?"
+- echo2 "[y] "
+- read YN
+- if [ "$YN" != "n" ] ; then
+- if mkdir -p $INPUT ; then
+- ok=1
+- fi
+- fi
+- fi
+- elif exists "$INPUT/services.h" ; then
+- echo "You cannot use the Services source directory as a target directory."
+- else
+- ok=1
+- fi
+- if [ ! -d "$INPUT/runtime/" ] ; then
+- if mkdir -p $INPUT/runtime/ ; then
+- ok=1
+- fi
+- fi
+- done
+- MODULE_PATH=$INPUT
+- echo ""
+-fi
+-echo ""
+-
+-###
+-
+-echo "End of interactive configuration."
+-echo ""
+
+ ###########################################################################
+
diff --git a/irc/anope/pkg-descr b/irc/anope/pkg-descr
new file mode 100644
index 000000000000..d33944a7159a
--- /dev/null
+++ b/irc/anope/pkg-descr
@@ -0,0 +1,17 @@
+Anope is a set of Services for IRC networks that allows users to
+manage their nicks and channels in a secure and efficient way, and
+administrators to manage their network with powerful tools.
+
+Anope currently works with:
+ - DreamForge 4.6.7
+ - Bahamut 1.4.27 or later
+ - UnrealIRCd 3.1.1 or later (including 3.2)
+ - UltimateIRCd 2.8.2 or later (including 3.0.0)
+ - ViagraIRCd 1.3 or later
+ - Hybrid 7 or later
+ - PTlink 6.15 or later
+
+Anope could also work with some of the deamons derivated by the ones listed
+above.
+
+WWW: http://www.anope.org/
diff --git a/irc/anope/pkg-plist b/irc/anope/pkg-plist
new file mode 100644
index 000000000000..2294698cee7c
--- /dev/null
+++ b/irc/anope/pkg-plist
@@ -0,0 +1,25 @@
+lib/anope/hs_moo.so
+lib/anope/ircd_catserv.so
+libexec/anope/anope
+libexec/anope/listchans
+libexec/anope/listnicks
+%%PORTDOCS%%%%DATADIR%%/example.chk
+%%PORTDOCS%%%%DATADIR%%/example.conf
+%%PORTDOCS%%%%DATADIR%%/languages/cat
+%%PORTDOCS%%%%DATADIR%%/languages/de
+%%PORTDOCS%%%%DATADIR%%/languages/en_us
+%%PORTDOCS%%%%DATADIR%%/languages/es
+%%PORTDOCS%%%%DATADIR%%/languages/fr
+%%PORTDOCS%%%%DATADIR%%/languages/gr
+%%PORTDOCS%%%%DATADIR%%/languages/it
+%%PORTDOCS%%%%DATADIR%%/languages/nl
+%%PORTDOCS%%%%DATADIR%%/languages/pt
+%%PORTDOCS%%%%DATADIR%%/languages/ru
+%%PORTDOCS%%%%DATADIR%%/languages/tr
+%%PORTDOCS%%%%DATADIR%%/tables.sql
+%%PORTDOCS%%@unexec rmdir %D/%%DATADIR%%/logs 2>/dev/null || true
+%%PORTDOCS%%@dirrm %%DATADIR%%/languages
+%%PORTDOCS%%@unexec rmdir %D/%%DATADIR%%/backups 2>/dev/null || true
+%%PORTDOCS%%@dirrm %%DATADIR%%
+@dirrm libexec/anope
+@dirrm lib/anope