aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-05 20:35:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-05 20:35:28 +0000
commit0bb764c0bb164edaa1eed1147054fcb6562e2bfe (patch)
tree32326cf47197ead62f4d707de52521e06bf0e029 /irc
parentbc4f34cad31152bfc456738feabe187adfebd3f0 (diff)
downloadports-0bb764c0bb164edaa1eed1147054fcb6562e2bfe.tar.gz
ports-0bb764c0bb164edaa1eed1147054fcb6562e2bfe.zip
- Always create plugins directory
Submitted by: arved
Notes
Notes: svn path=/head/; revision=97401
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile4
-rw-r--r--irc/xchat2/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 315a3b6b1097..fda663659009 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -89,4 +89,8 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
${WRKSRC}/configure
+# Create plugins directory even when no plugins are installed
+post-install:
+ @${MKDIR} ${PREFIX}/lib/xchat/plugins
+
.include <bsd.port.post.mk>
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 315a3b6b1097..fda663659009 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -89,4 +89,8 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
${WRKSRC}/configure
+# Create plugins directory even when no plugins are installed
+post-install:
+ @${MKDIR} ${PREFIX}/lib/xchat/plugins
+
.include <bsd.port.post.mk>