aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:54 +0000
commite51bbb58a4c6768d011c6b5ec5e74fd757f85e57 (patch)
tree1854068f339c180ccfac6a1304765861eb2e85fc /irc
parenta28f0f7f7f7687e6ab6ebc4b3313f96232c00aa0 (diff)
downloadports-e51bbb58a4c6768d011c6b5ec5e74fd757f85e57.tar.gz
ports-e51bbb58a4c6768d011c6b5ec5e74fd757f85e57.zip
Remove all _USE=openssl occurrences.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=436248
Diffstat (limited to 'irc')
-rw-r--r--irc/anope/Makefile2
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/ezbounce/Makefile2
-rw-r--r--irc/ircd-ratbox/Makefile2
-rw-r--r--irc/ircproxy/Makefile2
-rw-r--r--irc/ngircd/Makefile2
-rw-r--r--irc/unreal/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index dcfc918b73d0..df16f81c2cba 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -56,7 +56,7 @@ PLIST_SUB+= MYSQL="@comment "
.if ${PORT_OPTIONS:MOPENSSL}
PLIST_SUB+= OPENSSL=""
-OPENSSL_USE= openssl=yes
+USES+= ssl
.else
PLIST_SUB+= OPENSSL="@comment "
.endif
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 52ebd2a65436..10f000e0491e 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -42,7 +42,7 @@ OPTIONS_DEFAULT= PLUGINS SSL
IPV6_CONFIGURE_ENABLE= ipv6
SSL_CONFIGURE_WITH= ssl
-SSL_USE= openssl=yes
+SSL_USES= ssl
PLUGINS_CONFIGURE_WITH= plugins="${PLUGIN_LIST:C/\$$/,/g}"
diff --git a/irc/ezbounce/Makefile b/irc/ezbounce/Makefile
index 904507582e28..245c51e19b6f 100644
--- a/irc/ezbounce/Makefile
+++ b/irc/ezbounce/Makefile
@@ -14,7 +14,7 @@ OPTIONS_DEFINE= DOCS SSL COMPRESS
OPTIONS_DEFAULT=SSL COMPRESS
OPTIONS_SUB= yes
-SSL_USE= OPENSSL=YES
+SSL_USES= ssl
SSL_CONFIGURE_WITH= ssl
COMPRESS_BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:devel/boost-libs
COMPRESS_CONFIGURE_WITH=boost
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index 4fe30e2fc3d4..3af1e2210801 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -64,7 +64,7 @@ OPTIONS_SUB= yes
ASSERT_CONFIGURE_ENABLE= assert
IPV6_CONFIGURE_ENABLE= ipv6
-OPENSSL_USE= openssl=yes
+OPENSSL_USES= ssl
OPENSSL_CONFIGURE_ON= --enable-openssl=${OPENSSLBASE}
OPENSSL_CONFIGURE_OFF= --disable-openssl
SERVICES_CONFIGURE_ENABLE= services
diff --git a/irc/ircproxy/Makefile b/irc/ircproxy/Makefile
index d6fa31d9a232..43525dd08ee6 100644
--- a/irc/ircproxy/Makefile
+++ b/irc/ircproxy/Makefile
@@ -35,7 +35,7 @@ MEMDEBUG_CONFIGURE_ENABLE= memdebug
FDDEBUG_CONFIGURE_ENABLE= fddebug
IPV6_CONFIGURE_ENABLE= ipv6
SSL_CONFIGURE_ENABLE= ssl
-SSL_USE= OPENSSL=yes
+SSL_USES= ssl
post-patch:
@${REINPLACE_CMD} -e 's|EUSER="ircproxy"|EUSER="ircproxyd"|g; \
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index 13343cdcd9a6..d6eed20441d6 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -49,7 +49,7 @@ IPV6_CONFIGURE_ENABLE= ipv6
IRCPLUS_DESC= IRC+ protocol
IRCPLUS_CONFIGURE_ENABLE= ircplus
LIBWRAP_CONFIGURE_WITH= tcp-wrappers
-OPENSSL_USE= openssl=yes
+OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
SNIFFER_DESC= IRC traffic sniffer
SNIFFER_CONFIGURE_ENABLE= sniffer
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index bb7c79853440..3021fd8f0d0e 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -71,7 +71,7 @@ NOSPOOF_CONFIGURE_ENABLE= nospoof
ZIPLINKS_CONFIGURE_ENABLE= ziplinks
IPV6_CONFIGURE_ENABLE= inet6
SSL_CONFIGURE_ENABLE= ssl
-SSL_USE= OPENSSL=yes
+SSL_USES= ssl
REMOTE_LIB_DEPENDS= libcurl.so:ftp/curl
REMOTE_CONFIGURE_ENABLE= --enable-libcurl=${LOCALBASE}
PREFIXAQ_CONFIGURE_ENABLE= prefixaq