aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-29 22:44:49 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-29 22:44:49 +0000
commit47cb36aa585bf931fccd93d9e0f2a289d34c96c4 (patch)
tree22b6583da5415915a54105af4e4df382bf32682b /irc
parent54f0486e51c7aa2aa0e9cefe267e35f46dbff0d9 (diff)
downloadports-47cb36aa585bf931fccd93d9e0f2a289d34c96c4.tar.gz
ports-47cb36aa585bf931fccd93d9e0f2a289d34c96c4.zip
- Honors LOCALBASE.
- Executable moved to ${PREFIX}/sbin - Add rcNG script. - Logfile is placed under /var/log. - Pidfile is placed under /var/pid. PR: ports/88177 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=149963
Diffstat (limited to 'irc')
-rw-r--r--irc/thales/Makefile9
-rw-r--r--irc/thales/files/patch-conf.h11
-rw-r--r--irc/thales/files/patch-thales.conf.default17
-rw-r--r--irc/thales/files/thales.sh.in29
-rw-r--r--irc/thales/pkg-plist2
5 files changed, 65 insertions, 3 deletions
diff --git a/irc/thales/Makefile b/irc/thales/Makefile
index c2b95f380948..8280a49cbf32 100644
--- a/irc/thales/Makefile
+++ b/irc/thales/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thales
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,6 +18,7 @@ COMMENT= GNU Thales -- An IRC to MySQL gateway
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_MYSQL= yes
+USE_RC_SUBR= thales.sh
USE_REINPLACE= yes
# Currently, not all supported IRCDs are handled here, only the ones
@@ -34,7 +36,10 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/ircd:${PORTSDIR}/irc/unreal
# ``Assign with expansion'' is needed here, otherwise we cannot override
# WITH_IRCD value supplied as make(1) argument (which can be bogus).
-CONFIGURE_ARGS:= --with-ircd=${WITH_IRCD}
+CONFIGURE_ARGS:= --with-ircd=${WITH_IRCD} \
+ --prefix=${PREFIX}/sbin/thales \
+ --with-mysql=${LOCALBASE} \
+ --with-mysql-libraries=${LOCALBASE}/lib/mysql
.if defined(WITHOUT_MODES)
CONFIGURE_ARGS+= --enable-no-modes
@@ -61,7 +66,7 @@ post-patch: .SILENT
do-install:
@${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/thales ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/thales ${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/data/thales.conf.default ${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/data/*.sql ${DATADIR}
.if !defined(NOPORTDOCS)
diff --git a/irc/thales/files/patch-conf.h b/irc/thales/files/patch-conf.h
new file mode 100644
index 000000000000..93d11938230a
--- /dev/null
+++ b/irc/thales/files/patch-conf.h
@@ -0,0 +1,11 @@
+--- src/conf.h Sun Jan 11 00:26:12 2004
++++ src/conf.h Sat Apr 2 10:42:03 2005
+@@ -23,7 +23,7 @@
+ #include "log.h"
+
+ /* Configuration directives. */
+-#define THALES_CONF "thales.conf"
++#define THALES_CONF "%%PREFIX%%/etc/thales.conf"
+ #define MAXPARAMS 4
+
+ typedef struct
diff --git a/irc/thales/files/patch-thales.conf.default b/irc/thales/files/patch-thales.conf.default
new file mode 100644
index 000000000000..711e384909f7
--- /dev/null
+++ b/irc/thales/files/patch-thales.conf.default
@@ -0,0 +1,17 @@
+--- data/thales.conf.default Sat Jul 5 17:04:39 2003
++++ data/thales.conf.default Sat Apr 2 10:57:47 2005
+@@ -144,12 +144,12 @@
+ # PIDFile <filename> [REQUIRED]
+ # Specifies the name of the file containing Services' process ID.
+
+-PIDFile thales.pid
++PIDFile /var/run/thales.pid
+
+ # LogFile <filename> [REQUIRED]
+ # Specifies the name of the log file.
+
+-LogFile thales.log
++LogFile /var/log/thales.log
+
+ ###########################################################################
+ #
diff --git a/irc/thales/files/thales.sh.in b/irc/thales/files/thales.sh.in
new file mode 100644
index 000000000000..bd2df2e0d153
--- /dev/null
+++ b/irc/thales/files/thales.sh.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: thales
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable Thales:
+# thales_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable Thales
+#
+
+. %%RC_SUBR%%
+
+name="thales"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/thales"
+
+[ -z "$thales_enable" ] && thales_enable="NO"
+
+required_files="%%PREFIX%%/etc/thales.conf"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/irc/thales/pkg-plist b/irc/thales/pkg-plist
index 1e29abd3d97a..c4fdb8a209c6 100644
--- a/irc/thales/pkg-plist
+++ b/irc/thales/pkg-plist
@@ -1,4 +1,4 @@
-bin/thales
+sbin/thales
etc/thales.conf.default
%%DATADIR%%/mysql-bahamut.sql
%%DATADIR%%/mysql-hybrid.sql