aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 20:30:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 20:30:17 +0000
commit852053d6da1a50aad61ec5993fa9edb021c236dd (patch)
treef2cfbe221f024e60d5a6192725cbe0c2ad3a0e26 /irc
parent1c1965297d738fd818bbe533ac4f23f05a696e4f (diff)
downloadports-852053d6da1a50aad61ec5993fa9edb021c236dd.tar.gz
ports-852053d6da1a50aad61ec5993fa9edb021c236dd.zip
* Add optional Tcl support
* Convert from pkg-comment to COMMENT PR: 48438 Submitted by: Koop Mast <einekoai@chello.nl>
Notes
Notes: svn path=/head/; revision=75819
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile19
-rw-r--r--irc/xchat-gnome/pkg-comment1
-rw-r--r--irc/xchat-gnome/pkg-plist1
-rw-r--r--irc/xchat2/Makefile19
-rw-r--r--irc/xchat2/pkg-comment1
-rw-r--r--irc/xchat2/pkg-plist1
6 files changed, 38 insertions, 4 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index ce18750b4151..0d2bcf156659 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://xchat.org/files/source/2.0/ \
DISTNAME= xchat-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+COMMENT= An X11 IRC client using the GTK+ 2 toolkit
LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
@@ -48,8 +49,21 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB= PYTHON="@comment "
.endif
+.if defined(WITH_TCL)
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
+CONFIGURE_ARGS+= --enable-tcl=${LOCALBASE}/lib/tcl8.3
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ -I${LOCALBASE}/include/tcl8.3" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
+ -L${LOCALBASE}/lib/tcl8.3"
+PLIST_SUB= TCL=""
+.else
+CONFIGURE_ARGS+= --enable-tcl=no
+PLIST_SUB= TCL="@comment "
+.endif
+
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
@@ -59,6 +73,9 @@ pre-everything::
.if !defined(WITH_SOCKS)
@${ECHO_MSG} "WITH_SOCKS=yes for SOCKS5 proxy support"
.endif
+.if !defined(WITH_TCL)
+ @${ECHO_MSG} "WITH_TCL=yes for tcl support"
+.endif
post-patch:
@${REINPLACE_CMD} \
diff --git a/irc/xchat-gnome/pkg-comment b/irc/xchat-gnome/pkg-comment
deleted file mode 100644
index 87bec7c9208c..000000000000
--- a/irc/xchat-gnome/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-An X11 IRC client using the GTK+ 2 toolkit
diff --git a/irc/xchat-gnome/pkg-plist b/irc/xchat-gnome/pkg-plist
index 27ffd14dfd37..fff60a492e28 100644
--- a/irc/xchat-gnome/pkg-plist
+++ b/irc/xchat-gnome/pkg-plist
@@ -2,6 +2,7 @@ bin/xchat
bin/xchat-text
lib/xchat/plugins/perl.so
%%PYTHON%%lib/xchat/plugins/python.so
+%%TCL%%lib/xchat/plugins/tcl.so
share/gnome/apps/Internet/xchat.desktop
share/gnome/pixmaps/xchat.png
share/locale/am/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index ce18750b4151..0d2bcf156659 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://xchat.org/files/source/2.0/ \
DISTNAME= xchat-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+COMMENT= An X11 IRC client using the GTK+ 2 toolkit
LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
@@ -48,8 +49,21 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB= PYTHON="@comment "
.endif
+.if defined(WITH_TCL)
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
+CONFIGURE_ARGS+= --enable-tcl=${LOCALBASE}/lib/tcl8.3
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ -I${LOCALBASE}/include/tcl8.3" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
+ -L${LOCALBASE}/lib/tcl8.3"
+PLIST_SUB= TCL=""
+.else
+CONFIGURE_ARGS+= --enable-tcl=no
+PLIST_SUB= TCL="@comment "
+.endif
+
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
@@ -59,6 +73,9 @@ pre-everything::
.if !defined(WITH_SOCKS)
@${ECHO_MSG} "WITH_SOCKS=yes for SOCKS5 proxy support"
.endif
+.if !defined(WITH_TCL)
+ @${ECHO_MSG} "WITH_TCL=yes for tcl support"
+.endif
post-patch:
@${REINPLACE_CMD} \
diff --git a/irc/xchat2/pkg-comment b/irc/xchat2/pkg-comment
deleted file mode 100644
index 87bec7c9208c..000000000000
--- a/irc/xchat2/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-An X11 IRC client using the GTK+ 2 toolkit
diff --git a/irc/xchat2/pkg-plist b/irc/xchat2/pkg-plist
index 27ffd14dfd37..fff60a492e28 100644
--- a/irc/xchat2/pkg-plist
+++ b/irc/xchat2/pkg-plist
@@ -2,6 +2,7 @@ bin/xchat
bin/xchat-text
lib/xchat/plugins/perl.so
%%PYTHON%%lib/xchat/plugins/python.so
+%%TCL%%lib/xchat/plugins/tcl.so
share/gnome/apps/Internet/xchat.desktop
share/gnome/pixmaps/xchat.png
share/locale/am/LC_MESSAGES/xchat.mo