aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-08-04 02:46:24 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-08-04 02:46:24 +0000
commit129752552ff3e561e83cf7b344c675393e052db9 (patch)
tree64df5377bb2a1c082b851cc2bb777a5fa3a29a7f /irc
parentf1f532459140336efa2ddfaffd167f61eaff98df (diff)
downloadports-129752552ff3e561e83cf7b344c675393e052db9.tar.gz
ports-129752552ff3e561e83cf7b344c675393e052db9.zip
Various small fixes, bump the PORTREVISION.
Notes
Notes: svn path=/head/; revision=218015
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat/Makefile1
-rw-r--r--irc/xchat/files/patch-xc286-smallfixes68
2 files changed, 69 insertions, 0 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 20ea926c0356..53b435a04b15 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xchat
PORTVERSION= 2.8.6
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/files/patch-xc286-smallfixes b/irc/xchat/files/patch-xc286-smallfixes
new file mode 100644
index 000000000000..581462477583
--- /dev/null
+++ b/irc/xchat/files/patch-xc286-smallfixes
@@ -0,0 +1,68 @@
+#
+# Various small fixes from CVS that are considered safe to apply to 2.8.6.
+#
+--- xchat-2.8.6/src/common/cfgfiles.c 2008-02-05 21:02:47.000000000 +1100
++++ src/common/cfgfiles.c 2008-06-15 13:45:43.000000000 +1000
+@@ -886,7 +886,6 @@
+ set_showval (session *sess, const struct prefs *var, char *tbuf)
+ {
+ int len, dots, j;
+- static const char *offon[] = { "OFF", "ON" };
+
+ len = strlen (var->name);
+ memcpy (tbuf, var->name, len);
+@@ -909,8 +908,10 @@
+ *((int *) &prefs + var->offset));
+ break;
+ case TYPE_BOOL:
+- sprintf (tbuf + len, "\0033:\017 %s\n", offon[
+- *((int *) &prefs + var->offset)]);
++ if (*((int *) &prefs + var->offset))
++ sprintf (tbuf + len, "\0033:\017 %s\n", "ON");
++ else
++ sprintf (tbuf + len, "\0033:\017 %s\n", "OFF");
+ break;
+ }
+ PrintText (sess, tbuf);
+--- xchat-2.8.6/src/common/chanopt.c 2008-06-10 22:00:55.000000000 +1000
++++ src/common/chanopt.c 2008-06-15 13:48:04.000000000 +1000
+@@ -32,7 +32,7 @@
+
+ #define S_F(xx) STRUCT_OFFSET_STR(struct session,xx)
+
+-channel_options chanopt[] =
++static const channel_options chanopt[] =
+ {
+ {"alert_beep", "BEEP", S_F(alert_beep)},
+ {"alert_taskbar", NULL, S_F(alert_taskbar)},
+--- xchat-2.8.6/src/common/servlist.c 2008-04-01 19:22:34.000000000 +1100
++++ src/common/servlist.c 2008-06-15 13:57:41.000000000 +1000
+@@ -509,6 +509,8 @@
+ list = g_slist_nth (net->servlist, net->selected);
+ if (!list)
+ list = net->servlist;
++ if (!list)
++ return;
+ ircserv = list->data;
+
+ /* incase a protocol switch is added to the servlist gui */
+--- xchat-2.8.6/src/common/text.c 2008-03-28 13:20:04.000000000 +1100
++++ src/common/text.c 2008-06-15 13:59:59.000000000 +1000
+@@ -216,7 +216,7 @@
+ static void
+ scrollback_save (session *sess, char *text)
+ {
+- char buf[1024];
++ char buf[512 * 4];
+ time_t stamp;
+ int len;
+
+@@ -266,7 +266,7 @@
+ scrollback_load (session *sess)
+ {
+ int fh;
+- char buf[1024];
++ char buf[512 * 4];
+ char *text;
+ time_t stamp;
+ int lines;