aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /irc
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile4
-rw-r--r--irc/bopm/Makefile1
-rw-r--r--irc/hybserv/Makefile2
-rw-r--r--irc/kvirc-devel/Makefile1
-rw-r--r--irc/kvirc/Makefile1
-rw-r--r--irc/miau/Makefile1
-rw-r--r--irc/nefarious/Makefile1
-rw-r--r--irc/ngircd/Makefile1
-rw-r--r--irc/quirc/Makefile1
-rw-r--r--irc/undernet-ircu/Makefile1
-rw-r--r--irc/weechat-devel/Makefile1
-rw-r--r--irc/weechat/Makefile1
-rw-r--r--irc/xaric/Makefile1
13 files changed, 1 insertions, 16 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 15020f1584d4..3b762a38b65f 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -20,12 +20,10 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
USE_GMAKE= yes
-CONFIGURE_TARGET=
CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
--datadir="${PREFIX}/share" \
- --libdir="${PREFIX}/share" \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+ --libdir="${PREFIX}/share"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS}"
diff --git a/irc/bopm/Makefile b/irc/bopm/Makefile
index f171320bff54..3e03e426006e 100644
--- a/irc/bopm/Makefile
+++ b/irc/bopm/Makefile
@@ -18,7 +18,6 @@ LOGDIR= /var/log/${PORTNAME}
USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= configure src/libopm/configure
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc --localstatedir=${LOGDIR}
USE_LDCONFIG= yes
diff --git a/irc/hybserv/Makefile b/irc/hybserv/Makefile
index e5b462a8f8e7..c2da60312b81 100644
--- a/irc/hybserv/Makefile
+++ b/irc/hybserv/Makefile
@@ -19,8 +19,6 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/hybserv
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
.if defined(WITH_DAEMONTOOLS)
CONFIGURE_ARGS+= --with-daemontools
RUN_DEPENDS+= supervise:${PORTSDIR}/sysutils/daemontools
diff --git a/irc/kvirc-devel/Makefile b/irc/kvirc-devel/Makefile
index 4fbaf9ead404..98940c4b6ff6 100644
--- a/irc/kvirc-devel/Makefile
+++ b/irc/kvirc-devel/Makefile
@@ -22,7 +22,6 @@ INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
-CONFIGURE_TARGET=
CONFIGURE_ENV= QTDIR="${LOCALBASE}"
PLIST_SUB= VER=${PORTVERSION}
CONFLICTS= kvirc-3.2.0*
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 56ecd6dc5021..a0725e058fcd 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -24,7 +24,6 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GETTEXT= yes
INSTALLS_ICONS= yes
-CONFIGURE_TARGET=
PLIST_SUB= VER=${PORTVERSION}
MAN1= kvirc.1
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index 7c18adbdbd19..de0a6cb90f37 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -32,7 +32,6 @@ CONFIGURE_ARGS= --enable-dccbounce \
--enable-empty-awaymsg \
--enable-dumpstatus \
--disable-dependency-tracking
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS}" \
LIBS="${LIBS}"
diff --git a/irc/nefarious/Makefile b/irc/nefarious/Makefile
index e4927db55bd9..4ac7bf3d20c6 100644
--- a/irc/nefarious/Makefile
+++ b/irc/nefarious/Makefile
@@ -16,7 +16,6 @@ COMMENT= IRC server used by evilnet based off of Undernet\'s ircu
USE_BZIP2= yes
HAS_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_SUB+= INSTALL_PREFIX=${INSTALL_PREFIX:S/${PREFIX}\///}
MAN8= ircd.8
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index cde1f7e1bbba..a064576dda08 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -16,7 +16,6 @@ COMMENT= Free open source daemon for Internet Relay Chat (IRC)
USE_RC_SUBR= ngircd
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index 17b7e009bf4f..1d6589733d8c 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
USE_XORG= xt
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-wish=${LOCALBASE}/bin/wish8.4 \
--with-tcl-include-dir=${LOCALBASE}/include/tcl8.4 \
--with-tk-include-dir=${LOCALBASE}/include/tk8.4 \
diff --git a/irc/undernet-ircu/Makefile b/irc/undernet-ircu/Makefile
index d1f769ea15d9..1e3072a86c7f 100644
--- a/irc/undernet-ircu/Makefile
+++ b/irc/undernet-ircu/Makefile
@@ -18,7 +18,6 @@ CONFLICTS= ircd-hybrid-7.[0-9]*
GNU_CONFIGURE= yes
USE_RC_SUBR= undernet.sh
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-dpath=${PREFIX}/etc/ --with-symlink=no
PLIST_FILES= bin/ircd bin/umkpasswd bin/convert-conf etc/ircd.conf.example
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index b81c2f29ef30..95d1770176c3 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -20,7 +20,6 @@ USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-lua
MAN1= weechat-curses.1
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index b81c2f29ef30..95d1770176c3 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -20,7 +20,6 @@ USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-lua
MAN1= weechat-curses.1
diff --git a/irc/xaric/Makefile b/irc/xaric/Makefile
index 911fb23c2598..a970ada72e10 100644
--- a/irc/xaric/Makefile
+++ b/irc/xaric/Makefile
@@ -15,7 +15,6 @@ COMMENT= IRC Client similer to BitchX or ircII
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= xaric.1