aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-03 00:21:56 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-03 00:21:56 +0000
commit7d7e897ba5696ceae664575be6ab187f2b21b4b0 (patch)
tree3cd4a60840a3f16d01c26def999465020cf9dd66 /irc
parent9706c706c493e68d42ee0eda3ab08b13dbf7b681 (diff)
downloadports-7d7e897ba5696ceae664575be6ab187f2b21b4b0.tar.gz
ports-7d7e897ba5696ceae664575be6ab187f2b21b4b0.zip
- Add patch to fix core dump issue on amd64
- Bump portrevision PR: ports/125108 Submitted by: Chris Pet <chrispetso@gmail.com>
Notes
Notes: svn path=/head/; revision=216188
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/bitchx/files/patch-amd64_fix44
2 files changed, 45 insertions, 1 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index a1a0f8e8a004..6130adaf1fb0 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= irc
MASTER_SITES= SF
DISTNAME= ircii-pana-1.1-final
diff --git a/irc/bitchx/files/patch-amd64_fix b/irc/bitchx/files/patch-amd64_fix
new file mode 100644
index 000000000000..bd73ca030e38
--- /dev/null
+++ b/irc/bitchx/files/patch-amd64_fix
@@ -0,0 +1,44 @@
+
+
+Patch attached with submission follows:
+
+diff -ur BitchX.orig/include/module.h BitchX/include/module.h
+--- BitchX.orig/include/module.h Fri Apr 11 03:09:07 2003
++++ include/module.h Sun Jan 8 17:18:15 2006
+@@ -15,7 +15,7 @@
+
+ #include "struct.h"
+
+-typedef int (*Function_ptr)();
++typedef long (*Function_ptr)();
+
+ #ifdef WANT_DLL
+ #ifdef HPUX
+diff -ur BitchX.orig/include/modval.h BitchX/include/modval.h
+--- BitchX.orig/include/modval.h Fri Apr 11 03:09:07 2003
++++ include/modval.h Sun Jan 8 17:18:15 2006
+@@ -318,7 +318,7 @@
+ #define show_window(x) ((void) (global[SHOW_WINDOW]((Window *)x)))
+ #define get_status_by_refnum(x, y) ((char *) (global[GET_STATUS_BY_REFNUM]((unsigned int)x, (unsigned int)y)))
+ #define get_visible_by_refnum(x) ((int) (global[GET_VISIBLE_BY_REFNUM]((char *)x)))
+-#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned int)x)))
++#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned long)x)))
+ #define get_window_by_refnum(x) ((Window *) (global[GET_WINDOW_BY_REFNUM]((unsigned int)x)))
+ #define get_window_by_name(x) ((Window *) (global[GET_WINDOW_BY_NAME]((char *)x)))
+ #define next_window(x, y) ((void) (global[FUNC_NEXT_WINDOW]((char)x, (char *)y)))
+diff -ur BitchX.orig/source/screen.c BitchX/source/screen.c
+--- BitchX.orig/source/screen.c Thu Jul 31 09:01:08 2003
++++ source/screen.c Sun Jan 8 17:18:18 2006
+@@ -1377,8 +1377,8 @@
+ {
+ if (!w)
+ w = current_window;
+- if (w->screen)
+- w->screen->cursor_window = w;
++/* if (w->screen)
++ w->screen->cursor_window = w;*/
+ }
+
+ /*
+
+