aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-19 19:43:44 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-19 19:43:44 +0000
commit8a953fe5656db5535bd19ec4c841d29480a1d35c (patch)
tree317a4924c9218ce35026dcc8e3636073326ce05a /irc
parent38fe420d269563f8211cb014c43c64b42fd4c493 (diff)
downloadports-8a953fe5656db5535bd19ec4c841d29480a1d35c.tar.gz
ports-8a953fe5656db5535bd19ec4c841d29480a1d35c.zip
Update to 1.9.8.
Notes
Notes: svn path=/head/; revision=73528
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile15
-rw-r--r--irc/xchat-gnome/distinfo2
-rw-r--r--irc/xchat-gnome/files/patch-Makefile.in10
-rw-r--r--irc/xchat-gnome/files/patch-configure63
-rw-r--r--irc/xchat-gnome/pkg-plist2
-rw-r--r--irc/xchat2/Makefile15
-rw-r--r--irc/xchat2/distinfo2
-rw-r--r--irc/xchat2/files/patch-Makefile.in10
-rw-r--r--irc/xchat2/files/patch-configure63
-rw-r--r--irc/xchat2/pkg-plist2
10 files changed, 64 insertions, 120 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index c4131b548f54..34a175d3e3ba 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xchat2
-PORTVERSION= 1.9.4
-PORTREVISION= 1
+PORTVERSION= 1.9.8
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.9/ \
http://xchat.linuxpower.org/files/source/1.9/
@@ -23,7 +22,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -38,10 +37,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(WITH_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-openssl
-.endif
+# openssl in now default in configure
.if defined(WITH_PYTHON)
USE_PYTHON= yes
@@ -53,16 +49,13 @@ PLIST_SUB= PYTHON="@comment "
.endif
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SSL) || !defined(WITH_SOCKS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
.if !defined(WITH_PYTHON)
@${ECHO_MSG} "WITH_PYTHON=yes for Python support"
.endif
-.if !defined(WITH_SSL)
- @${ECHO_MSG} "WITH_SSL=yes for OpenSSL support"
-.endif
.if !defined(WITH_SOCKS)
@${ECHO_MSG} "WITH_SOCKS=yes for SOCKS5 proxy support"
.endif
diff --git a/irc/xchat-gnome/distinfo b/irc/xchat-gnome/distinfo
index 5267fc5c4d62..bfa09ccdb790 100644
--- a/irc/xchat-gnome/distinfo
+++ b/irc/xchat-gnome/distinfo
@@ -1 +1 @@
-MD5 (xchat-1.9.4.tar.bz2) = ed0820b35e5a9c7c5860108a1555236f
+MD5 (xchat-1.9.8.tar.bz2) = f7df856c9fec9d9776738129dec6c063
diff --git a/irc/xchat-gnome/files/patch-Makefile.in b/irc/xchat-gnome/files/patch-Makefile.in
index 1d4ec6ca1aae..796ecc226be9 100644
--- a/irc/xchat-gnome/files/patch-Makefile.in
+++ b/irc/xchat-gnome/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Sat Aug 17 23:57:01 2002
-+++ Makefile.in Sat Aug 17 23:57:45 2002
-@@ -122,7 +122,7 @@
+--- Makefile.in.orig Sun Dec 8 23:16:00 2002
++++ Makefile.in Sun Dec 8 23:16:41 2002
+@@ -145,7 +145,7 @@
icondir = $(datadir)/pixmaps
util_DATA = xchat.desktop
--utildir = $(sysconfdir)/X11/applnk/Internet
+-utildir = $(datadir)/applications
+utildir = $(datadir)/apps/Internet
+ subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = config.h
diff --git a/irc/xchat-gnome/files/patch-configure b/irc/xchat-gnome/files/patch-configure
index e9036bdc9622..04cf2b246013 100644
--- a/irc/xchat-gnome/files/patch-configure
+++ b/irc/xchat-gnome/files/patch-configure
@@ -1,51 +1,28 @@
---- configure.orig Sat Aug 17 23:42:13 2002
-+++ configure Sat Aug 17 23:42:55 2002
-@@ -3211,10 +3211,10 @@
+--- configure.orig Sun Nov 24 20:59:19 2002
++++ configure Sun Dec 8 18:13:53 2002
+@@ -7358,6 +7358,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -10381,7 +10382,7 @@
#include "confdefs.h"
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *libintl_nl_domain_bindings;
- int main() {
+ #ifdef F77_DUMMY_MAIN
+ # ifdef __cplusplus
+ extern "C"
+@@ -10392,7 +10393,7 @@
+ main ()
+ {
bindtextdomain ("", "");
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
- ; return 0; }
- EOF
- if { (eval echo configure:3221: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -3600,7 +3600,7 @@
- #include "confdefs.h"
- #include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
-+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -3608,7 +3608,7 @@
- const char *_nl_expand_alias ();
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:3615: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -3628,7 +3628,7 @@
- #include "confdefs.h"
- #include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
-+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -3636,7 +3636,7 @@
- const char *_nl_expand_alias ();
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:3643: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ;
+ return 0;
+ }
diff --git a/irc/xchat-gnome/pkg-plist b/irc/xchat-gnome/pkg-plist
index ef2b9ae6ae04..b57bdb84a5ca 100644
--- a/irc/xchat-gnome/pkg-plist
+++ b/irc/xchat-gnome/pkg-plist
@@ -4,12 +4,14 @@ lib/xchat/plugins/perl.so
%%PYTHON%%lib/xchat/plugins/python.so
share/gnome/apps/Internet/xchat.desktop
share/gnome/pixmaps/xchat.png
+share/locale/am/LC_MESSAGES/xchat.mo
share/locale/ca/LC_MESSAGES/xchat.mo
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
share/locale/el/LC_MESSAGES/xchat.mo
share/locale/es/LC_MESSAGES/xchat.mo
+share/locale/et/LC_MESSAGES/xchat.mo
share/locale/fi/LC_MESSAGES/xchat.mo
share/locale/fr/LC_MESSAGES/xchat.mo
share/locale/he/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index c4131b548f54..34a175d3e3ba 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xchat2
-PORTVERSION= 1.9.4
-PORTREVISION= 1
+PORTVERSION= 1.9.8
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.9/ \
http://xchat.linuxpower.org/files/source/1.9/
@@ -23,7 +22,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -38,10 +37,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(WITH_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-openssl
-.endif
+# openssl in now default in configure
.if defined(WITH_PYTHON)
USE_PYTHON= yes
@@ -53,16 +49,13 @@ PLIST_SUB= PYTHON="@comment "
.endif
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SSL) || !defined(WITH_SOCKS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
.if !defined(WITH_PYTHON)
@${ECHO_MSG} "WITH_PYTHON=yes for Python support"
.endif
-.if !defined(WITH_SSL)
- @${ECHO_MSG} "WITH_SSL=yes for OpenSSL support"
-.endif
.if !defined(WITH_SOCKS)
@${ECHO_MSG} "WITH_SOCKS=yes for SOCKS5 proxy support"
.endif
diff --git a/irc/xchat2/distinfo b/irc/xchat2/distinfo
index 5267fc5c4d62..bfa09ccdb790 100644
--- a/irc/xchat2/distinfo
+++ b/irc/xchat2/distinfo
@@ -1 +1 @@
-MD5 (xchat-1.9.4.tar.bz2) = ed0820b35e5a9c7c5860108a1555236f
+MD5 (xchat-1.9.8.tar.bz2) = f7df856c9fec9d9776738129dec6c063
diff --git a/irc/xchat2/files/patch-Makefile.in b/irc/xchat2/files/patch-Makefile.in
index 1d4ec6ca1aae..796ecc226be9 100644
--- a/irc/xchat2/files/patch-Makefile.in
+++ b/irc/xchat2/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Sat Aug 17 23:57:01 2002
-+++ Makefile.in Sat Aug 17 23:57:45 2002
-@@ -122,7 +122,7 @@
+--- Makefile.in.orig Sun Dec 8 23:16:00 2002
++++ Makefile.in Sun Dec 8 23:16:41 2002
+@@ -145,7 +145,7 @@
icondir = $(datadir)/pixmaps
util_DATA = xchat.desktop
--utildir = $(sysconfdir)/X11/applnk/Internet
+-utildir = $(datadir)/applications
+utildir = $(datadir)/apps/Internet
+ subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = config.h
diff --git a/irc/xchat2/files/patch-configure b/irc/xchat2/files/patch-configure
index e9036bdc9622..04cf2b246013 100644
--- a/irc/xchat2/files/patch-configure
+++ b/irc/xchat2/files/patch-configure
@@ -1,51 +1,28 @@
---- configure.orig Sat Aug 17 23:42:13 2002
-+++ configure Sat Aug 17 23:42:55 2002
-@@ -3211,10 +3211,10 @@
+--- configure.orig Sun Nov 24 20:59:19 2002
++++ configure Sun Dec 8 18:13:53 2002
+@@ -7358,6 +7358,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -10381,7 +10382,7 @@
#include "confdefs.h"
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *libintl_nl_domain_bindings;
- int main() {
+ #ifdef F77_DUMMY_MAIN
+ # ifdef __cplusplus
+ extern "C"
+@@ -10392,7 +10393,7 @@
+ main ()
+ {
bindtextdomain ("", "");
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
- ; return 0; }
- EOF
- if { (eval echo configure:3221: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -3600,7 +3600,7 @@
- #include "confdefs.h"
- #include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
-+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -3608,7 +3608,7 @@
- const char *_nl_expand_alias ();
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:3615: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -3628,7 +3628,7 @@
- #include "confdefs.h"
- #include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
-+extern int *libintl_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
-@@ -3636,7 +3636,7 @@
- const char *_nl_expand_alias ();
- int main() {
- bindtextdomain ("", "");
--return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
-+return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings + *_nl_expand_alias (0)
- ; return 0; }
- EOF
- if { (eval echo configure:3643: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ;
+ return 0;
+ }
diff --git a/irc/xchat2/pkg-plist b/irc/xchat2/pkg-plist
index ef2b9ae6ae04..b57bdb84a5ca 100644
--- a/irc/xchat2/pkg-plist
+++ b/irc/xchat2/pkg-plist
@@ -4,12 +4,14 @@ lib/xchat/plugins/perl.so
%%PYTHON%%lib/xchat/plugins/python.so
share/gnome/apps/Internet/xchat.desktop
share/gnome/pixmaps/xchat.png
+share/locale/am/LC_MESSAGES/xchat.mo
share/locale/ca/LC_MESSAGES/xchat.mo
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
share/locale/el/LC_MESSAGES/xchat.mo
share/locale/es/LC_MESSAGES/xchat.mo
+share/locale/et/LC_MESSAGES/xchat.mo
share/locale/fi/LC_MESSAGES/xchat.mo
share/locale/fr/LC_MESSAGES/xchat.mo
share/locale/he/LC_MESSAGES/xchat.mo