aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-03-15 21:45:12 +0000
committerClive Lin <clive@FreeBSD.org>2001-03-15 21:45:12 +0000
commitf9ca2d0669ad31171a10c4f288179f50858b3319 (patch)
tree01d5a4683ab069eac05229431d55760c70b7773c /irc
parent39cba59c63d5e746b577e39f8df049e530b108bc (diff)
downloadports-f9ca2d0669ad31171a10c4f288179f50858b3319.tar.gz
ports-f9ca2d0669ad31171a10c4f288179f50858b3319.zip
o Nasty fix to deal with "Why some files are bzip2's ????"
BX runs well without bzip2. Not that good to introduce another RUN_DEPENDS spam. o Add 2 patch files I forgot in previous commit.
Notes
Notes: svn path=/head/; revision=39900
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile3
-rw-r--r--irc/bitchx/files/patch-ap12
-rw-r--r--irc/bitchx/files/patch-aq33
3 files changed, 47 insertions, 1 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 6b13cbad08bd..7fd061f1f4d2 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -69,10 +69,11 @@ CONFIGURE_ARGS+=--without-plugins
PLIST_SUB+= PLUGINS:="@comment "
.endif
-.if defined(WITH_LATIN)
pre-patch:
+.if defined(WITH_LATIN)
@${PERL} -pi -e "s!#undef LATIN1!#define LATIN1!" ${WRKSRC}/include/config.h
.endif
+ @${PERL} -pi -e "s!bzip2!true!g" ${WRKSRC}/Makefile.in
pre-extract:
@${ECHO} "Available switches:"
diff --git a/irc/bitchx/files/patch-ap b/irc/bitchx/files/patch-ap
new file mode 100644
index 000000000000..ae3adcf497f3
--- /dev/null
+++ b/irc/bitchx/files/patch-ap
@@ -0,0 +1,12 @@
+--- Makefile.in.orig Tue Mar 13 18:40:31 2001
++++ Makefile.in Tue Mar 13 18:42:58 2001
+@@ -114,8 +114,7 @@
+
+ # This command will be used to install the BitchX help files. If you don't
+ # want to install them, replace with the following:
+-# INSTALL_HELP_CMD = @echo The help files have not been installed.
+-INSTALL_HELP_CMD = @INSTALL_HELP_CMD@
++INSTALL_HELP_CMD = echo
+
+ # This is where the optional plugins will be copied to.
+ PLUGINDIR = @PLUGINDIR@
diff --git a/irc/bitchx/files/patch-aq b/irc/bitchx/files/patch-aq
new file mode 100644
index 000000000000..3ba41fccd0d7
--- /dev/null
+++ b/irc/bitchx/files/patch-aq
@@ -0,0 +1,33 @@
+--- include/config.h.old Wed Mar 14 11:20:48 2001
++++ include/config.h Wed Mar 14 11:23:51 2001
+@@ -468,7 +468,7 @@
+ #define DEFAULT_FTP_GRAB OFF
+ #define DEFAULT_HTTP_GRAB OFF
+ #define DEFAULT_HELP_WINDOW OFF
+-#define DEFAULT_NICK_COMPLETION ON
++#define DEFAULT_NICK_COMPLETION OFF
+ #define DEFAULT_NICK_COMPLETION_LEN 2
+ #define DEFAULT_NICK_COMPLETION_TYPE 0 /* 0 1 2 */
+ #define DEFAULT_NOTIFY ON
+@@ -498,9 +498,9 @@
+ #define DEFAULT_AINV 0
+ #define DEFAULT_ANNOY_KICK OFF
+ #define DEFAULT_AOP_VAR OFF
+-#define DEFAULT_AUTO_AWAY ON
+-#define DEFAULT_KICK_OPS ON
+-#define DEFAULT_AUTO_REJOIN ON
++#define DEFAULT_AUTO_AWAY OFF
++#define DEFAULT_KICK_OPS OFF
++#define DEFAULT_AUTO_REJOIN OFF
+ #define DEFAULT_DEOPFLOOD ON
+ #if defined(__EMXPM__) || defined(WIN32)
+ #define DEFAULT_CODEPAGE 437
+@@ -702,7 +702,7 @@
+ #endif
+
+ #undef PARANOID /* #define this if your paranoid about dcc hijacking */
+-#undef WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
++#define WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
+
+ /* new epic stuff */
+ #define OLD_STATUS_S_EXPANDO_BEHAVIOR