aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 23:07:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 23:07:01 +0000
commitef04b7f3ae07d0c1b72066f1524d35b856ee2c78 (patch)
tree27e91cf26a53df32847c864d0f62698b448c8b71 /irc
parent5c0d042ee77e26820e035c586dd6eb263d83485b (diff)
downloadports-ef04b7f3ae07d0c1b72066f1524d35b856ee2c78.tar.gz
ports-ef04b7f3ae07d0c1b72066f1524d35b856ee2c78.zip
add p5-POE-Component-IRC
A fully event-driven IRC client module
Notes
Notes: svn path=/head/; revision=46448
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Component-IRC/Makefile29
-rw-r--r--irc/p5-POE-Component-IRC/distinfo1
-rw-r--r--irc/p5-POE-Component-IRC/pkg-comment1
-rw-r--r--irc/p5-POE-Component-IRC/pkg-descr5
-rw-r--r--irc/p5-POE-Component-IRC/pkg-plist10
6 files changed, 47 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index f4f17679aa14..04732a239191 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -26,6 +26,7 @@
SUBDIR += ninja
SUBDIR += olirc
SUBDIR += p5-IRC
+ SUBDIR += p5-POE-Component-IRC
SUBDIR += party
SUBDIR += pure-emacs20
SUBDIR += pure-xemacs21-mule
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
new file mode 100644
index 000000000000..2760e15a7caf
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: POE::Component::IRC
+# Date created: Aug 19, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC
+PORTVERSION= 1.7
+CATEGORIES= irc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::Filter-CTCP.3 \
+ POE::Component::IRC.3 \
+ POE::Component::Filter-IRC.3
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC/distinfo b/irc/p5-POE-Component-IRC/distinfo
new file mode 100644
index 000000000000..70049285a3b9
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-IRC-1.7.tar.gz) = 942f2b5c058ad48c628cf178b5f6215b
diff --git a/irc/p5-POE-Component-IRC/pkg-comment b/irc/p5-POE-Component-IRC/pkg-comment
new file mode 100644
index 000000000000..cc1f915dd56c
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/pkg-comment
@@ -0,0 +1 @@
+A fully event-driven IRC client module
diff --git a/irc/p5-POE-Component-IRC/pkg-descr b/irc/p5-POE-Component-IRC/pkg-descr
new file mode 100644
index 000000000000..487c59ea72ab
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/pkg-descr
@@ -0,0 +1,5 @@
+POE::Component::IRC is a POE component (who'd have guessed?) which acts as
+an easily controllable IRC client for your other POE components and
+sessions. You create an IRC component and tell it what events your session
+cares about and where to connect to, and it sends back interesting IRC
+events when they happen. You make the client do things by sending it events.
diff --git a/irc/p5-POE-Component-IRC/pkg-plist b/irc/p5-POE-Component-IRC/pkg-plist
new file mode 100644
index 000000000000..9f1eea450382
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/IRC.pm
+lib/perl5/site_perl/%%PERL_VER%%/POE/Filter/CTCP.pm
+lib/perl5/site_perl/%%PERL_VER%%/POE/Filter/IRC.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/IRC/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true