aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-11-15 15:40:23 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-11-15 15:40:23 +0000
commit60fcecc73b10e848d956afbbf3e8f2eefc45ede5 (patch)
treec453a8c72bebf8c85ecd3c51b3aab7348e406684 /irc
parent3153153f7ee3aada6c57ee91de0e0ad806481653 (diff)
downloadports-60fcecc73b10e848d956afbbf3e8f2eefc45ede5.tar.gz
ports-60fcecc73b10e848d956afbbf3e8f2eefc45ede5.zip
- Update to version 0.1.6
- Implement WITH_PYTHON knob Submitted by: Rudolf Polzer <freebsd-dr@durchnull.de> (via email)
Notes
Notes: svn path=/head/; revision=148377
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat-devel/Makefile22
-rw-r--r--irc/weechat-devel/distinfo5
-rw-r--r--irc/weechat/Makefile22
-rw-r--r--irc/weechat/distinfo5
4 files changed, 44 insertions, 10 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 4c1269ef3a65..8d6cc6ee03b4 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= weechat
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.6
CATEGORIES= irc
-MASTER_SITES= http://weechat.flashtux.org/download/
+MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
+ http://weechat.flashtux.org/download/
MAINTAINER= az@FreeBSD.org
COMMENT= A lightweight and user friendly ncurse based IRC client
USE_BZIP2= yes
GNU_CONFIGURE= yes
-
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
@@ -25,6 +25,7 @@ MAN1= weechat-curses.1
INFO= weechat_doc_en weechat_doc_es weechat_doc_fr weechat_doc_pt
PLIST_FILES= bin/weechat-curses
+PLIST_DIRS= lib/weechat/plugins lib/weechat
.for lang in cs fr es
PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/weechat.mo
@@ -38,6 +39,21 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+#Tempory disable due problems with perl < 5.6 (4.x)
+#.if defined(WITH_PERL)
+#CONFIGURE_ARGS+=--enable-perl
+#USE_PERL= yes
+#PLIST_FILES+= lib/weechat/plugins/libperl.a lib/weechat/plugins/libperl.la \
+# lib/weechat/plugins/libperl.so lib/weechat/plugins/libperl.so.0
+#.endif
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+=--enable-python
+USE_PYTHON= yes
+PLIST_FILES+= lib/weechat/plugins/libpython.a lib/weechat/plugins/libpython.la \
+ lib/weechat/plugins/libpython.so lib/weechat/plugins/libpython.so.0
+.endif
+
pre-configure:
@${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
index a21fb008156a..f27f30c93773 100644
--- a/irc/weechat-devel/distinfo
+++ b/irc/weechat-devel/distinfo
@@ -1,2 +1,3 @@
-MD5 (weechat-0.1.5.tar.bz2) = 7aaf7e7f5b9d013b7269c9ca454fdbf9
-SIZE (weechat-0.1.5.tar.bz2) = 620739
+MD5 (weechat-0.1.6.tar.bz2) = 4e0898f4a318b5f4419a2b072c61d54c
+SHA256 (weechat-0.1.6.tar.bz2) = 2c5de0ab453104e0dad37f1083aa0b8100a957f7593b831c860bd6394ceafb90
+SIZE (weechat-0.1.6.tar.bz2) = 824914
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 4c1269ef3a65..8d6cc6ee03b4 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= weechat
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.6
CATEGORIES= irc
-MASTER_SITES= http://weechat.flashtux.org/download/
+MASTER_SITES= http://flashcode.free.fr/flashtux/weechat/ \
+ http://weechat.flashtux.org/download/
MAINTAINER= az@FreeBSD.org
COMMENT= A lightweight and user friendly ncurse based IRC client
USE_BZIP2= yes
GNU_CONFIGURE= yes
-
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
@@ -25,6 +25,7 @@ MAN1= weechat-curses.1
INFO= weechat_doc_en weechat_doc_es weechat_doc_fr weechat_doc_pt
PLIST_FILES= bin/weechat-curses
+PLIST_DIRS= lib/weechat/plugins lib/weechat
.for lang in cs fr es
PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/weechat.mo
@@ -38,6 +39,21 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+#Tempory disable due problems with perl < 5.6 (4.x)
+#.if defined(WITH_PERL)
+#CONFIGURE_ARGS+=--enable-perl
+#USE_PERL= yes
+#PLIST_FILES+= lib/weechat/plugins/libperl.a lib/weechat/plugins/libperl.la \
+# lib/weechat/plugins/libperl.so lib/weechat/plugins/libperl.so.0
+#.endif
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+=--enable-python
+USE_PYTHON= yes
+PLIST_FILES+= lib/weechat/plugins/libpython.a lib/weechat/plugins/libpython.la \
+ lib/weechat/plugins/libpython.so lib/weechat/plugins/libpython.so.0
+.endif
+
pre-configure:
@${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
index a21fb008156a..f27f30c93773 100644
--- a/irc/weechat/distinfo
+++ b/irc/weechat/distinfo
@@ -1,2 +1,3 @@
-MD5 (weechat-0.1.5.tar.bz2) = 7aaf7e7f5b9d013b7269c9ca454fdbf9
-SIZE (weechat-0.1.5.tar.bz2) = 620739
+MD5 (weechat-0.1.6.tar.bz2) = 4e0898f4a318b5f4419a2b072c61d54c
+SHA256 (weechat-0.1.6.tar.bz2) = 2c5de0ab453104e0dad37f1083aa0b8100a957f7593b831c860bd6394ceafb90
+SIZE (weechat-0.1.6.tar.bz2) = 824914