aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-10 22:17:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-10 22:17:03 +0000
commit62393e6ea8406baf97d2617e156c2b593df65482 (patch)
treed23d5bac287ed78800fbf0c847797bb480b9f9b4 /irc
parent61fb6596a0029a21ebdcaab72dc97fa840e4fe04 (diff)
downloadports-62393e6ea8406baf97d2617e156c2b593df65482.tar.gz
ports-62393e6ea8406baf97d2617e156c2b593df65482.zip
- Replace our patch with more correct one obtained from author
- Add faster master site PR: ports/60118 Submitted by: Scott M. Likens <damm@yazzy.org> (maintainer)
Notes
Notes: svn path=/head/; revision=95575
Diffstat (limited to 'irc')
-rw-r--r--irc/scrollz/Makefile4
-rw-r--r--irc/scrollz/files/patch-source-ircaux.c30
2 files changed, 26 insertions, 8 deletions
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index d256f0509340..01fef8afe0de 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -7,8 +7,10 @@
PORTNAME= scrollz
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= irc ipv6
-MASTER_SITES= ftp://ftp.du.se/pub/mirrors/ScrollZ/source/
+MASTER_SITES= http://scrollz.broken.com/source/ \
+ ftp://ftp.du.se/pub/mirrors/ScrollZ/source/
DISTNAME= ScrollZ-${PORTVERSION}
MAINTAINER= damm@yazzy.org
diff --git a/irc/scrollz/files/patch-source-ircaux.c b/irc/scrollz/files/patch-source-ircaux.c
index b7ddfa8163bc..ca9f3501f5ed 100644
--- a/irc/scrollz/files/patch-source-ircaux.c
+++ b/irc/scrollz/files/patch-source-ircaux.c
@@ -1,14 +1,30 @@
--- source/ircaux.c.orig Thu Oct 3 21:16:38 2002
-+++ source/ircaux.c Tue Nov 18 15:58:26 2003
-@@ -869,9 +869,11 @@
- return -10;
- #else
++++ source/ircaux.c Wed Dec 10 23:10:54 2003
+@@ -861,20 +861,19 @@
+ err = getaddrinfo(localhost, localport, &hintsx, &res0x);
+
+ if (err != 0)
+-#if defined(__linux__) && 0
+- /*
+- * Due to bug in glibc implementation in getaddrinfo() we always
+- * return -10. This will be fixed, soon
+- */
+- return -10;
+-#else
{
-+#ifndef __FreeBSD__
++ # ifndef EAI_ADDRFAMILY
++ # ifdef EAI_FAMILY
++ # define EAI_ADDRFAMILY EAI_FAMILY
++ # else
++ # error "no EAI_ADDRFAMILY or EAI_FAMILY"
++ # endif
++ # endif
if (err == EAI_ADDRFAMILY)
return -10;
else
-+#endif
return -2;
}
- #endif
+-#endif
+ err = -1;
+ for (resx = res0x; resx; resx = resx->ai_next)
+ {