aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-12 10:45:48 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-12 10:45:48 +0000
commite6909fa84f55c3e16183ef0f2dd4cd03c81b4614 (patch)
tree86a60084e8b7d6f43e4306e7010c8e221104ed7c /irc
parentb1d3818c6f840e9e3ba92f7f891b2d68a27ef32f (diff)
downloadports-e6909fa84f55c3e16183ef0f2dd4cd03c81b4614.tar.gz
ports-e6909fa84f55c3e16183ef0f2dd4cd03c81b4614.zip
Re-add srvx 1.2.1, srvx IRC services. [1]
Rename port 'svrx' to 'srvx'. [2] So I remove svrx. There's only one update in history, so I think I need to asj for a repocopy. PR: 59817, 61218 (update), 61232 [2] Submitted by: Walter Venable <weaseal@hotmail.com> (maintainer) Pointy hat to: me Approved by: erwin (mentor)
Notes
Notes: svn path=/head/; revision=97980
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/srvx/Makefile51
-rw-r--r--irc/srvx/distinfo1
-rw-r--r--irc/srvx/files/patch-aa25
-rw-r--r--irc/srvx/files/patch-ab11
-rw-r--r--irc/srvx/pkg-descr17
-rw-r--r--irc/srvx/pkg-plist12
7 files changed, 118 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 046051d97767..1278f36760e4 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -71,6 +71,7 @@
SUBDIR += sirc
SUBDIR += sircd
SUBDIR += slirc
+ SUBDIR += srvx
SUBDIR += tirc
SUBDIR += tircproxy
SUBDIR += tkirc
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
new file mode 100644
index 000000000000..eeb4bb5481ea
--- /dev/null
+++ b/irc/srvx/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: srvx
+# Date created: 2003-11-28
+# Whom: Walter Venable <weaseal@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= srvx
+PORTVERSION= 1.2.1
+CATEGORIES= irc net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= srvx
+
+MAINTAINER= weaseal@hotmail.com
+COMMENT= Srvx IRC services
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_PROTOCOL_BAHAMUT)
+CONFIGURE_ARGS+= --with-protocol=bahamut
+.endif
+
+pre-fetch:
+ @ ${ECHO} ""
+ @ ${ECHO} "--------------------------------------------------------------------------------"
+ @ ${ECHO} ""
+ @ ${ECHO} "The following build options are availabe:"
+ @ ${ECHO} ""
+ @ ${ECHO} " WITH_PROTOCOL_BAHAMUT=yes Enables Bahamut protocol"
+ @ ${ECHO} " (P10 is default)."
+ @ ${ECHO} ""
+ @ ${ECHO} " WITH_DEBUG=yes Enables debug mode."
+ @ ${ECHO} ""
+ @ ${ECHO} "--------------------------------------------------------------------------------"
+ @ ${ECHO} ""
+
+post-install:
+ @ ${ECHO} ""
+ @ ${ECHO} " When you 'make deinstall', any files generated by ${PORTNAME} (logs, etc)"
+ @ ${ECHO} " will remain in ${PREFIX}/etc/. These files must be removed"
+ @ ${ECHO} " manually."
+ @ ${ECHO} ""
+ @ ${ECHO} " ${PORTNAME} .help files are located in ${DOCSDIR}."
+ @ ${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/irc/srvx/distinfo b/irc/srvx/distinfo
new file mode 100644
index 000000000000..a293aa21664e
--- /dev/null
+++ b/irc/srvx/distinfo
@@ -0,0 +1 @@
+MD5 (srvx-1.2.1.tar.gz) = 4c1c4982fbc23156dbeb6d5c33850c3b
diff --git a/irc/srvx/files/patch-aa b/irc/srvx/files/patch-aa
new file mode 100644
index 000000000000..b1c049dc0b7b
--- /dev/null
+++ b/irc/srvx/files/patch-aa
@@ -0,0 +1,25 @@
+--- Makefile.in Sun Oct 12 22:37:15 2003
++++ Makefile.in Sun Nov 30 04:31:56 2003
+@@ -519,12 +519,17 @@
+
+ install-exec-local:
+ $(INSTALL) -d -m 755 $(prefix)
+- $(INSTALL) -m 744 ./src/srvx $(prefix)
+- $(INSTALL) -m 644 $(srcdir)/src/*.help $(prefix)
+- $(INSTALL) -m 600 $(srcdir)/srvx.conf.example $(prefix)
+- $(INSTALL) -m 644 $(srcdir)/sockcheck.conf.example $(prefix)
++ $(INSTALL) -d -m 755 $(prefix)/etc
++ $(INSTALL) -d -m 755 $(prefix)/share
++ $(INSTALL) -d -m 755 $(prefix)/share/doc
++ $(INSTALL) -d -m 755 $(prefix)/share/doc/srvx
++ $(INSTALL) -d -m 755 $(prefix)/bin
++ $(INSTALL) -m 744 ./src/srvx $(prefix)/bin/srvx
++ $(INSTALL) -m 644 $(srcdir)/src/*.help $(prefix)/share/doc/srvx/
++ $(INSTALL) -m 600 $(srcdir)/srvx.conf.example $(prefix)/etc/
++ $(INSTALL) -m 644 $(srcdir)/sockcheck.conf.example $(prefix)/etc/
+ @echo
+- @echo srvx-$(VERSION) has been installed to $(prefix)
++ @echo srvx-$(VERSION) has been installed to $(prefix)/bin
+ @echo Remember to edit srvx.conf.example and sockcheck.conf.example
+ @echo And of course, ./srvx --help before starting.
+ @echo
diff --git a/irc/srvx/files/patch-ab b/irc/srvx/files/patch-ab
new file mode 100644
index 000000000000..4a52ec7280f6
--- /dev/null
+++ b/irc/srvx/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/main.c Mon Sep 1 10:50:28 2003
++++ src/main.c Sun Nov 30 03:17:29 2003
+@@ -65,7 +65,7 @@
+
+ int quit_services, max_cycles;
+
+-char *services_config = "srvx.conf";
++char *services_config = "../etc/srvx.conf";
+
+ char **services_argv;
+ int services_argc;
diff --git a/irc/srvx/pkg-descr b/irc/srvx/pkg-descr
new file mode 100644
index 000000000000..b8a4304972bf
--- /dev/null
+++ b/irc/srvx/pkg-descr
@@ -0,0 +1,17 @@
+srvx is a set of IRC services for ircu P10 protocol networks; it
+is developed by a team of programmers affiliated with the GamesNET
+IRC Network. srvx is designed to be a fast, extensible, scalable
+and reliable provider of NickServ, ChanServ, HelpServ, OperServ,
+and Global services as well as advanced proxy detection.
+
+srvx is open source software; the source is available for download under
+the terms and conditions of the GNU General Public License, commonly known
+as the GNU GPL.
+
+The authors can be contacted via irc on irc.gamesnet.net in channel #srvx.
+Note that only one of the many authors is listed below, see website for a
+full list.
+
+Author: "Entrope" <entrope@users.sourceforge.net>
+WWW: http://www.srvx.net
+
diff --git a/irc/srvx/pkg-plist b/irc/srvx/pkg-plist
new file mode 100644
index 000000000000..71da6b738780
--- /dev/null
+++ b/irc/srvx/pkg-plist
@@ -0,0 +1,12 @@
+bin/srvx
+etc/srvx.conf.example
+etc/sockcheck.conf.example
+%%DOCSDIR%%/chanserv.help
+%%DOCSDIR%%/global.help
+%%DOCSDIR%%/helpserv.help
+%%DOCSDIR%%/modcmd.help
+%%DOCSDIR%%/nickserv.help
+%%DOCSDIR%%/opserv.help
+%%DOCSDIR%%/saxdb.help
+%%DOCSDIR%%/sendmail.help
+%%DOCSDIR%%/sockcheck.help