aboutsummaryrefslogtreecommitdiff
path: root/japanese/bugzilla/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-08-07 20:35:58 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-08-07 20:35:58 +0000
commitce7512f0fec0efc923f668e82213abcca790f191 (patch)
treedb540269f15bb29da2a2f163231e14ab726d20ba /japanese/bugzilla/Makefile
parent1d18b6525976da2a9f22c009fc480ac5f846bd50 (diff)
downloadports-ce7512f0fec0efc923f668e82213abcca790f191.tar.gz
ports-ce7512f0fec0efc923f668e82213abcca790f191.zip
- Update to 4.0.7
- Remove PKGNAMEPREFIX (-ja) since a PKGNAMESUFFIX (ja-) is already applied - Add NO_WRKSUBDIR - Add the plist target from the german ports (no need to install before) - Fix build to be done with and without pkgng Submitted by: ohauer@ (based on)
Notes
Notes: svn path=/head/; revision=302260
Diffstat (limited to 'japanese/bugzilla/Makefile')
-rw-r--r--japanese/bugzilla/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/japanese/bugzilla/Makefile b/japanese/bugzilla/Makefile
index 524d11a8968e..e665a7a98268 100644
--- a/japanese/bugzilla/Makefile
+++ b/japanese/bugzilla/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= bugzilla
-PORTVERSION= 4.0.6
+PORTVERSION= 4.0.7
CATEGORIES= japanese
MASTER_SITES= http://bug-ja.org/releases/4.0/ \
LOCAL
MASTER_SITE_SUBDIR= tota/bugzilla-ja
-PKGNAMESUFFIX= -ja
DISTNAME= Bugzilla-ja-${PORTVERSION}-template-rel01
MAINTAINER= tota@FreeBSD.org
@@ -19,6 +18,8 @@ COMMENT= Japanese localization for Bugzilla
RUN_DEPENDS= bugzilla>=${PORTVERSION}:${PORTSDIR}/devel/bugzilla
+NO_WRKSUBDIR= yes
+
.include "${.CURDIR}/../../devel/bugzilla/Makefile.common"
USE_BZIP2= yes
@@ -34,4 +35,14 @@ do-install:
@${ECHO_MSG}
.endif
+# Maintainer
+plist: patch
+ @( cd ${WRKDIR}/ && ${FIND} default -type f | ${AWK} '{print "%%WWWDIR%%/template/ja/"$$1}' | ${SORT} > ${PLIST}.new )
+ @( cd ${WRKDIR}/ && ${FIND} default -type d | ${AWK} '{print "@dirrmtry %%WWWDIR%%/template/ja/"$$1}' | ${SORT} -r >> ${PLIST}.new )
+ @${ECHO} "@dirrmtry %%WWWDIR%%/template/ja" >> ${PLIST}.new
+ @if ${DIFF} -u ${PLIST} ${PLIST}.new ; then \
+ ${ECHO_MSG} no pkg-plist changes; \
+ ${RM} ${PLIST}.new ; \
+ fi
+
.include <bsd.port.mk>