aboutsummaryrefslogtreecommitdiff
path: root/japanese/eb2/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-08-19 10:50:30 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-08-19 10:50:30 +0000
commit7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172 (patch)
tree7e0475b3b0285bf94c178e763590639b372a1727 /japanese/eb2/Makefile
parentc6cace87c28b68e3981186743ad173a70d9b6637 (diff)
downloadports-7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172.tar.gz
ports-7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172.zip
Upgrade to ndtpd-2.3.2 and eb-2.3.2. PR was for ndtpd-2.3.1 and
eb-2.3, I changed the versions and recalculated the checksums. Also, ndtpd/patches/patch-aa (by me) is for quieting ndtpd somewhat so it won't leave dozens of lines to /var/log/messages every time someone looks up a word, and eb/patches/patch-aa (by Kasahara-san, the original author) is for changing the shared lib versions. ndtpd/Makefile's LIB_DEPENDS was adjusted accordingly. PR: 12130 Submitted by: maintainer Reviewed (my changes) by: maintainer
Notes
Notes: svn path=/head/; revision=20810
Diffstat (limited to 'japanese/eb2/Makefile')
-rw-r--r--japanese/eb2/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/japanese/eb2/Makefile b/japanese/eb2/Makefile
index 7522dc643e53..92dda7e010b3 100644
--- a/japanese/eb2/Makefile
+++ b/japanese/eb2/Makefile
@@ -1,30 +1,34 @@
# New ports collection makefile for: eb
-# Version required: 2.2
+# Version required: 2.3.2
# Date created: 20 Jan 1999
# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
#
-# $Id: Makefile,v 1.2 1999/03/13 07:35:40 taoka Exp $
+# $Id: Makefile,v 1.3 1999/06/05 22:29:54 mharo Exp $
#
-DISTNAME= eb-2.2.2
-PKGNAME= ja-eb-2.2.2
+DISTNAME= eb-2.3.2
+PKGNAME= ja-eb-2.3.2
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/appendix/ \
ftp://ftp.sra.co.jp/pub/misc/eb/appendix/old/ \
ftp://ftp.sra.co.jp/pub/misc/eb/ \
- ftp://ftp.sra.co.jp/pub/misc/eb/old/
+ ftp://ftp.sra.co.jp/pub/misc/eb/old/ \
+ ftp://ftp.mei.co.jp/free/others/Dictionary/eb/appendix/ \
+ ftp://ftp.mei.co.jp/free/others/Dictionary/eb/
DISTFILES= ${EBFILES} ${APPENDIXFILES}
MAINTAINER= takamune@avrl.mei.co.jp
EBFILES= ${DISTNAME}.tar.gz
-APPENDIXFILES= chujiten-2.3.tar.gz \
+APPENDIXFILES= cencro-1.0.tar.gz \
+ chujiten-2.3.tar.gz \
chujiten2-2.0.tar.gz \
chujiten6-2.3.tar.gz \
colloc-2.0.tar.gz \
crownfj-2.0.tar.gz \
daijirin-2.0.tar.gz \
dd75-2.0.tar.gz \
+ genius-1.0.tar.gz \
global-2.0.tar.gz \
heritage-2.2.tar.gz \
izumi-2.0.tar.gz \
@@ -39,11 +43,12 @@ APPENDIXFILES= chujiten-2.3.tar.gz \
plus-2.0.tar.gz \
readers-2.2.tar.gz \
readers2-2.0.tar.gz
+LISTFILES= LIST LIST-ja
EXTRACT_ONLY= ${EBFILES}
DIST_SUBDIR= eb
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-zlib
CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
INSTALL_DATA="${INSTALL_DATA}"
@@ -51,16 +56,11 @@ CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
APPENDIXDIR= ${PREFIX}/share/eb/appendix
post-install:
- for i in ${APPENDIXFILES}; do \
- dir="`echo $$i | ${SED} 's/\.tar\.gz$$//'`"; \
- ${RM} -rf ${APPENDIXDIR}/$$dir; \
- (cd ${APPENDIXDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
- ${DISTDIR}/${DIST_SUBDIR}/$$i ${EXTRACT_AFTER_ARGS}); \
- done
- ${INSTALL_DATA} ${FILESDIR}/LIST ${APPENDIXDIR}/LIST
- ${INSTALL_DATA} ${FILESDIR}/LIST-ja ${APPENDIXDIR}/LIST-ja
-.for info in eb ebinfo ebfont ebrefile ebzip
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
+.for file in ${APPENDIXFILES}
+ ${TAR} -C ${APPENDIXDIR} -zxmf ${DISTDIR}/${DIST_SUBDIR}/${file}
+.endfor
+.for file in ${LISTFILES}
+ ${INSTALL_DATA} ${FILESDIR}/${file} ${APPENDIXDIR}
.endfor
.include <bsd.port.mk>