aboutsummaryrefslogtreecommitdiff
path: root/japanese/eb
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-03-02 20:35:38 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-03-02 20:35:38 +0000
commit10a9be4461187a74fcb53fd93bf19677af0898c8 (patch)
treeeb6b3f4d7b8a78fa8630ab732bda22d93b8262e5 /japanese/eb
parent679bb7d807db5083e9091e4965d4072332a18e82 (diff)
downloadports-10a9be4461187a74fcb53fd93bf19677af0898c8.tar.gz
ports-10a9be4461187a74fcb53fd93bf19677af0898c8.zip
[0] Updates for the latest version 3.3.1
[1] Fix MASTER_SITES [2] Don't use configure option '--enable-pthread' (backout last commit) because it breaks japanese/ndtpd and the pthread support of EB library itself is still incomplete and experimental. [3] Remove imported patch; files/patch-eb::match.c [4] Add patch to use USE_LIBTOOL=yes; files/patch-configure [5] Use configure option '--build=...' [6] Use LOCALBASE instead of PREFIX for other installed packages [7] Use DATADIR [8] Don't be quiet at post-extract section (backout last commit) [9] Sort @dirrm section of pkg-plist; generated by (cd /usr/local; find -ds share/eb -type d) | sed 's,^,@dirrm ,' [4]-[7] were submitted by KATO Tsuguru <tkato@prontomail.com>. Thanks, Kato-san. PR: ports/48840 Submitted by: Kazu TAKAMUNE <takamune@avrl.mei.co.jp>
Notes
Notes: svn path=/head/; revision=76750
Diffstat (limited to 'japanese/eb')
-rw-r--r--japanese/eb/Makefile29
-rw-r--r--japanese/eb/distinfo4
-rw-r--r--japanese/eb/files/patch-configure10
-rw-r--r--japanese/eb/files/patch-eb::match.c20
-rw-r--r--japanese/eb/pkg-plist90
5 files changed, 69 insertions, 84 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 5339465109d3..d1206750932a 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= eb
-PORTVERSION= 3.3
-PORTREVISION= 2
+PORTVERSION= 3.3.1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
- ftp://ftp.eos.hokudai.ac.jp/pub/network/ndtp/eb/
+ ftp://ftp.eos.hokudai.ac.jp/pub/net/ndtp/eb/
DISTFILES= ${EBFILES} \
${LISTFILES} \
${APPENDIXFILES}
EXTRACT_ONLY= ${EBFILES}
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${DISTNAME}+.diff ${DISTNAME}+2.diff
+#PATCHFILES= ${DISTNAME}+.diff ${DISTNAME}+2.diff
MAINTAINER= takamune@avrl.mei.co.jp
COMMENT= C library for accessing EB, EBG, EBXA and EPWING CD-ROM dictionaries
@@ -60,24 +59,22 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
DIST_SUBDIR= eb
USE_PERL5= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
- --enable-pthread \
- --with-pthread-cflags="${PTHREAD_CFLAGS}" \
- --with-pthread-ldflags="${PTHREAD_LIBS}" \
- --with-gettext-includes=${PREFIX}/include \
- --with-gettext-libraries=${PREFIX}/lib \
- --with-iconv-includes=${PREFIX}/include \
- --with-iconv-libraries=${PREFIX}/lib
+ --with-gettext-includes=${LOCALBASE}/include \
+ --with-gettext-libraries=${LOCALBASE}/lib \
+ --with-iconv-includes=${LOCALBASE}/include \
+ --with-iconv-libraries=${LOCALBASE}/lib
-APPENDIXDIR= ${PREFIX}/share/eb/appendix
+APPENDIXDIR= ${DATADIR}/appendix
post-extract:
- @${RM} -fr ${WRKSRC}/zlib
- @${MKDIR} ${WRKDIR}/appendix
+ ${RM} -fr ${WRKSRC}/zlib
+ ${MKDIR} ${WRKDIR}/appendix
.for file in ${APPENDIXFILES}
- @${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
+ ${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
${DISTDIR}/${DIST_SUBDIR}/${file}
.endfor
diff --git a/japanese/eb/distinfo b/japanese/eb/distinfo
index 2b9c7c3e312a..dd1f8eafa0eb 100644
--- a/japanese/eb/distinfo
+++ b/japanese/eb/distinfo
@@ -1,4 +1,4 @@
-MD5 (eb/eb-3.3.tar.gz) = cdf5439f2d0dd50709f44bac5ca7f3eb
+MD5 (eb/eb-3.3.1.tar.gz) = c06a9754eb244ba04f6d7ea3108cffb0
MD5 (eb/appendix/LIST) = 60c2a8b4b24edddef010255b20f1b0f4
MD5 (eb/appendix/LIST-ja) = 68d9baa8b90292da0ce552626670705f
MD5 (eb/appendix/cencro-1.0.tar.gz) = 1c93a68fae90990b631bd5302349d199
@@ -30,5 +30,3 @@ MD5 (eb/appendix/plus-2.0.tar.gz) = 4f03b6808fdd9032471b654b80e0c7a1
MD5 (eb/appendix/readers-2.2.tar.gz) = 73e27f0f9727a9e225117f4611257fb3
MD5 (eb/appendix/readers2-2.0.tar.gz) = 5125b2925c76291ee2c0c616a09217c4
MD5 (eb/appendix/superdic98-1.0.tar.gz) = cc38fde2e6d5b12dba6f494a8a979b03
-MD5 (eb/eb-3.3+.diff) = 6005ed01e9ff762eaa2f81a13793d964
-MD5 (eb/eb-3.3+2.diff) = 34fc5cab076b8c43deb9c2f127e9c75c
diff --git a/japanese/eb/files/patch-configure b/japanese/eb/files/patch-configure
new file mode 100644
index 000000000000..fc4571016d48
--- /dev/null
+++ b/japanese/eb/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Feb 7 18:20:16 2003
++++ configure Sun Feb 16 23:47:36 2003
+@@ -7535,6 +7535,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/japanese/eb/files/patch-eb::match.c b/japanese/eb/files/patch-eb::match.c
deleted file mode 100644
index 2ea79a73cb43..000000000000
--- a/japanese/eb/files/patch-eb::match.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- eb/match.c.orig Tue Aug 14 10:04:25 2001
-+++ eb/match.c Sat Mar 1 02:34:57 2003
-@@ -43,7 +43,7 @@
-
- for (;;) {
- if (length <= i) {
-- result = *word_p;
-+ result = 0;
- break;
- }
- if (*word_p == '\0') {
-@@ -92,7 +92,7 @@
-
- for (;;) {
- if (length <= i) {
-- result = *word_p;
-+ result = 0;
- break;
- }
- if (*word_p == '\0') {
diff --git a/japanese/eb/pkg-plist b/japanese/eb/pkg-plist
index 9467ea4b7667..b3b104196297 100644
--- a/japanese/eb/pkg-plist
+++ b/japanese/eb/pkg-plist
@@ -43,9 +43,9 @@ info/ebzip.info
@exec install-info %D/info/ebzip-ja.info %D/info/dir
@exec install-info %D/info/ebzip.info %D/info/dir
lib/libeb.a
-lib/libeb.la
lib/libeb.so
lib/libeb.so.7
+share/aclocal/eb3.m4
share/eb/appendix/LIST
share/eb/appendix/LIST-ja
share/eb/appendix/cencro-1.0/catalog
@@ -221,18 +221,8 @@ share/eb/appendix/superdic98-1.0/kanjigen.app
share/eb/appendix/superdic98-1.0/kanjigen/data/furoku
share/eb/appendix/superdic98-1.0/koujien.app
share/eb/appendix/superdic98-1.0/koujien/data/furoku
-share/locale/ja/LC_MESSAGES/eb.mo
-share/locale/ja/LC_MESSAGES/ebutils.mo
@dirrm share/eb/appendix/cencro-1.0/cencro
@dirrm share/eb/appendix/cencro-1.0
-@dirrm share/eb/appendix/genius-1.0/genius
-@dirrm share/eb/appendix/genius-1.0
-@dirrm share/eb/appendix/genius2-1.1/genius/data
-@dirrm share/eb/appendix/genius2-1.1/genius
-@dirrm share/eb/appendix/genius2-1.1
-@dirrm share/eb/appendix/gendai2000-1.0/gn00eb02
-@dirrm share/eb/appendix/gendai2000-1.0/gn00eb01
-@dirrm share/eb/appendix/gendai2000-1.0
@dirrm share/eb/appendix/chujiten-2.3/eiwa
@dirrm share/eb/appendix/chujiten-2.3/waei
@dirrm share/eb/appendix/chujiten-2.3
@@ -244,15 +234,15 @@ share/locale/ja/LC_MESSAGES/ebutils.mo
@dirrm share/eb/appendix/colloc-2.0/colloc/data
@dirrm share/eb/appendix/colloc-2.0/colloc
@dirrm share/eb/appendix/colloc-2.0
-@dirrm share/eb/appendix/crowngj-1.0/crger
-@dirrm share/eb/appendix/crowngj-1.0
-@dirrm share/eb/appendix/crownfj2-1.0/crfre
-@dirrm share/eb/appendix/crownfj2-1.0
@dirrm share/eb/appendix/crownfj-2.0/crown_fj/data
@dirrm share/eb/appendix/crownfj-2.0/crown_fj
@dirrm share/eb/appendix/crownfj-2.0/daily_ei/data
@dirrm share/eb/appendix/crownfj-2.0/daily_ei
@dirrm share/eb/appendix/crownfj-2.0
+@dirrm share/eb/appendix/crownfj2-1.0/crfre
+@dirrm share/eb/appendix/crownfj2-1.0
+@dirrm share/eb/appendix/crowngj-1.0/crger
+@dirrm share/eb/appendix/crowngj-1.0
@dirrm share/eb/appendix/daihyakka-1.0/dhk01
@dirrm share/eb/appendix/daihyakka-1.0
@dirrm share/eb/appendix/daijirin-2.0/dgx01/data
@@ -261,35 +251,43 @@ share/locale/ja/LC_MESSAGES/ebutils.mo
@dirrm share/eb/appendix/dd75-2.0/chujiten
@dirrm share/eb/appendix/dd75-2.0/koujien
@dirrm share/eb/appendix/dd75-2.0
+@dirrm share/eb/appendix/gendai2000-1.0/gn00eb01
+@dirrm share/eb/appendix/gendai2000-1.0/gn00eb02
+@dirrm share/eb/appendix/gendai2000-1.0
+@dirrm share/eb/appendix/genius-1.0/genius
+@dirrm share/eb/appendix/genius-1.0
+@dirrm share/eb/appendix/genius2-1.1/genius/data
+@dirrm share/eb/appendix/genius2-1.1/genius
+@dirrm share/eb/appendix/genius2-1.1
@dirrm share/eb/appendix/global-2.0/gejcje/data
@dirrm share/eb/appendix/global-2.0/gejcje
@dirrm share/eb/appendix/global-2.0
-@dirrm share/eb/appendix/heritage-2.2/roget
-@dirrm share/eb/appendix/heritage-2.2/dict
@dirrm share/eb/appendix/heritage-2.2/abbrev
@dirrm share/eb/appendix/heritage-2.2/bioentry
-@dirrm share/eb/appendix/heritage-2.2/geoentry
@dirrm share/eb/appendix/heritage-2.2/colleges
-@dirrm share/eb/appendix/heritage-2.2/root
+@dirrm share/eb/appendix/heritage-2.2/dict
+@dirrm share/eb/appendix/heritage-2.2/geoentry
@dirrm share/eb/appendix/heritage-2.2/info
+@dirrm share/eb/appendix/heritage-2.2/roget
+@dirrm share/eb/appendix/heritage-2.2/root
@dirrm share/eb/appendix/heritage-2.2
@dirrm share/eb/appendix/izumi-2.0/file1
@dirrm share/eb/appendix/izumi-2.0
-@dirrm share/eb/appendix/jitenban-2.4/mypaedia/data
-@dirrm share/eb/appendix/jitenban-2.4/mypaedia
-@dirrm share/eb/appendix/jitenban-2.4/iwakoku/data
-@dirrm share/eb/appendix/jitenban-2.4/iwakoku
-@dirrm share/eb/appendix/jitenban-2.4/chujiten/data
-@dirrm share/eb/appendix/jitenban-2.4/chujiten
@dirrm share/eb/appendix/jitenban-2.4/chiezo/data
@dirrm share/eb/appendix/jitenban-2.4/chiezo
+@dirrm share/eb/appendix/jitenban-2.4/chujiten/data
+@dirrm share/eb/appendix/jitenban-2.4/chujiten
+@dirrm share/eb/appendix/jitenban-2.4/iwakoku/data
+@dirrm share/eb/appendix/jitenban-2.4/iwakoku
+@dirrm share/eb/appendix/jitenban-2.4/mypaedia/data
+@dirrm share/eb/appendix/jitenban-2.4/mypaedia
@dirrm share/eb/appendix/jitenban-2.4
-@dirrm share/eb/appendix/jitenban97-2.1/iwakoku/data
-@dirrm share/eb/appendix/jitenban97-2.1/iwakoku
-@dirrm share/eb/appendix/jitenban97-2.1/chujiten/data
-@dirrm share/eb/appendix/jitenban97-2.1/chujiten
@dirrm share/eb/appendix/jitenban97-2.1/chiezo/data
@dirrm share/eb/appendix/jitenban97-2.1/chiezo
+@dirrm share/eb/appendix/jitenban97-2.1/chujiten/data
+@dirrm share/eb/appendix/jitenban97-2.1/chujiten
+@dirrm share/eb/appendix/jitenban97-2.1/iwakoku/data
+@dirrm share/eb/appendix/jitenban97-2.1/iwakoku
@dirrm share/eb/appendix/jitenban97-2.1/mypaedia/data
@dirrm share/eb/appendix/jitenban97-2.1/mypaedia
@dirrm share/eb/appendix/jitenban97-2.1
@@ -300,18 +298,18 @@ share/locale/ja/LC_MESSAGES/ebutils.mo
@dirrm share/eb/appendix/kanjigen2-2.0
@dirrm share/eb/appendix/kojien-2.3/kojien
@dirrm share/eb/appendix/kojien-2.3
-@dirrm share/eb/appendix/kojien2-2.0/koujien/data
-@dirrm share/eb/appendix/kojien2-2.0/koujien
@dirrm share/eb/appendix/kojien2-2.0/furoku/data
@dirrm share/eb/appendix/kojien2-2.0/furoku
+@dirrm share/eb/appendix/kojien2-2.0/koujien/data
+@dirrm share/eb/appendix/kojien2-2.0/koujien
@dirrm share/eb/appendix/kojien2-2.0
-@dirrm share/eb/appendix/kojien4-2.2/koujien
@dirrm share/eb/appendix/kojien4-2.2/furoku
+@dirrm share/eb/appendix/kojien4-2.2/koujien
@dirrm share/eb/appendix/kojien4-2.2
+@dirrm share/eb/appendix/oxford-2.0/about
@dirrm share/eb/appendix/oxford-2.0/oxford
@dirrm share/eb/appendix/oxford-2.0/quick
@dirrm share/eb/appendix/oxford-2.0/user
-@dirrm share/eb/appendix/oxford-2.0/about
@dirrm share/eb/appendix/oxford-2.0
@dirrm share/eb/appendix/plus-2.0/plus/data
@dirrm share/eb/appendix/plus-2.0/plus
@@ -321,20 +319,22 @@ share/locale/ja/LC_MESSAGES/ebutils.mo
@dirrm share/eb/appendix/readers2-2.0/readers/data
@dirrm share/eb/appendix/readers2-2.0/readers
@dirrm share/eb/appendix/readers2-2.0
-@dirrm share/eb/appendix/superdic98-1.0/koujien/data
-@dirrm share/eb/appendix/superdic98-1.0/koujien
-@dirrm share/eb/appendix/superdic98-1.0/kanjigen/data
-@dirrm share/eb/appendix/superdic98-1.0/kanjigen
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep03/data
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep03
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep02/data
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep02
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep01/data
-@dirrm share/eb/appendix/superdic98-1.0/gn98ep01
-@dirrm share/eb/appendix/superdic98-1.0/furoku/data
-@dirrm share/eb/appendix/superdic98-1.0/furoku
@dirrm share/eb/appendix/superdic98-1.0/chujiten/data
@dirrm share/eb/appendix/superdic98-1.0/chujiten
+@dirrm share/eb/appendix/superdic98-1.0/furoku/data
+@dirrm share/eb/appendix/superdic98-1.0/furoku
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep01/data
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep01
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep02/data
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep02
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep03/data
+@dirrm share/eb/appendix/superdic98-1.0/gn98ep03
+@dirrm share/eb/appendix/superdic98-1.0/kanjigen/data
+@dirrm share/eb/appendix/superdic98-1.0/kanjigen
+@dirrm share/eb/appendix/superdic98-1.0/koujien/data
+@dirrm share/eb/appendix/superdic98-1.0/koujien
@dirrm share/eb/appendix/superdic98-1.0
@dirrm share/eb/appendix
@dirrm share/eb
+share/locale/ja/LC_MESSAGES/eb.mo
+share/locale/ja/LC_MESSAGES/ebutils.mo