aboutsummaryrefslogtreecommitdiff
path: root/japanese/emacs-emcws
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:08:52 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:08:52 +0000
commit0b1020495087240f21a4fa421e92e457fc065310 (patch)
treea9275c6a984cfec29d075da9a46c02652d31293e /japanese/emacs-emcws
parent656da512bff3c98531096fb649085c714a884a31 (diff)
downloadports-0b1020495087240f21a4fa421e92e457fc065310.tar.gz
ports-0b1020495087240f21a4fa421e92e457fc065310.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Notes
Notes: svn path=/head/; revision=53956
Diffstat (limited to 'japanese/emacs-emcws')
-rw-r--r--japanese/emacs-emcws/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index bf834ab8f26b..97cd04822a94 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -164,13 +164,13 @@ do-install:
@test -d ${PREFIX}/share/emacs/${EMACS_VER}-emcws/site-lisp || \
${MKDIR} ${PREFIX}/share/emacs/${EMACS_VER}-emcws/site-lisp
@if [ ! -f ${PREFIX}/share/emacs/${EMACS_VER}-emcws/site-lisp/subdirs.el ]; then \
- (${ECHO} "(if (fboundp 'normal-top-level-add-subdirs-to-load-path)"; \
- ${ECHO} " (normal-top-level-add-subdirs-to-load-path))") \
+ (${ECHO_CMD} "(if (fboundp 'normal-top-level-add-subdirs-to-load-path)"; \
+ ${ECHO_CMD} " (normal-top-level-add-subdirs-to-load-path))") \
> ${PREFIX}/share/emacs/${EMACS_VER}-emcws/site-lisp/subdirs.el ; \
fi
@if [ ! -f ${PREFIX}/share/emacs/${EMACS_VER}-emcws/lisp/subdirs.el ]; then \
- (${ECHO} "(if (fboundp 'normal-top-level-add-subdirs-to-load-path)"; \
- ${ECHO} " (normal-top-level-add-subdirs-to-load-path))") \
+ (${ECHO_CMD} "(if (fboundp 'normal-top-level-add-subdirs-to-load-path)"; \
+ ${ECHO_CMD} " (normal-top-level-add-subdirs-to-load-path))") \
> ${PREFIX}/share/emacs/${EMACS_VER}-emcws/lisp/subdirs.el ; \
fi