aboutsummaryrefslogtreecommitdiff
path: root/japanese/emacs-emcws
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-10 17:19:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-10 17:19:56 +0000
commit33ee2fced505dd6566ddaa343efaba45be2f4690 (patch)
tree7b9a13c34c3eb99f59ada17891e75c4969ad4660 /japanese/emacs-emcws
parent6c6d54379fd794e68eb01f55a0a00d75f31a8e8d (diff)
downloadports-33ee2fced505dd6566ddaa343efaba45be2f4690.tar.gz
ports-33ee2fced505dd6566ddaa343efaba45be2f4690.zip
- Fix build with recent Xaw3d
PR: ports/85821 Submitted by: NAKAJI Hiroyuki <nakaji@jp.freebsd.org> (maintainer)
Notes
Notes: svn path=/head/; revision=142366
Diffstat (limited to 'japanese/emacs-emcws')
-rw-r--r--japanese/emacs-emcws/Makefile2
-rw-r--r--japanese/emacs-emcws/files/patch-src:xterm.c42
2 files changed, 43 insertions, 1 deletions
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index c6218980fa48..b50ea1150465 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emcws
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= japanese editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
diff --git a/japanese/emacs-emcws/files/patch-src:xterm.c b/japanese/emacs-emcws/files/patch-src:xterm.c
new file mode 100644
index 000000000000..01ec93bec95e
--- /dev/null
+++ b/japanese/emacs-emcws/files/patch-src:xterm.c
@@ -0,0 +1,42 @@
+--- src/xterm.c.orig Tue Oct 15 23:21:45 2002
++++ src/xterm.c Wed Aug 31 09:18:48 2005
+@@ -118,8 +118,6 @@
+ #ifdef HAVE_XAW3D
+ #include <X11/Xaw3d/Simple.h>
+ #include <X11/Xaw3d/Scrollbar.h>
+-#define ARROW_SCROLLBAR
+-#include <X11/Xaw3d/ScrollbarP.h>
+ #else /* !HAVE_XAW3D */
+ #include <X11/Xaw/Simple.h>
+ #include <X11/Xaw/Scrollbar.h>
+@@ -8863,30 +8861,12 @@
+ XawScrollbarSetThumb (widget, top, shown);
+ else
+ {
+-#ifdef HAVE_XAW3D
+- ScrollbarWidget sb = (ScrollbarWidget) widget;
+- int scroll_mode = 0;
+-
+- /* `scroll_mode' only exists with Xaw3d + ARROW_SCROLLBAR. */
+- if (xaw3d_arrow_scroll)
+- {
+- /* Xaw3d stupidly ignores resize requests while dragging
+- so we have to make it believe it's not in dragging mode. */
+- scroll_mode = sb->scrollbar.scroll_mode;
+- if (scroll_mode == 2)
+- sb->scrollbar.scroll_mode = 0;
+- }
+-#endif
+ /* Try to make the scrolling a tad smoother. */
+ if (!xaw3d_pick_top)
+ shown = min (shown, old_shown);
+
+ XawScrollbarSetThumb (widget, top, shown);
+
+-#ifdef HAVE_XAW3D
+- if (xaw3d_arrow_scroll && scroll_mode == 2)
+- sb->scrollbar.scroll_mode = scroll_mode;
+-#endif
+ }
+ }
+ }