aboutsummaryrefslogtreecommitdiff
path: root/japanese/emacs-emcws
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-10 06:11:29 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-10 06:11:29 +0000
commitc4024739fb8d994b5d61d6ce137379b6e3b4515a (patch)
tree7b2ab04b79876b4d6eb6cde69e0f3a038c20bb81 /japanese/emacs-emcws
parent5daf5dd5672e05946f8a405b7dc9e9a3766ab7dc (diff)
downloadports-c4024739fb8d994b5d61d6ce137379b6e3b4515a.tar.gz
ports-c4024739fb8d994b5d61d6ce137379b6e3b4515a.zip
Make this port compile clean when specifying another ${PREFIX}.
PR: 61071 Submitted by: Munehiro Matsuda <haro@h4.dion.ne.jp> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=97843
Diffstat (limited to 'japanese/emacs-emcws')
-rw-r--r--japanese/emacs-emcws/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index ab5be349efc3..bb39c08d9aca 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -146,6 +146,12 @@ CONFIGURE_ARGS+= --with-xpg4
.endif
.endif
+.if exists(${PREFIX}/bin/emacs-${EMACS_VER})
+EMACS_BASE=${PREFIX}
+.else
+EMACS_BASE=${LOCALBASE}
+.endif
+
pre-fetch:
@${CAT} ${FILESDIR}/emcws-message
@@ -153,7 +159,7 @@ pre-build:
${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
${RM} -rf ${WRKSRC}/info/*
@(cd ${WRKSRC}/src/../lisp; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} compile-files EMACS=${LOCALBASE}/bin/emacs-${EMACS_VER})
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} compile-files EMACS=${EMACS_BASE}/bin/emacs-${EMACS_VER})
@(cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} emacs)
@(cd ${WRKSRC}/src/../lisp; \
${WRKSRC}/src/emacs -batch -q -f batch-byte-compile \